Hi !!


I am currently messing around with MTK GPS stuff and the binary protocol.

Assuming my APM2.0 GPS has the 1.6 loaded, i want to upgrade the GPS FW. Since the gps is directly mounted to the mainboard i don't know how to do it.

The APM wiki http://code.google.com/p/ardupilot/wiki/MediaTek gives no hints.

Please help!

So long

Kraut Rob

EDIT: SOLUTION FOUND:

UPDATE 12/28/2012

I included a zip file with all the needed files and a complete guide below.

It contains basically the same files than the previous version but an extended guide and the source code.

UPDATE 12/28/2012

Added German guide.

UPDATE 19/01/2013

FTDI Hardwareflash on APM 2.0 (Set your FTDI to 5V, if you have one of these Breakoutboards)

1. Download the zip below to have all the files needed - and a flashguide.

2. Load MP and save all your parameters to a file (if desired).

3. Do Arduino / eeprom clear on your main CPU so that no serial traffic can disturb the process. Do not omit this step. It won't work with the arduino still talking on the serial line - i tested it. P.s. You can also use the precompiled hex from my post here: https://diydrones.ning.com/xn/detail/705844:Comment:1094234

4. Unpower APM for soldering. If FTDI connection is already established, powercycle to reset GPS to its' default state.

5. Locate the external GPS port (UART1). If you have not the right plug (like me) you have some solder pads right behind it. You will need GND/RX/TX. Look at this picture for the right connection: http://diydrones.com/forum/attachment/download?id=705844%3AUploaded...

Note: I labeled RX and TX relative to the GPS not the CPU (like printed on the PCB). I showed 3 points where you can get access to the important datalines, besides the obvious connectionport (that would be number 4:)).

6. Power APM Board, fire up the flashing soft and follow the documentation -> Point 8 in MTKFlashGuide2.pdf or point 7 in MTKFlashGuide2German.pdf. Reading the complete pdf is also ok.

7. Reload Arducopter FW on mainboard and reload your saved settings (if desired). Perhaps recheck calibrations (ACC etc.)

8. Done.

UPDATE 21/01/2013 - 02/03/2013

Here is a Must Try List - if you have a persisting flash problem (Thanks Anton for the idea)

- https://diydrones.ning.com/xn/detail/705844:Comment:1094071  (Thanks Anton)

- https://diydrones.ning.com/xn/detail/705844:Comment:1094290  (Thanks William Stoner)

- http://diydrones.com/xn/detail/705844:Comment:1097033       (Thanks Isaac)

- http://www.diydrones.com/xn/detail/705844:Comment:1097725 (Thanks Chris Webb // Mac running VMWare WinXP)

- https://diydrones.ning.com/xn/detail/705844:Comment:1140259 (Thanks "exaustgas" // Win serial port)

- http://diydrones.com/xn/detail/705844:Comment:1146635 (Thanks Cody // serial port in flashutil config)

- Try to rule out a driver/win firewall/administrator/viruskiller thing

UPDATE 02/03/2013

Due to the outstanding work of Perecastor here: https://diydrones.ning.com/xn/detail/705844:Comment:1149155

We have a French guide now as well !!

I took the liberty to put it here as well.

UPDATE 21/05/2013

Hardware - "Hack":

Use your PC - RC Transmitter Adaptercable as FTDI:

http://diydrones.com/xn/detail/705844:Comment:1252901 (Thanks Jan Boermans)

Cheers

Rob

Views: 35627

Attachments:

Reply to This

Replies to This Discussion

I removed the reset jumper I needed for updating the MTK...but I do have JP1 in place (for powering both rails from the same source).  Would that make a difference for uploading through arduino?  I've always left that in before.  Also, I never power the APM through battery when I have USB connected.

Which "cables" did you have in mind?  I'm currently hooked up to my RC receiver and to the ESC's...but again, I've always left those connected in the past and never had any problems programming the APM.

I thought of this cable: http://diydrones.ning.com/forum/topics/please-help-how-can-i-flash-...

or maybe some ftdi - leftover.

Just letting you know that I followed your instructions exactly (I have zero Arduino experience) and everything worked. Thanks!

Two anomalies, one you covered. I did require the "reset jumper" for my APM 2.5. The strange one was when I went back and reloaded MP. It would not connect using the Connect button. I eventually clicked on the Quad 2.9 FW icon anyway and it loaded, even with the MP (v1.2.32) button still offering me to connect. This must be a slight MP issue as it clearly had connected with the proper bit rate etc. So if this happens to someone else, just try loading the FW anyways.

Thank you very much for your feedback, Craig!

It is normal that hitting the connect button in missionplaner while the simple passthrough program is running does nothing because when you hit connect it wants to connect to a mavlink sending source (the apm FW). I think that is also outlined in the wiki "setting up" or so. So you did right and clicked on the symbol representing your model. After the correct FW was installed on your apm the connect button on the mp finds a nice mavlink-sending-source and works again :) .

Cheers

Kraut Rob

Yeah, that makes perfect sense. I forgot about the passthrough prog in the APM, was thinking of the MTK prog only...

I need help. I can get as far as the power flash then I get "no com port detected". I did EEPROM clear and power cycle tryed the jumper nothing works

So you are doing the direct ftdi - version. A FTDI hardware adapter must be found by your computer. If you are updating your mtk via software there is no use for eeprom clear, except you install UpdateGPSBlinky.hex or UpdateGPS.hex afterwards..... like in my howto pdf described..

I'm trying via software I tryed both gpsupdate.hex and blinky.hex then power cycle. The mtk exe works but powerflash won't

Hmm, did you try antons trick: http://diydrones.ning.com/forum/topics/please-help-how-can-i-flash-...

or the "cable" (like in pdf or alternatively: http://diydrones.ning.com/forum/topics/please-help-how-can-i-flash-...) ?

Windows problem? Firewall? Administrator?

Hard to say...

If I leave mtk software running then I can select the com port in powerflash but it won't download I just get that big red X. What could I check on my firewall?
And I haven't tryed the ftdi cable way because I don't have one

I disabled the firewall completely - that's my non-internet machine.

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service