Hi !!

I am currently messing around with MTK GPS stuff and the binary protocol.

Assuming my APM2.0 GPS has the 1.6 loaded, i want to upgrade the GPS FW. Since the gps is directly mounted to the mainboard i don't know how to do it.

The APM wiki http://code.google.com/p/ardupilot/wiki/MediaTek gives no hints.

Please help!

So long

Kraut Rob


UPDATE 12/28/2012

I included a zip file with all the needed files and a complete guide below.

It contains basically the same files than the previous version but an extended guide and the source code.

UPDATE 12/28/2012

Added German guide.

UPDATE 19/01/2013

FTDI Hardwareflash on APM 2.0 (Set your FTDI to 5V, if you have one of these Breakoutboards)

1. Download the zip below to have all the files needed - and a flashguide.

2. Load MP and save all your parameters to a file (if desired).

3. Do Arduino / eeprom clear on your main CPU so that no serial traffic can disturb the process. Do not omit this step. It won't work with the arduino still talking on the serial line - i tested it. P.s. You can also use the precompiled hex from my post here: https://diydrones.ning.com/xn/detail/705844:Comment:1094234

4. Unpower APM for soldering. If FTDI connection is already established, powercycle to reset GPS to its' default state.

5. Locate the external GPS port (UART1). If you have not the right plug (like me) you have some solder pads right behind it. You will need GND/RX/TX. Look at this picture for the right connection: http://diydrones.com/forum/attachment/download?id=705844%3AUploaded...

Note: I labeled RX and TX relative to the GPS not the CPU (like printed on the PCB). I showed 3 points where you can get access to the important datalines, besides the obvious connectionport (that would be number 4:)).

6. Power APM Board, fire up the flashing soft and follow the documentation -> Point 8 in MTKFlashGuide2.pdf or point 7 in MTKFlashGuide2German.pdf. Reading the complete pdf is also ok.

7. Reload Arducopter FW on mainboard and reload your saved settings (if desired). Perhaps recheck calibrations (ACC etc.)

8. Done.

UPDATE 21/01/2013 - 02/03/2013

Here is a Must Try List - if you have a persisting flash problem (Thanks Anton for the idea)

- https://diydrones.ning.com/xn/detail/705844:Comment:1094071  (Thanks Anton)

- https://diydrones.ning.com/xn/detail/705844:Comment:1094290  (Thanks William Stoner)

- http://diydrones.com/xn/detail/705844:Comment:1097033       (Thanks Isaac)

- http://www.diydrones.com/xn/detail/705844:Comment:1097725 (Thanks Chris Webb // Mac running VMWare WinXP)

- https://diydrones.ning.com/xn/detail/705844:Comment:1140259 (Thanks "exaustgas" // Win serial port)

- http://diydrones.com/xn/detail/705844:Comment:1146635 (Thanks Cody // serial port in flashutil config)

- Try to rule out a driver/win firewall/administrator/viruskiller thing

UPDATE 02/03/2013

Due to the outstanding work of Perecastor here: https://diydrones.ning.com/xn/detail/705844:Comment:1149155

We have a French guide now as well !!

I took the liberty to put it here as well.

UPDATE 21/05/2013

Hardware - "Hack":

Use your PC - RC Transmitter Adaptercable as FTDI:

http://diydrones.com/xn/detail/705844:Comment:1252901 (Thanks Jan Boermans)



Views: 35664


Reply to This

Replies to This Discussion

Ok thanks for the info! I'm going to try this after i get my quad properly tuned first.

Regards Jani

Would it be my com port on my pc. It's set to 9600 or does that not matter?

Try to set to 38K baud or higher then. My are set to 115K under windows.

i do have same problemm, but on the device list, it shows under com3 "arduino mega 2560",

and there is no way i can change baud rate or other setting to this com port from the device manager

then the com port do not appear on the flash application,

any ideas to try ?



In device manager under com ports, double click the port your APM is on.  It will open the properties for that port.  Select the port setting tab, then the advanced radio button.  Near the bottom of the window, there will be a drop down list you can select to assign a different com port.  I had problems when I used Com 3.  My computer also has a COM 1.  In the days before Plug and Play they used the same interrupt and that could trip you up.

Use the drop down list to set it to some unused com port...I arbitrarily chose Com 10.

Be sure to change it in Mission Planner too.

Thanks for your reply , i have been struggling for two days with the issue now .


it seams something is different on my setup ,

this is what i got from device manager, then i cant change any parameter or com port assigment,


this is the config that shows up when inserting the 3dr wireless adapter .

So the problem is with the usb cable connected to the apm2, and the driver asociated to it , but i dont really know what else to try.


when i try to cennect with the wireless link, it shows the com port on the flash tool , but then gaves an error


[Flash Download]
     Fail!!(Download)   BROM_CMD_START_FAIL
     Take(3) secs to test.

I finally got mine updated. Here's what I did
1-upload gpsblinky.hex via mission planner
2 power cycle apm2.0
3 connect jumper on 5v output rail to reset pin near USB port on apm
4 power apm via output rail with a esc
5 open power flash and select all the right hex files
6 hit connect and the download
After you hit download then plug in the USB cable.
I had to hit download a few times before it would go but it worked.

Thanks for all the help

Do you have your usb cable directly connected to the APM usb in ,

if so , how your computer is not showing the arduino 2560 driver ?, have you disabled this usb driver, in order to let the pc assign the FTDI driver to this port ?


Thought I would share my process as well as I hit a small snag with the com port, may be because I run Windows XP SP3 in a VM.

My Gear:

APM 2.5

Mediatek 2.0

Note: Only power source via USB.

System: Mac Pro running VMWare Fusion with a Windows XP VM.

1. Upload UpdateGPS.hex to APM using Mission Planner
2. Cycle power on APM 
3. Test with miniGPS, working on COM 3
4. Connected the jumper http://diydrones.ning.com/xn/detail/705844:Comment:1094290
. Opened PowerFlash.exe

  - Bumped into a snag here COM 3 was not being listed under ComPort

  - Went to working directory for PowerFlash.exe and modified Powerflash.ini
  - Then skipped com portion of step 13 but still set the Update Baudrate

6. Followed the rest of the steps for PowerFlash and it worked perfectly.

7. Confirmed firmware update with MiniGPS

I downloaded and followed the directions in the first post. Everything worked as described for me.

Windows XP. APM2.5

Thank you very much "Kraut Rob" for the effort you put into this tutorial.


Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service