Hi !!


I am currently messing around with MTK GPS stuff and the binary protocol.

Assuming my APM2.0 GPS has the 1.6 loaded, i want to upgrade the GPS FW. Since the gps is directly mounted to the mainboard i don't know how to do it.

The APM wiki http://code.google.com/p/ardupilot/wiki/MediaTek gives no hints.

Please help!

So long

Kraut Rob

EDIT: SOLUTION FOUND:

UPDATE 12/28/2012

I included a zip file with all the needed files and a complete guide below.

It contains basically the same files than the previous version but an extended guide and the source code.

UPDATE 12/28/2012

Added German guide.

UPDATE 19/01/2013

FTDI Hardwareflash on APM 2.0 (Set your FTDI to 5V, if you have one of these Breakoutboards)

1. Download the zip below to have all the files needed - and a flashguide.

2. Load MP and save all your parameters to a file (if desired).

3. Do Arduino / eeprom clear on your main CPU so that no serial traffic can disturb the process. Do not omit this step. It won't work with the arduino still talking on the serial line - i tested it. P.s. You can also use the precompiled hex from my post here: https://diydrones.ning.com/xn/detail/705844:Comment:1094234

4. Unpower APM for soldering. If FTDI connection is already established, powercycle to reset GPS to its' default state.

5. Locate the external GPS port (UART1). If you have not the right plug (like me) you have some solder pads right behind it. You will need GND/RX/TX. Look at this picture for the right connection: http://diydrones.com/forum/attachment/download?id=705844%3AUploaded...

Note: I labeled RX and TX relative to the GPS not the CPU (like printed on the PCB). I showed 3 points where you can get access to the important datalines, besides the obvious connectionport (that would be number 4:)).

6. Power APM Board, fire up the flashing soft and follow the documentation -> Point 8 in MTKFlashGuide2.pdf or point 7 in MTKFlashGuide2German.pdf. Reading the complete pdf is also ok.

7. Reload Arducopter FW on mainboard and reload your saved settings (if desired). Perhaps recheck calibrations (ACC etc.)

8. Done.

UPDATE 21/01/2013 - 02/03/2013

Here is a Must Try List - if you have a persisting flash problem (Thanks Anton for the idea)

- https://diydrones.ning.com/xn/detail/705844:Comment:1094071  (Thanks Anton)

- https://diydrones.ning.com/xn/detail/705844:Comment:1094290  (Thanks William Stoner)

- http://diydrones.com/xn/detail/705844:Comment:1097033       (Thanks Isaac)

- http://www.diydrones.com/xn/detail/705844:Comment:1097725 (Thanks Chris Webb // Mac running VMWare WinXP)

- https://diydrones.ning.com/xn/detail/705844:Comment:1140259 (Thanks "exaustgas" // Win serial port)

- http://diydrones.com/xn/detail/705844:Comment:1146635 (Thanks Cody // serial port in flashutil config)

- Try to rule out a driver/win firewall/administrator/viruskiller thing

UPDATE 02/03/2013

Due to the outstanding work of Perecastor here: https://diydrones.ning.com/xn/detail/705844:Comment:1149155

We have a French guide now as well !!

I took the liberty to put it here as well.

UPDATE 21/05/2013

Hardware - "Hack":

Use your PC - RC Transmitter Adaptercable as FTDI:

http://diydrones.com/xn/detail/705844:Comment:1252901 (Thanks Jan Boermans)

Cheers

Rob

Views: 35663

Attachments:

Reply to This

Replies to This Discussion

here is the translation in french :

Attachments:

Perecastor! You are the man! Thank you very much for taking the time and doing the French translation! So including the openoffice source file was a good idea after all :) !

I will add it to the main post!

What a community!!

Perhaps someone is able to do another language?

Thank you!

Cheers

Roberto

Hello. I have Mediatek 3329 v2.0 module with APM 2.5. I want to try 2.9.1. Do i need to flash GPS firmware to 1.9? The factory shipped firmware version is AXN1.50_2366_3329_96.1151100.1.bin as shown on the site link. How is GPS 1.9 firmware performance compared to the GPS factory shipped firmware? I am pretty satisfied with the performace with 2.8.1. Has anybody tried it with 2.9.1? Has anybody tried it?

I flashed my APM 2.0 onboard GPS firmware from 1.6 to 1.9.

I know its not necessary to flash the GPS firmware for 2.9.1 but it is said that it performs better than GPS firmware version 1.6. The only problem is that GPS firmware version 1.9 doesn't work with 1.6. Am i right?

I think i can reflash the GPS with the default 1.6 firmware if i like? Is it so?

Thats a lot of mixed up stuff in your post.

APM 2.9.1 = MTK 1.6 & MTK 1.9 support

APM 2.8.1 = MTK 1.6 support

APM 2.8.1 Tuned = MTK 1.6 & MTK 1.9 support (http://diydrones.com/xn/detail/705844:Comment:1141353)

MTK can be flashed in both ways anytime.

woot! got this to work finally. used the apm2.5 as the programmer for my external GPS and follwed the excellent instructions and it worked perfectly - even resurrected the one I thought was perma-bricked. Now have 2 MTK2.0s updated to the 1.9 firmware. Look slike my problems were due to the FTDI I was using. Thanks guys!

You are welcome! Do you have some information why the FTDI method failed on you or what FW seemed to have bricked your mtk? I want to link it to the "must try list".

Thank you very much for your flattering reply!

Cheers Kraut Rob

Same with my APM2

Thx for sharing. had click download 10-12 Times

I did receive 3 weeks ago my combo APM2.5 with Mediatek MT3329 GPS.

It is the GPS flashed with 1.9 as default from factory?

I have managed to update both my MTK 3329 GPSs with the new firmware by using the FDTI. I have tried many different methods to do it on APM1 but it never works.

When I connect the GPS with the FDTI cable and connect the miniGPS module I get a GPD 3D fix in about 30 seconds now.  I couldn't believe how fast it is and this is only from my balcony where I only have half view of the sky. I get around 7 satellites when ti gets the fix.

However!! (yes there is a "however" still) Once I mount the GPS to my copter and APM1 board, it usually takes around 20-30min to get GPS lock.  I tried change back to the FDTI cable and again it connects in about 30 seconds. But when I put it back onto the AMP1 board it still takes over 20min each time.

I even tried it on my Openpilot CC board and same result, about 20min or more to get a fix

Any idea why this happens? how can I fix this?

Hi John!

I think there is some serious disturbance - source on your copter. Otherwise such a discrepancy is not explainable. Even the worst code in the world, configuring your mtk in the worst possible way could not produce a difference between 30sec and 30 min.

Try the following:

Do your bestcase gps - szenario: Just the gps with ftdi and computer. So the gps fix is done in no time.

Now powerup your quad and move it near the GPS (15 cm?) and find a distance to the GPS when it is disturbed (longer fixtime, lowered dB etc). You can even try pointing different "arms" of your copter to the gps - perhaps it is possible to locate the source. At least you will now the distance needed to put your gps away from the copter to make it work undisturbed. So building a little pole, ensuring that distance, could help you.

Cheers Kraut Rob

Thanks for your reply Rob. The thing is this is the normal position I have been using it on this quad for over a year, and before the update of this new firmware it would take about 5 to 10min to lock in (out in the field that is and some time a bit longer than that on my balcony) and did have some good gps fix even then with the old firmware.

As you can see in the photo its pretty clear from any of the items that might give of a lot of dirty RF. This is it mounted with the Openpilot cc board, but i had same result with the APM1 board mounted on this as well.

Ill do your test just to be sure, but I cant see this being the problem.

@John: I see. For testing you can always flash back to the original mtk fw - i think openpilot will use it in nmea mode anyway, so the advantage of the more precise binary protocol will not come at play there - but the faster response to movement should be an improvement. From my own painful gps experience with mtk AND ublox i can assure you that you have some interference going on. Maybe they are more evident with a different mtk fw. The STM 72Mhz is a real RF pig, from what i see on my Naze. After a lot of struggle i came up with a solution that works for me. 1. I put a ferrite around the GPS cable (not shure if that helped, but i had one lying around). 2. I build a groundplate (with very poor workmanship skills) that is mounted with zipties in the center of the copter. Here are some pictures of the disaster that works very well:

http://fpv-treff.de/download/file.php?id=3072&mode=view

http://fpv-treff.de/download/file.php?id=3071&mode=view

http://fpv-treff.de/download/file.php?id=3070&mode=view

My first setup, that was also an improvement. It consisted of these little screw boxes you have from the hardwarestore. I put the gps into it and stuck some aluminium foil below it and mounted it with zipties above the center. That looked like this: http://fpv-treff.de/download/file.php?id=2955&mode=view

Here are also some good links that helped me:

http://diydrones.com/forum/topics/how-to-gps-shield

http://diydrones.com/forum/topics/arducopter-2-5-released?commentId...

http://autoquad.org/wiki/wiki/autoquad-hardware-connections/gps-gro...

Cheers

Kraut Rob

Reply to Discussion

RSS

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service