Hi !!

I am currently messing around with MTK GPS stuff and the binary protocol.

Assuming my APM2.0 GPS has the 1.6 loaded, i want to upgrade the GPS FW. Since the gps is directly mounted to the mainboard i don't know how to do it.

The APM wiki http://code.google.com/p/ardupilot/wiki/MediaTek gives no hints.

Please help!

So long

Kraut Rob


UPDATE 12/28/2012

I included a zip file with all the needed files and a complete guide below.

It contains basically the same files than the previous version but an extended guide and the source code.

UPDATE 12/28/2012

Added German guide.

UPDATE 19/01/2013

FTDI Hardwareflash on APM 2.0 (Set your FTDI to 5V, if you have one of these Breakoutboards)

1. Download the zip below to have all the files needed - and a flashguide.

2. Load MP and save all your parameters to a file (if desired).

3. Do Arduino / eeprom clear on your main CPU so that no serial traffic can disturb the process. Do not omit this step. It won't work with the arduino still talking on the serial line - i tested it. P.s. You can also use the precompiled hex from my post here: https://diydrones.ning.com/xn/detail/705844:Comment:1094234

4. Unpower APM for soldering. If FTDI connection is already established, powercycle to reset GPS to its' default state.

5. Locate the external GPS port (UART1). If you have not the right plug (like me) you have some solder pads right behind it. You will need GND/RX/TX. Look at this picture for the right connection: http://diydrones.com/forum/attachment/download?id=705844%3AUploaded...

Note: I labeled RX and TX relative to the GPS not the CPU (like printed on the PCB). I showed 3 points where you can get access to the important datalines, besides the obvious connectionport (that would be number 4:)).

6. Power APM Board, fire up the flashing soft and follow the documentation -> Point 8 in MTKFlashGuide2.pdf or point 7 in MTKFlashGuide2German.pdf. Reading the complete pdf is also ok.

7. Reload Arducopter FW on mainboard and reload your saved settings (if desired). Perhaps recheck calibrations (ACC etc.)

8. Done.

UPDATE 21/01/2013 - 02/03/2013

Here is a Must Try List - if you have a persisting flash problem (Thanks Anton for the idea)

- https://diydrones.ning.com/xn/detail/705844:Comment:1094071  (Thanks Anton)

- https://diydrones.ning.com/xn/detail/705844:Comment:1094290  (Thanks William Stoner)

- http://diydrones.com/xn/detail/705844:Comment:1097033       (Thanks Isaac)

- http://www.diydrones.com/xn/detail/705844:Comment:1097725 (Thanks Chris Webb // Mac running VMWare WinXP)

- https://diydrones.ning.com/xn/detail/705844:Comment:1140259 (Thanks "exaustgas" // Win serial port)

- http://diydrones.com/xn/detail/705844:Comment:1146635 (Thanks Cody // serial port in flashutil config)

- Try to rule out a driver/win firewall/administrator/viruskiller thing

UPDATE 02/03/2013

Due to the outstanding work of Perecastor here: https://diydrones.ning.com/xn/detail/705844:Comment:1149155

We have a French guide now as well !!

I took the liberty to put it here as well.

UPDATE 21/05/2013

Hardware - "Hack":

Use your PC - RC Transmitter Adaptercable as FTDI:

http://diydrones.com/xn/detail/705844:Comment:1252901 (Thanks Jan Boermans)



Views: 35651


Reply to This

Replies to This Discussion

Still no luck with this.  I will try using an Arduino as a pass-through to try to get PowerFlash to recognize the COM port.

Hi Guys, here is how I got my APM 2.0 updated to the 1.9 firmware via USB:

1. Use Mission planner to change the Arduino firmware to make it an FTDI adapter for the GPS (in the download .zip at the beginning of the thread)

2. Connect via USB, go to device manager, right click on the "Arduino Mega 2560", properties, "port settings", "advanced". Change the comport to anything other than 1-3. I made mine 10. Hit OK, then change Bits per second to 38,400. 

3. Unplug and plug back in the APM.

4. Hook up a jumper cable between as shown in this picture. I used a female-female cable I got at Radio Shack. 

5. Open the mini GPS utility and make sure it connects on your selected com port. Close that down.

6. Open the power flash utility and follow the directions in the .PDF. I had to try twice. The first time it failed, the second time I tried it worked. 

Hope this helps. 

Don't forget to change your comport settings back to 115k

My reason for doing this was an attempt to make the GPS get a lock faster as has been a known issue with APM 2.0. After doing this I got in lock in less than a minute, indoors. 

@Cody: Did you have success in the meantime?

Thank you very much for sharing your solution, i will add it to the must try list!


Kraut Rob

It work perfectly. Thks a lot.

I am always glad to hear that it actually works so thank you for your feedback, Ralph!

If i knew how i would start a poll:

a) FW Update worked with no problems.

b) FW Update worked but was a pain.

c) FW Update didn't work and i tried everything.


Kraut Rob

I did, admittedly by reading a few pages back.

The COM port used for the first GPS persisted in the config file.  Changing the config file to the correct COM port for the second GPS fixed the problem.

It's like PowerFlash doesn't bother to check for new ports after you use it for the first time.  No problem though, easy fix!

I have a second APM 2.0 and tried this same procedure. I got it work after pressing download about 8 times. I have no idea why it would be intermittent, but whatever. If you get a fail message, try it a few times before looking elsewhere. 

Oh, and power cycle the board by disconnecting the USB before reloading the APM firmware back on. Mission Planner wouldnt recognize the device until I did that....I think the powerflash utility was still using the com port or something even though I closed the window? Not sure, just power cycle. 

It's the MTK power flash tool.  It's like that even when you are running stand alone w/o the GPS attached to the APM.

Interesting finding! I will add it to the must try list!

Glad that it finally worked...

Ahas anyone successfully flashed 1.9 onto the 3DR Mtek v2 add on GPS? I gave it a try and appear to have bricked one. I get to the point of doing the flash and get the red progress bar but not the blue one and that's it. The GPS is now unresponsive - solid blue light and no response to any commands.

Thanks to you for sharing this how to and thanks to the guy who made possible to convert the mega 2560 into a ftdi cable ! What's his name?

It took me 10 minutes for upgrading my GPS ^^ 

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service