Hi !!


I am currently messing around with MTK GPS stuff and the binary protocol.

Assuming my APM2.0 GPS has the 1.6 loaded, i want to upgrade the GPS FW. Since the gps is directly mounted to the mainboard i don't know how to do it.

The APM wiki http://code.google.com/p/ardupilot/wiki/MediaTek gives no hints.

Please help!

So long

Kraut Rob

EDIT: SOLUTION FOUND:

UPDATE 12/28/2012

I included a zip file with all the needed files and a complete guide below.

It contains basically the same files than the previous version but an extended guide and the source code.

UPDATE 12/28/2012

Added German guide.

UPDATE 19/01/2013

FTDI Hardwareflash on APM 2.0 (Set your FTDI to 5V, if you have one of these Breakoutboards)

1. Download the zip below to have all the files needed - and a flashguide.

2. Load MP and save all your parameters to a file (if desired).

3. Do Arduino / eeprom clear on your main CPU so that no serial traffic can disturb the process. Do not omit this step. It won't work with the arduino still talking on the serial line - i tested it. P.s. You can also use the precompiled hex from my post here: https://diydrones.ning.com/xn/detail/705844:Comment:1094234

4. Unpower APM for soldering. If FTDI connection is already established, powercycle to reset GPS to its' default state.

5. Locate the external GPS port (UART1). If you have not the right plug (like me) you have some solder pads right behind it. You will need GND/RX/TX. Look at this picture for the right connection: http://diydrones.com/forum/attachment/download?id=705844%3AUploaded...

Note: I labeled RX and TX relative to the GPS not the CPU (like printed on the PCB). I showed 3 points where you can get access to the important datalines, besides the obvious connectionport (that would be number 4:)).

6. Power APM Board, fire up the flashing soft and follow the documentation -> Point 8 in MTKFlashGuide2.pdf or point 7 in MTKFlashGuide2German.pdf. Reading the complete pdf is also ok.

7. Reload Arducopter FW on mainboard and reload your saved settings (if desired). Perhaps recheck calibrations (ACC etc.)

8. Done.

UPDATE 21/01/2013 - 02/03/2013

Here is a Must Try List - if you have a persisting flash problem (Thanks Anton for the idea)

- https://diydrones.ning.com/xn/detail/705844:Comment:1094071  (Thanks Anton)

- https://diydrones.ning.com/xn/detail/705844:Comment:1094290  (Thanks William Stoner)

- http://diydrones.com/xn/detail/705844:Comment:1097033       (Thanks Isaac)

- http://www.diydrones.com/xn/detail/705844:Comment:1097725 (Thanks Chris Webb // Mac running VMWare WinXP)

- https://diydrones.ning.com/xn/detail/705844:Comment:1140259 (Thanks "exaustgas" // Win serial port)

- http://diydrones.com/xn/detail/705844:Comment:1146635 (Thanks Cody // serial port in flashutil config)

- Try to rule out a driver/win firewall/administrator/viruskiller thing

UPDATE 02/03/2013

Due to the outstanding work of Perecastor here: https://diydrones.ning.com/xn/detail/705844:Comment:1149155

We have a French guide now as well !!

I took the liberty to put it here as well.

UPDATE 21/05/2013

Hardware - "Hack":

Use your PC - RC Transmitter Adaptercable as FTDI:

http://diydrones.com/xn/detail/705844:Comment:1252901 (Thanks Jan Boermans)

Cheers

Rob

Views: 35657

Attachments:

Reply to This

Replies to This Discussion

sorry for my English which is translated by google :-)

I was able to successfully update the onboard GPS in my 2.0,
but in the few tests I have done the results are always disappointing
for this GPS, loiter mode of the sealing portion is poor and
still does not hold the position, I think I'm better off
in the configuration of pid and maybe I best results, someone did
a few videos to see what results you can get with APM 2.0 and
GPS updated to 1.9?
Thanks again for your work :-)

Like many, I was excited by the release of the 2.9 version software.  So, I started down the path of doing the upgrade.  I've hit a full stop on this aspect of things.

I'm trying to update the firmware on the MediaTek 3329 GPS on my APM 2.0 hardware.  It appears that MP loads the pass through firmware just fine.  MTK_MiniGPS sees the GPS, shows satelites, will show firmware revisions and allow changes to the settings.

I follow the directions to run the flash tool, and it doesn't matter what I do, I get "BROM_CMD_START_FAIL".

I've changed com ports, I've tried both versions of pass through, I've run the program as admin, I've moved the directories and changed them from read only status.  I've cleared the EEPROM prior to the flash for the pass through, I've even held the device in reset as advised in the manual.  I've tried on another computer.  I have been completely unsuccessful at getting the firmware to flash.

Voltage to the GPS module is 3.313V and the module is on the daughter board soldered to the APM board.

Any ideas?

Firewall,antivirus,windows 7 or 8 instead xp......when i did this on XP sp3 i turned of firewall and antivirus...also i had newest Mission planer 1.2.32.also i we first upload 2.9.....i am no expert just try to help with ideas....

After you load the pass through program, you need to connect the DTR line to +5V.
Randy posted an image of where to put the jumper awhile back

http://diydrones.ning.com/xn/detail/705844:Comment:1067281

why not use software solution??

That was the trick!  I read this thread at least 4 times...don't know why I missed it.

I went for the external FTDI cable solution and soldered some leads onto the 3DR GPS module and used an FTDI cable to flash the GPS. It failed on the first attempt with the BROM... error but worked the second time :-) Thanks, now the Hexa has a slightly better GPS module, just need to get some good weather to try it out.

Ok now i'm little confused. Can someone clarify few things? :

  • This update is also for APM 1 [2560] with MTK3329 V1.2 and 2.9+ arducopter firmware?
  • If above is yes for APM1 , only way to update is using ftdi cable?
  • What is this update actually do? Force SBAS [Egnos support?] on? What else?

As i'm living in north Europe(64° Latitude = Finland) i don't have very good chance to catch any support for WAAS or even Egnos. From different sources i found there's possibility to have 3 EGNOS satellite in view, but it's difficult because of those are so low angle in horizon:

EGNOS - PRN 120 - Inmarsat 3F2 (AOR-E 15.5°W) Garmin 33
EGNOS - PRN 124 - Artemis (21.5°E) Garmin 37
EGNOS - PRN 126 - Inmarsat 3F5 (25.0°E) Garmin 39

Some sources in Finland are saying that it's actually better to turn off WAAS and SBAS support here if possible? I'm not sure what to do now...

-Jani-

 

I was having trouble getting the update to work.  I tried this jumper and still no go.  At this point I had tried every other method and kept getting the big red "X".  Out of frustration I started clicking the connect and download buttons in sequence and suddenly it started to do the update.  I have no ideas why this worked but the update was finally successful. 

I left the Mini GPS tool running and it got a fix indoors where it never had before after about 5 minutes.

Thanks a lot for preparing your nice instruction package, and for doing all the work to figure it out for us.

Now I haven't actually used your instructions yet, will try after I update my APM FW to 2.9, but I have a basic question: is 1.9 FW required to be used with APM 2.9 ? IOW is it optional (and preferred), but will APM 2.9 still work with GPS FW 1.6 ? Thanks. I like to do things one step at a time to make sure each step works or that I know where the problem is...

Hi Graham, thank you for the hint! My "3DR GPS MTK V2.0" works with MiniGPS but not flashing. After connecting it AFTER clicking Download button it work! I think this hint should be added to "must try" list :) And I have used UpdateUSBBlinky, thank you Kraut!

APM 2.9 will understand mtk1.6 as well. So it is not a must-have.

Reply to Discussion

RSS

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service