I wondered if anyone could enlighten me what is going on here.

When I plug in my APM 2.5, 3.01 to my Rx using PPM the channels are mixed up... ie the Throttle =Roll,

Yaw=Yaw, Pitch=Throttle, Ail=Pitch  the switches are fine.

Everything works the way it should when plugged in PWM, the channel mixup only happens when using (trying to use ) PPM.

I have reloaded PPM encoder firmware, used different TXs and Rxs etc to no avail.( same thing happens)

Tx radios I have are Graupner Mc32 and Jr 9x with dragon link V2

I fly Mode 2. 

Thanks in advance.

Views: 11098

Reply to This

Replies to This Discussion

When using PPM the channel order matters, as you gave found. APM2.5 uses the AETR sequence as standard. That's Aileron, Elevator, Throttle, Rudder. What mode Transmitter and make do you have? In the new firmwares you can remap the channels in APM, but there are some things to be cautious of.


I did mention I use a Graupner Mc32 and a JR 9x with a Dragon Link. Mode 2

The Graupner Mc32 Tx lets you change mode configurations to Mode 1,2,3 or 4.

I have tried everything I can think of....its probably something I am overlooking. Though I have been over

the manual a hundred times : ).

What do you mean "you can revamp the channels in APM" ? 

See http://copter.ardupilot.com/wiki/arducopter-parameters/#RCMAP__Para...

The mode is related to the throttle being on the left or right. The PPM signal can be outputted in different channels orders, i.e AETR (i think this us futaba default) on my OpenTx firmware i changed it to do this sequence, can you change it on your graupner? Its seems its RETA as default (this is the JR default, i believe).

thanks Bill

It seems ( from what I can see ) the RCMAP_Parameters are only avail in Helicopter firmware...maybe wrong here but I cant see it anywhere in the Multirotor firmware Parameter list.

I can channel map my Graupner MC32, however I want to use my JR 9X with the Dragon Link. I can only change Modes in the 9x radio but cant customise it other than Mode 1,2,3 or 4.

It would be good to do all the config in the APM 2.5 and leave the Tx alone.

I think the parameters autogen script is not working properly again. If you connect using mission planner and go to full parameter view, you will see what options are available for a particular firmware version.

Here is the solution to the channel mapping issues having to do with moving the PPM signal from the DragonLink to the Pixhawk or other APM based flight controller.

In the full parameter list of APM Planner 2, look for RCMAP.  Therein lies the Pitch, Roll, Throttle, and Yaw Configuration.
By changing to these parameters, all is right with the world.
RCMAP_Pitch 3
RCMAP_Roll 2
RCPAMP_Throttle 1

If you remap channels on the APM2.5/6 and using PPM please bypass the PPM encoder, otherwise failsafe will work incorrectly

see http://plane.ardupilot.com/wiki/arduplane-parameters/#RCMAP__Parame...

see http://copter.ardupilot.com/wiki/common-apm25-and-26-overview/#Expl... on how to bypass the onboard PPM encoder

I had the same problem with pixhawk, trying to connect to a Dragonlink receiver. I had to remap as follows:

- Pitch 3

- Roll 2

- Throttle 1

- Yaw 4

and had to assign a different switch to the flight modes on the DX8, so I can see now during RC calibration on Mission Planner each channel now corresponds to the right stick, so all good up to there.

But now when not in RC calibration I have no servo movement and I have Failsafe on Flight Data window, you are right Bill ion that Failsafe won't work correctly. When I turn off my DX8 the failsafe goes away.

I'm sure failsafe needs to be set differently, everything else seems to be fine.

I read the links but really doesn't explain how to set failsafe for pixhawk when using PPM after remapping the channels.

Any detailed explanation will be highly appreciated!!

Exactly the same problem here after remapping the channels it appears that the failsafe is reversed i.e when i activate failsafe (995 on channel 1 remap for throttle) the pixhawk behaves as if it has a good throttle signal and is ready for flight if i go above the threshold  lets say 1500 failsafe is activated.

i am remapping because i am using a dx7s with a dragonlink system

I'm still having the exact same problem. Anyone have clues? should we post somewhere else to get more replies? I'm pretty sure someone have found the trick, this should be a rather common setup. Help!

Have you guys found a solution to this yet. The channel mapping makes sense but I need the failsafes to work. Have you guys tried what Bill Bonney said about disabling the ppm encoder? I've read it 10 times and still Have no idea how to disable it. I might just have to buy a 9xr as getting any descent direction here is almost impossible. Let me know if you guys have had any luck.

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service