I have about 7 flights on my Bixler 2 and every time I've flown I haven't been able to discharge the batteries more than 1Ah out of 2.2Ah, before the low voltage cutoff begins to regulate my throttle.  Also the resting voltage of the battery packs after each flight is around 11.7v compared to around 9.6-10 for a fully discharged 3S Lipo battery .

 I believe the ESC is programmed properly for 3 cell's its an E-Flight 30A (EFLA1030) but through all of the beeping it gets kinda fuzzy.  

Could the APM have anything todo with the improper discharging?

I've been using Turnigy 2200mAh 3S 25C with only 2 cycles on them since I've purchased them. I know they can output more capacity, from my previous experience with Turnigy 2200mAh 3S 20C which I had but about 20 cycles on before seeing any degradation in capacity and those were discharged at 38 Amps in my Stryker.

Any thoughts on what the problem could be?

Flight times:      8-10 Min

Static current : 12-13(A) without APM installed

 

Thanks for the help

 

 

Views: 280

Reply to This

Replies to This Discussion

Does the mAh capacity imputed into mission planner have any control over the motor when using the power monitor for voltage and current?

Looks like it's my speed control causing the problem, I'll be using a spare to test if it is the speed control or not. Post to follow!

Was finally able to diagnose with a known working speed control, seemed that the one I have is programmed improperly or is now faulty. Ordered a backup ESC while I work on this one.  

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service