Hi

Two of my customers have trouble setting up the Pixhawk - I myself have a Pixhawk, but don't use a Futaba receiver, thereby I can't replicate the problem (I would like to find out if the problem is connected to the receiver they use, or something else).

Both use a Futaba R7008SB receiver.
Both managed to upload the Firmware to their Pixhawks - but they are not able to do the radio calibration (the Pixhawk doesn't "see" the receivers, the bars in the calibration are all grey).

They have nothing else connected to the Pixhawk, except receiver (connected to the right port / RC), buzzer, safety switch and USB cable.

The Pixhawk signals via the big LED "pre-arm check failed" (which makes sense ;)

They power the Pixhawk via USB and at the same time with a LiPo (via the Power Module).

The receiver is "found" by the remote, the LEDs are on, the setting of receiver and remote (regarding the use of the SBUS) seems to be right. They use the right port of the receiver to connect to the Pixhawk.

I am happy about any suggestions ...

Thanks a lot in advance

Felix

Views: 40461

Reply to This

Replies to This Discussion

I understand your point xian, but for the sake of a $25 ppm encoder you could be flying today whilst we are waiting for the sbus to be incorporated into stable.

Yep, I agree, really not so bad to use the encoder.  

I was able to get the SBus working with one of the firmwares, haven't had time to look at this project again, but I bought the encoder and now I can use it with any firmware, no need to worry about the SBus

It might be irritating not getting something to work the way you (Xian06) had hoped, but no reason to throw away a good controller just because one small problem.  I bet you are going to have another 1000 problems before you get to fly well or fly at all.  If you are going to want to throw the controller at the wall or sell it everytime a problem comes up then you aren't going to get very far.  I bet you every controller on the market has some kind of issue.  You could always buy a DJ and have a fly-away on SBus :)

I went through exactly the same thing when this happened to me so I know how you feel.  I started reading up on the other controllers and I decided to buy the encoder.  The rest are just not as good as this controller, from my research.  Not to say that I did great research so you will need to go through that yourself.

Pixhawk 3.1.5 equal with APM 2.6.

So Pixhawk software not released yet and I think do not release 3.2 this year(too much bugs).

Pixhawk hardware good but need 1-2 years to software use it.

I am using the 14sg and 7008sb on a 3Dr Aero and it works fine. I cant get the 7008sb to even work on arducopter latest version even with a PPM encoder? Any thoughts as to why?

Hello Aaron, which modus did you select for the R700SB? You can select different mods by holding the small swith when powering the RX. The red LED will flash:

1x when in mode 1

2x when in mode 2

etc. I believe there are 4 mods. Mode 1 is the right one.

I tried everything I could find on the net. I followed the directions to set the mode but it always stayed in mode 1/A. Had it plugged into ch8/ sbus and also tried sbus2. nothing worked. I ended up buying a r2008sb and it works great. maybe I will use it on my next copter or plane.  

Plug a ubec into the rc in on pixhawk. The lead from ppm encoder goes to sbus on hawk. I had the safe issue

Dear Martin,

At last I got a PPM encoder and it started working now. But only on one condition, after each power on I have to press the Pixhawk reset switch for some time!!!! Then its start working. Do you suspect any firmware issues????

Thank you

Madhuraj

Hi Madhuraj,

Great to hear from you and im glad to gear things are improving! When you refer to the reset switch are you talking about the fmu reset switch located next to the USB port on the side of the pixhawk or the safety switch?
This is the switch port you can see at the centre of the Pixhawk. I is the between the telemetry and serial ports,
thanks
Madhuraj
Hi madhuraj,
No problems, that's the safety switch! You are required to depress the switch each time you arm the copter, it has 3 light displays. Quick and constant blinking is it performing a system check, just wait until it finishes- it should then go to slow constant blinking meaning that it is ready to arm. You should only need to press it for a few seconds if you have waited until the checks have been completed. It will then go to solid red meaning that it is ready to arm on your transmitter. Sometimes it will take a long time to arm as it performs the pre arm checks, especially if you are trying to take off in a gps assisted mode as it will wait until the gps is up and running (30secs or so). If so try arming in stabilise but do give it time before going to GPS assist modes. I always arm in stabilise but check GPS status beforehand. You can disarm the safety checks in mission planner but I do not recommend it unless you are well aware of the system, it is there to look after you!
Hope it goes well, let me know if you have any issues,

Martin
Dear Martin,
Thank you very much for the reply. I will get back to you after my flight...
Thank you
Madhuraj

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service