since I updated the firmware compatible with MAV10, I systematically to boot the message "Update CharSet". I have to do a reset to miniOSD, to boot properly. I works with APM2
Has anybody a solution?

Views: 918

Reply to This

Replies to This Discussion

I am having the exact same problem. Updated my miniOSD yesterday and keep getting "Update CharSet"

Even after i update the charset with the most recent one on the download page.

When you upload the charset did you have the video section powered?

There are a few threads on this problem, and I think it comes down to load power when the charset is uploaded.

In another thread, the upload charset section of the firmware is taken out and then you woun't ever get the message, but won't be able to update the charset with taht firmware.



Hi and thanks for the reply :)

Im heading home now and ill try having the video section powered while updating (it wasnt before)

ill post my results.

I tried having the video section connected (and powered) and loading both firmware and charset.

I still get the message "update charset".

If i disconnect the tx/rx between the miniosd and apm2, I get a message "waiting for heartbeats" and the version of arducam osd is v1.9

Both firmware and charset seem to load correctly. I get a popup window after loading firmware saying done!

And the bottom message board in OSD_Config says the charset upload is done.

Im officially out of ideas. Got anything for me to try out ?

On the wiki, it says there can be issues writing the charset if the voltage powering the minimosd is not exactly 5 volts.

So basically, we know it just didn't actually write it even though the status said it did.

If i disconnect the tx/rx between the miniosd and apm2, I get a message "waiting for heartbeats" and the version of arducam osd is v1.9

Actually, that is the exact expected behavior. Because of the code running on the 328p, when it's waiting for mavlink, it's not decoding mavlink and doesn't need the charset. When you send it packets, it goes to the running part of the code and then displays the error message when it checks the charset.

The wiki states the solution is to try an alternate power source as if it's not perfect then there are errors(your exact situation). Thus, I got the feeling your 5 volt power on the FTDI input side is the one thing you haven't changed when trying to resolve this. ( I could be wrong, I just didn't see you saying you changed the 5 volt source).

Max7456's internal memory is really picky about voltage level during a charset update. Usually it happens with some PCs with lower USB voltage. The only way to fix that is updating the charset by feeding the board properly. Just making sure it has around 5V there. E.g.: tying the two stages and feeding it by a external battery on the video IO pins.

Again, I would try a direct usb port with no hub, try a totally different USB port, try a different computer, and then maybe try the external power as a last resort. I'm just thinking the 328P is acting as a passthrough when it's using it's output pins to write to the OSD IC. Thus this is logical that low power into the 328p would equal lower write voltages because there is always a loss through the 328p on an output pin (we can't beat physics). It might be just within spec at 5 volts and at maybe 5-10% tolerance on the low side of usb power is actuallly more than 10% tolerance going "through" the 328p to the other IC.

I went through the same sequence today when I also updated my firmware to the mavlink 1.0. The difference is mine worked via my 5 volt FTDI cable and no more issues.

Thanks Barry for the response.

Your spot on, that i have not tried another power source (unless plugging in the 12v on the video side).

I am using this to connect to the OSD board:

I have not been looking into other ways of powering the board while updating the charset, because i have not run into any errors while running the update. There are no error messages and the message bar indicates that the update is done.

Its running late here in Iceland, but ill try out another power source tomorrow, and keep you guys posted.

The help is very much appreciated :)

Nothing wrong with the in and of itself, but in this application, the loss through the cable, the connectors, the wires between it and the minimosd might be on that fine line.


I feel the best fix is fix the power. I think you will find that it didn't take the charset upload.

That being said, this link from a while back has a work around.

Burt Green

Hi again.

I connected an external 5.09 power supply to the OSD and tried updating the firmware and charset yet again (i measured the voltage from the breakout board and it turned out to be 4.95v).

But the same thing happens as i boot her up. "update charset" is the message. And when i hit the reset button, it reboots and gives me the "waiting for heartbeats" after the reboot.

I will try some other values of voltage, but I am not hopeful, since the voltage is well within the  5-10% error margin of 5v. 

Anyone else has been dealing with similar problems ?

Sorry, that sucks. What if you go back to mavlink 0.9 firmware and try the charset?

Just curious if it's a firmware problem or a hardware/voltage problem?


Just to be sure, your problem is the "update charset"? 

After the reboot that message is normal, It waiting for the APM to start sending MavLink messages.

If you can't get it working after reboot, Are you connected correctly? RX on the MiniOsd goes to the Serial TX out on the APM.

Next, do you have the correct firmware on the OSD, If you have the most recent APM firmware, you need the firmware on the OSD for the Mavlink 1.0.

If you can a display after you reboot the OSD after the "update charset" message then, here is a hex file that should by pass that message. It is from this tread, only change was to bypass the upload charset.

Gábor Has put a lot of work into this.

Burt Green 


Thank, no problem with your bypass

Reply to Discussion


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service