[Resolved] No throttle control on arducopter 2.9.1, quadcopter 3DR, APM2.5

Update 19/02/2013: problem has been resolved. See discussions below for conclusion.

Hello,
I am in a dead end that frustrates me to the point I might give up soon...any help welcome.
I have not yet flown my new quad that I try to finalize for weeks now,learning step by step how to solve the hidden road blocks. Except this time I am at a road block I can't resolve and do not find any info on the wiki.
This is the issue:
-I am at the stage where I have apparently succesfully calibrated the ESCs until step 6 of the wiki automatic calibration procedure
-After that if i turn on the quadcopter again and I arm it with the throttle stick bottom right for 4 seconds,then comes the issue:
Any throttle stick position make the four motors turn at a constant speed (except full down where motors stop). It is as if the throttle stick would be an on/off switch.
If i connect one esc directly to channel 3 of the receiver,then stick works as expected.
So is it a defect on my APM board,not able to send variable pulses to the output rail? is it a problem with 2.9.1?
(i was in stabilize mode)

Any advice/ help please!
Hugues

Views: 10924

Replies to This Discussion

Hugues,

    Ah, the issue is your Rate P values are about 100x bigger than they should be.  The default is 0.150 but it looks like it's currently 11.25.

     If you haven't tested your copter yet, I think you should probably disable the sonar for the first few flights as well to keep things simple.

     Also be sure to do a stabilize flight and check the accelerometer values (especially Z) before trying out alt hold.  (and remember to disable the RAW messages after you're done your test 'cuz it eats a lot of CPU).

Thank you so much Randy!
Indeed i wanted to reduce P rate as described in the wiki by one step of 25% because i'm using 880kv motors with 11x4.7 props. But instead of typing 0.1125 i made the mistake of typing 11.25!!

For the vibrations ,see my last blog post,I have very good results with a suspended system.
You're the man !
For information, there is a bug in the mission planner, pid config screen: when you type in a number with a comma, it apparently displays it right ( for ex 0,112) but then if you display the advanced list parameters it shows 11,2!
I am using a numeric keypad on a BE french configured keyboard.
Maybe a notice should be given on the wiki.

which exact value of P there is alot of P s ... cause I have the same problem 

Hi Hugues,

Could you solve your problem? I have the same problem I haven't found the solution!

Thanks.

Hello,

Yes this was solved long ago (1.5 years ago!). The issue was my P rate was on a value of 11 instead of 0.11 (100 times too much).

I just reverted to the default PID values in mission planner and problem was solved.

Im having the same issues as in Hugues video posted earlier , Im  using the 1.

3.17  mission and arducopter  3.2 . I cant seem to find where the PID settings are in Mision planner in this 1.3.17 although I see under config / tuning and full paremeter  list there at PID settings there but default  for throttle  all seem normal see attached file . Any ideas anyone , seems Hugues issues were solved by PID settings but Im not sure Im in the correct location to check mine

Attachments:

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service