Problems with DJI E600 ESC / Motors not starting together with PixHawk

I have a new Hex platform I just built and this is the first time I've used the PixHawk.

I'm using the DJI E600 ESCs and Motors.

When I arm and slightly increase throttle, not all the motors are starting at the same time.

When I increase the throttle, the ones that started last are running slower than the rest.

If I leave them running on low throttle, the slow ones eventually slow down and stop.

I've tried to calibrate the DJI E600 ESCs to the Pixhawk, but they won't calibrate.

This apparently is correct as the DJI E600 OPTO ESC do not require calibration and so they won't allow a calibration to run.  Love to hear you thoughts on this as well!!

I have flight tested everything today and its flying great once its in the air.

When Im going to take off I can see the platform tilt towards the slower motors until it lifts.

I've taken a video on my work bench with the props removed trying to show what I'm talking about.

You can view it here: https://www.youtube.com/watch?v=rkcmp7wbZTE 

Any help / Advice on this issue?

Has anyone else run the DJI E600 system on a PixHawk?

Thanks

Views: 2410

Reply to This

Replies to This Discussion

i plan to built a Tarot 680 Pro with DJI E800 kits but my concern is same as your since i plan to use Pixhawk FC and how do we calibrate for DJI motors

Hope somebody can answer to our concerns

Bill

It looks like we may have a solution.

I'm doing some testing and will keep my results updated here: 

http://charlottefpv.com/topic/problems-with-dji-e600-esc-motors-not...

Cool keeping an eye on your post when you do your first fly testing, please report back on your post 

Thank you

Bill

Had this "Issue" also. This caused wobbly take offs and sometimes flip overs on takeoff. I fixed this changing the following params: MOT_SPIN_ARMED and THR_MIN. I found these when I realized my props did not spin up when I armed the copter. Now that being said.. I still get the occasional time where I press the safety button after plugging in the battery and the ESCs start up at different times. The "start up beeps" are not synced.. Not sure whats going on there but the copter flys perfect now. 

MOT_SPIN_ARMED to 200
THR_MIN to 200

Slightly different to my values, but the same idea.

When I get time, I want to try different settings.

See: http://charlottefpv.com/topic/problems-with-dji-e600-esc-motors-not... 

Can anyone share their starting PID values for the E800 kit with an extended Tarot 680pro? 

I have been and are still having the same problem. I'm running dji e800 on pixhawk px4 with my motors stopping also.
I am running apm planner on a Mac and I can't find the paramaters you suggested to change.
MOT-SPIN-ARED. I only have standard params.
Oh sorry also using taranis plus radio.
For abound 4 months I've been trying to get it all working, each time getting closer and closer.
So to get to the point of havering the motors just to spin got me excited like you wouldn't believe.
I have no hair left!
Please can someone help!!

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service