PX4 + Mission Planner Initial Setup - Can't connect!

Hi All,

I just received my PX4 and PX4IO kit, and am trying to get the autopilot up and running - following this guide to the letter: http://copter.ardupilot.com/wiki/common-load-firmware-px4/

I've successfully used Mission Planner to successfully update (multiple times, confirmed by the files on the SD card saying it started up OK) the firmware in both the PX4 and PX4IO.

It's really interesting that I can update the firmware for the PX4FMU via Mission Planner, however, the issue I keep running into is actually connecting to the board via USB afterwards through the COM port. It just says "Trying to Connect" with the countdown timer, and then will eventually time out if I let the counter run. Tried assigning different COM ports in Windows. Here's the Windows Port Settings:

Bits Per Second: 115200

Data Bits: 8

Parity: None

Stop Bits: 1

Flow Control: None

I've tried uninstalling and reinstalling the COM driver, tried powering through an external hub as I've read that could sometimes cause this issue.

I'm using Mission Planner 1.2.64 mav 1.0, Arducopter 3.0.1 Y6, through a Parallels Desktop Win7 64-bit virtual machine on my latest gen Macbook Pro.

I didn't purchase the 3DR Telemetry radios to go along with it, so I can't try to connect via radio at the moment (regretting not buying those radios now).

------

Well now this just gets frustrating. I've managed to get it to connect randomly 2-3 times, seemingly by changing the Flow Control to either Xon/Xoff or Hardware. Have not gotten it to connect ever set to "None". But after disconnecting and trying to reconnect, (disconnecting the USB and reconnecting it too), it won't come back.

Any advice?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • The same trouble here - but for me the powered hub workaround solves the problem.

    Maybe there is some problem with power usage declaration in the USB device descriptor?

  • Tried another windows machine (32bit Win7 on a HP tower).

    Same issues. Oddly, the COM port would get forced to 9600 baud by Windows, and if I would change the windows setting to 115200, it would revert back to 9600 immediately after I hit OK and then reopened the window.

    Oddly, I got it to connect a few times at 9600 set in Mission Planner on that machine!

    And, back once again to my main Virtual Machine, I got it to connect once at 115200 baud via an external hub..... but then couldn't get it to reconnect again anytime after that.

    I've also tried supplying power via the PX4IO input also with no luck.

  • Ian,

    Did you try to connect after reboot the px4fmu. I had a similar issue and i successfully connected after reboot the px4fmu

    Cheers,

    Aytek

This reply was deleted.

Activity

DIY Robocars via Twitter
Friday
DIY Robocars via Twitter
RT @_JonMyer: 🏎 We need your help in naming my #AWS DeepRacer Underground Track 🏎 @davidfsmith's track is going to be referred to as 𝗔𝗪𝗦 𝗗…
Thursday
DIY Robocars via Twitter
RT @gclue_akira: 仕事もおわったし、電脳化にとらい #マリオカートハック https://t.co/4IU90hCLgm
Thursday
DIY Robocars via Twitter
This is the hashtag to follow all the people in Japan who are hacking the new Nintendo Mario Kart with the real AR… https://twitter.com/i/web/status/1319281354664677376
Thursday
DIY Robocars via Twitter
RT @gclue_akira: @chr1sa @diyrobocars jupyter mario https://t.co/P0oHdjlCRq
Thursday
DIY Robocars via Twitter
RT @_JonMyer: 🚨Our 1st AWS DeepRacer Community Race is Underway on http://twitch.tv/aws 🚨 Join us to find out which member of your commu…
Oct 20
DIY Robocars via Twitter
Oct 19
DIY Robocars via Twitter
RT @BackyardRobotcs: After an admittedly long wait, the new Tinymovr R3.3 motor controller is now available https://tinymovr.com 🥳
Oct 19
DIY Robocars via Twitter
RT @_JonMyer: 🏎 1 hr left before the #AWS #DeepRacer Community 🏎 Top 5 Race tomorrow LIVE on Twitch 1st Place = $50 Amazon GC or AWS Credit…
Oct 19
DIY Robocars via Twitter
Oct 16
DIY Robocars via Twitter
Oct 15
DIY Robocars via Twitter
Oct 14
DIY Robocars via Twitter
RT @davidfsmith: Race virtually with The AWS DeepRacer Community Race and then join us on the track to see how your times compare on the ph…
Oct 14
DIY Robocars via Twitter
Oct 14
Hiroki Tanaka liked Hiroki Tanaka's profile
Oct 13
DIY Robocars via Twitter
RT @breadcentric: It's now!
Oct 13
More…