I have a Quad that I've been flying for about a year. Flight controller is PixHawk. I updated to v3.4.4 about a month ago. I autotuned PITCH and ROLL successfully and made several flights since then.

Yesterday I had a flyaway. Luckily there was no harm other than to the Quad itself. I was able to recover it a couple of miles away thanks to the telemetry link that stayed alive until after the crash.

Flight was as follows: I used my RC transmitter to take off in stabilize mode and then moved to AltHold as I usually do once the copter reached a few meters altitude. I then switched to Loiter mode and attempted to correct the position of the copter (pitch/roll) that appeared to be drifting due to a light wind. I immediately noticed that the copter was not reacting to my pitch/roll inputs so I attempted an RTL. The copter didnt seem to react to the RTL command either so I moved to Land but still no reaction.

The copter kept climbing until I lost sight of it. Fortunately, the telemetry link was working and allowed me to follow the path that the copter was taking. I attempted to command RTL from Mission Planner and made a few tries to control the copter using Guided mode on the map but still no luck. The copter kept climbing steadily (and drifting presumably in the direction of the winds).

Batteries started to run out about 10 min after take off and the copter started to descend. It eventually crashed a couple of miles away. I managed to recover it in reasonable shape given the circumstances.

I'm looking for some help in understanding the reason for the failure. Attached is the dataflash log (zipped due to the 7MB upload limit) with the hope that someone may be able to shed some light.

I'm a novice and never really looked at logs before. I did manage to find my RCIN Roll Input right after take off but didnt see it having any effect on the ATT Desired Roll. Is there anything in the log that could help explain that?

I also noticed that CTUN.DAlt became "NaN" quite early in the flight. Would that explain why the copter kept climbing? What could be the reason for that?

I'm not sure whether this is relevant, but I did make 2 changes to the parameters right before the flight. One change was to the FENCE altitude (increased from 50m to 80m). I also changed the RTL speed to 1000.

I will appreciate any help and/or pointers to information that may help me get to the root cause of the failure.



Views: 394


Reply to This

Replies to This Discussion

A year ago, almost to the day....does this give you any insights?


Thank you for the pointer! I looked through that thread and it looks different at first sight. His log shows DAlt constantly increasing. In my case, ~10 seconds after take off, DAlt becomes an invalid value (denoted as NaN="Not a Number" in the log).

I did follow the suggestion to check vibration levels as per http://ardupilot.org/copter/docs/common-measuring-vibration.html and my numbers (~<20m/s/s) seem to be well within the acceptable range.

Mossbackfarm said:

A year ago, almost to the day....does this give you any insights?


Just to let everyone looking at this thread know that this problem has been root caused and solved in 3.4.6.

See http://discuss.ardupilot.org/t/copter-3-4-6-released/15803



Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service