i have built a quad

APM 2.6

4x sunnysky 800kv

4x 11x4.7 props 

4x ESC Mystery 30A

dji 450 (clone)

lipo 11.1 3s 5500mah (brand Floureon)

+ sonar + optflow + 3rd radio

Total weight with GoPro + Gimbal + all of above, including battery: 1.87kg

as you see it quite lightweight...and initially i thought this was a little beast... given the small, light frame.. and first tests proved it had very lot of power... but now after ten days i havent used i got new props sam size, same brand, APC clone, and now my ThrottleOut value in the graph is about 780~800 (!!!) when it used to be just 550~600

could be this an ESC problem (too much A?)?

could be this an props problem (too large?)?

could be this a motors problem (broken? not powerful?) ?

could be this a frame problem (too small) ?


[attaching dataflash log which captures 5 mins of indoor flight]

PS. other note: I was able to fly only 5mins with the Floureon 5500mah lipo 3S.

Views: 2121


Reply to This

Replies to This Discussion

Hi Manhattan

Does the new props have the same pitch as the previous props. Props with a lower pitch will have less thrust, thus needing more throttle.

Are you sure your Lipo pack is up to full charge and balanced properly?

same props, same pitch 11x4.7. lipo (35C) were charged 12.60.. maybe they are not the best battery out there..

this guy on this video https://www.youtube.com/watch?v=D6ZwhaOTLSE

with same config as mine fly 12min on 4S and 8min on 3S and i cant even almost lift off... i wonder if the longer arms could help maybe changing frame?

i want to try with a NAZA lite i have spared and see if the problem is APM or not

Have you solved your problem yet? I have a similar with my copter before being hard to keep hovering (climbed extremely easily) and now it barely lifts. I have also gone from 10" 4,5 to 11" 4,7 but did never think this would be the problem. Feels more like the motors are not spinning up properly. 

i've done some research:

first off – I was confused by  manufacturer's thrust chart they give for the motors... luckly i found a guy who did some test with same SunnnySky and now i understand the payload weight vs. lift has to be calculated based on 50% throttle... rookie mistake!

so based on the new calculation I understood my frame was too heavy or better... my mottor were not powerful enough based on calculation....

so i'm basically using a 4C battery instead of 3C and that solved my problem basically

also be sure you did ESC calibration... that helps.

and finally yes props matters but you have to use the motor thrust chart to understand the lift power at 50% thtottle...it can vary from 300 to 500gr. depending on manufacturer/props size

Unfortunately I've gone through all that. My motors have thrust of 1300g with 3S battery and 11x47 props. I have done the calibration of ESC through the transmitter.

As I said I was running this platform before with another Flight Controller running multiwii and I had lots of power. Even had to add a camera to get it more stable and not so difficult to hold hovering.

My platform weights 1300g, a tricopter with theoretical thrust of 3600g with the three motors. I've read lots of people complaining after update from APM 2,8 (i think) getting less juice out of their machines. I was hoping there would be an easy solution for me. The value thr_max seems important and should be set to 1000 for full power but in my case that was already there.

1300gr at half throttle? you sure? which motors are they?

i'd expect to be 1300 at 100% and about 300-400gr at 50% thr which

means you may have about 300-500gr/ea. at 50% = you have a total thrust of about 1200kg

but your frame weighs 1300 that means you need to go at 60% or more to lift

i never had APM before.. I was using NAZA with no such problems...... it is an interesting point though you make about the controller... i heard similar things..

Possible, I do not run APM but the Pixhawk, however the setup should be almost identical. 

Did you downgrade the firmware? do that first if that is what you suspect.

Inside the setup software you can set the throttle max and min values, even your hover point etc. 

Possibly this has been changed which could make the copter do as you describe 

Okaj, you are right. 1300g is att full throttle and yes, I have to give more than 50% throttle to lift. But this was not this way before the change to APM.

Many have looked at the Current logs and seen that they are getting around 50% of maximum current draw at 100% throttle. I much suspect I have the same problem. The motors I'm using are kv750, very popular motors on tricopter builds running FPV at similar weight. Maybe you have heard of RCExplorer? They normally run this motors on a wooden frame.

I also noticed that I have less flight time. Before I had lots of strength even though the battery was running critically low. No problems still flying around at 9,5V on battery. Now when I reach 10,5 it is hard to get it not to smash the ground if I descend a little to fast.

I have not tried version below 3.0. Though I am not aware of the changes I guess I've felt that it is a bad solution to go back to old firmware. Maybe they are not that many and significant ones?

One thing I want though is the autotune. Just made some minor changes in my frame and would want to save the pids from the autotune. Tomorrow maybe when weather is a little better I might go for it. After writing them down I could go to an older firmware.

Was supposed to run autotune last time but did not get it to engage. Therefore I've reset thr_mid as it was the only thing I can think of that could still affect. TX calibrated and no trims on. Tried to engage at a stable alt-hold position but nothing. Tried several times.

I find ecalc (ecalc.ch) to be accurate in terms of predicting throttle setting needed for hover.  I encourage you to weigh your tri (all up with battery, camera etc) and see what throttle setting the software thinks is needed with all your gear put into the software.  That will give you a good basis for determining the nature of the problem.  If the software says you need more than ~60% throttle to hover on new batteries,  you will have big trouble as the battery runs down.

Having a similar problem myself which I am yet to sort out, my 450 quad use to fly fine using a 5000mah 3c and have no problems with flight time or power but for some reason it will now struggle with flight time an with in a minute or so it shows

signs of low battery and it struggles to maintain thrust and looses altitude ,A check of battery shows still shows 11 + .Tried

a 2200mah 3c last night and got a 5 minute flight(hovering)  which was better but still not anywhere near what I use to get even on 2200.

watching this with interest

Now this is strange.... Im using a similar setup and am geting upwards of 15mins flight time, thats tested and not calculated!!

My advice would be to try a 4 cell with 10x4,5 props like me, you might also need to set the throttle mid point on the mission planner. Hovering at the mid point on your tx is important when changing the flight modes.

Here is my latest project take a look: http://explorer4-quadcopter.atwebpages.com/

Reply to Discussion


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service