I can't get to work the radio calibration.

In the terminal i get this error as you can see in the image and the video shows.

Can anyone help?


Views: 1126

Replies to This Discussion

I don't know witch lights are correct, you can see in the video i post, can you see if it's the right ones,

It's hard to tell, does the blue light on the apm flash at all?
What operating system you using? The interface looks a bit different to mine. Also, have you installed the driver for the apm? Do you get any pop up windows in the notification area when you plug it in?
Also, investigate how you are powering the board, make sure you are powering the rails correctly and you have removed the jumper.

Apart from the above, I don't think I can help any more, maybe someone with a bit more experience can chip in and see if there's anything else that may be wrong...

Thanks Richard.

I will test  more today to see where i get it.

Yes the blue flash, i teste in windows 8 ans windows 7, the interface it's the new one, i get it today from the download section.

i'm powering the the power module, the other end conects to the ezosd current sensor, and from this to the motor.

as you can see in the fotos i'm adding.

Hello again

could this be because i don't have any telemetry conected to the apm?



One thing we can clear up now is that you do not want PCM mode. The receiver output will be in either PWM or PPM with PWM being the most common method where CH1 out from the receiver connects to CH1 input on the APM. PPM requires that we place a jumper between CH2 and CH3 signal pins on the APM input, then connect the PPM sum output from the receiver to CH1 input on the APM. This has the advantage of simpler wiring and eliminates the need for the PPM encoder on the APM. This is shown here in the APM wiki.

As for the rest of your issue, If you tilt and roll the APM does the HUD in the Flight Data screen in the Mission Planner respond? I would start by simplifying things for now, remove all unnecessary hardware such as the OSD, leaving only those things minimally required such as the 3DR Power Module, and the GPS. When you connect to the Mission Planner does it report initialization the GPS lock and change from disarmed to armed?

Do you have a standard non-LRS type receiver that you could try>


Nathaniel ~KD2DEY

Can you connect to the APM from the terminal? Which com port is being assigned to the APM?

You may have simply installed the wrong driver, this can a happen if you connect the APM before you have installed the Mission Planner software.

To fix

1. Plug in the APM and go to Device Manager in in Control Panel (short-cut is to press the windows key and type 'device manager')

2. Expand the 'Ports (COM & LPT) section (or it maybe listed in the 'unknown' section

3. Right click on the APM and select uninstall

4. Unplug the APM and reboot

5. Start Mission Planner, then plug in the APM

6. If windows says Searching Windows Update for driver click 'skip' or 'close' (can't remember which it is)

(other options to fix this are more brute force are two uninstall Mission Planner, reboot , the reinstall. But if windows has associated the APM with the wrong device driver, you still need to go to device manager to the 'unknown' section to remove the problem) 

This part i have done and nothing change.

In the Mission planer when radio calibration show pwm, how to i change to PPM?


It's not something you change in the Mission Planner, it's the type of output your receiver has. Re-read my post and look at the picture in the wiki link in that post and I think you will understand.

How about the answers to my other questions above? It could be the difference between being able to help you or not.


Nathaniel ~KD2DEY


I don't change nothing n the mission planner. I use the ESuhf TX with the EZuhf RX 8CH.

I have done already the ppm sum wit the jumper as you said.

REgarding when i connect by usb the mission planner with the apm 2.5 without anything connected besides the powe rmodule and gps, it doesn't change from disarm to armed.

The strange is if i have connected the servos to the board i can move them with the radio, but seems i can write nothing in the board gives always error.



When you check the COM Port being used as Bill suggests below in item 2, what COM Port does it say is in use? Is the Mission Planner set to the same port? Also when you are connected via USB what baud rate are you using 115200? It sounds as though your whole problem is driver related. You are obviously establishing some kind of connection as the radio calibration screen doesn't appear unless you are connected.

I agree with Bill, Go through each step he has outlined including if necessary uninstalling the Mission Planner. Don't neglect to reboot where indicated. This really should be a straightforward process on either Windows 7 or 8.

I did a search and found one user who lost his ability to connect to his APM via the Mission Planner after an upgrade to Windows 8 from 7 and reinstalling the Mission Planner fixed it for him. Just don't forget the reboots in the sequence.


Nathaniel ~KD2DEY

Have you tried this with ntothing else connected to the APM? Just using the USB cable?


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service