Radios work on 1 computer but not laptop?

So I bought a new laptop yesterday, wiped Win 8 off right away and have Win 7 on it now. I've got all the drivers installed, too. Now the odd part, I'm trying to get my telemetry working.

It works just fine on my desktop, connects and I get data through .. but on the laptop with the exact same settings, it just times out/no heartbeat packets. I'm lost?

Dan

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • 3D Robotics

    Are you sure you've selected 57k?

    • Yep - unless it's not taking effect for some reason. Looking at the LED's for the FTDI chip when I try connect, they're blinking as if it's trying to start a connection, but the radio modules just continue doing their ~1hz red LED flash. I can unplug it from the laptop, plug it straight into my desktop and it connects fine. Really odd.

      As an aside, if I also try the "load settings" button in the raido config page, it says failed to enter command mode, but once again works fine on my desktop. 

      • Just been trying a bit more .. I used doubledriver to create a copy of the FTDI drivers from my desktop - no good. Then I just copied mission planner entirely - still no good. Win is all up to date, tried all the latest drivers, few different versions of mission planner .. nothing.

        • Sorry for the triple post, but this is really messing with my head. I have a friends spare APM and telemetry modules here. I hooked those up, plugged it into the laptop, works fine. Also plugged them into the desktop, also works fine. Plug my telem modules into the same APM and my desktop, works fine. Plug into the laptop - doesn't work. So obviously the issue is with my telemetry module somewhere, but why only on the laptop and not the desktop? 

          • 3D Robotics

            Are you plugging straight into the laptop or via a hub? Sometimes hubs don't generate enough power. Also try switching the USB cable. 

            Also, is that a USB 3.0 or USB 2.0 port? Sometimes USB 3.0 ports can cause issues due to non-optimized drivers. 

            • Straight in, I've checked voltages and they all seem fine. I've tried both USB2 and 3 ports.

              I have found something interesting though .. I have both APM's and their telem modules connected and running, and plugged both "RX" modules into the laptop. The one that won't work on the laptop has the FTDI RX LED flashing like crazy, while the other one, which does work, doesn't have any fTDI LED's flashing at all (but both have the dim red radio LED flickering). This is even after unplugging/replugging the device, so I haven't opened it's comport. Plugging both modules into my desktop gives the same thing, but the "bodgy" module still connects fine in MP. So strange ..

              • 3D Robotics

                Check that all the radio settings are the same, such as ECC and IDs. All the radios should have exactly the same settings. 

                • They appear to, I did a reset to defaults in MP also. The fact the "bodgy" radio's FTDI RX LED is flashing even without opening the comport is kind of a giveaway though.

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @_JonMyer: 🏎 We need your help in naming my #AWS DeepRacer Underground Track 🏎 @davidfsmith's track is going to be referred to as 𝗔𝗪𝗦 𝗗…
15 hours ago
DIY Robocars via Twitter
RT @gclue_akira: 仕事もおわったし、電脳化にとらい #マリオカートハック https://t.co/4IU90hCLgm
16 hours ago
DIY Robocars via Twitter
This is the hashtag to follow all the people in Japan who are hacking the new Nintendo Mario Kart with the real AR… https://twitter.com/i/web/status/1319281354664677376
16 hours ago
DIY Robocars via Twitter
RT @gclue_akira: @chr1sa @diyrobocars jupyter mario https://t.co/P0oHdjlCRq
16 hours ago
DIY Robocars via Twitter
RT @_JonMyer: 🚨Our 1st AWS DeepRacer Community Race is Underway on http://twitch.tv/aws 🚨 Join us to find out which member of your commu…
Tuesday
DIY Robocars via Twitter
Monday
DIY Robocars via Twitter
RT @BackyardRobotcs: After an admittedly long wait, the new Tinymovr R3.3 motor controller is now available https://tinymovr.com 🥳
Monday
DIY Robocars via Twitter
RT @_JonMyer: 🏎 1 hr left before the #AWS #DeepRacer Community 🏎 Top 5 Race tomorrow LIVE on Twitch 1st Place = $50 Amazon GC or AWS Credit…
Monday
DIY Robocars via Twitter
Oct 16
DIY Robocars via Twitter
Oct 15
DIY Robocars via Twitter
Oct 14
DIY Robocars via Twitter
RT @davidfsmith: Race virtually with The AWS DeepRacer Community Race and then join us on the track to see how your times compare on the ph…
Oct 14
DIY Robocars via Twitter
Oct 14
Hiroki Tanaka liked Hiroki Tanaka's profile
Oct 13
DIY Robocars via Twitter
RT @breadcentric: It's now!
Oct 13
DIY Robocars via Twitter
RT @SahikaGenc: Happy Prime Day! AWS DeepRacer is available at a 30% discount today! @sunilmallya #AWSDeepRacer https://www.amazon.com/AWS-DeepRacer-Fully-autonomous-developers/dp/B07JMHRKQG/ref=sr_1_5?dchild=1&keywords=deepracer&qid=1602609599&sr=8-5
Oct 13
More…