We have everything up and running in our fixed wing trainer but only get 40 feet away during the collapsed antenna range test before the servos go nuts. If Ardupilot is taken out of the loop, Range is over 100 ft, the plane flies fine and the Co Pilot works.
I removed all avionics from the plane and set them up on a test bed for diagnostics. Here's what we've tried----
1-Running Ardupilot off separate battery
2-Grounded shielding of Ardupilot and input cables
3-Opto isolation of Rx from Ardupilot
4-Reorienting components

I'm using a Futaba 72MHz PPM Rx and no matter what methods we've tried, the range is still cut in half. Anyone else have these issues or are my avionics possessed!?

Views: 367

Reply to This

Replies to This Discussion

We use exactly the same configuration, but with ArduPilot powered by the Rx, and get range measured in miles. Why don't you try that configuration and see if it makes a difference?
Hi Chris,
Ardupilot and Rx on the same battery was our baseline arrangement but the Ardupilot power was from soldered wires to the Bat + and - on the board, then we tried variations 1-4. I'll try using using just the power from the Rx inputs (as written in the Ardupilot page) and see what happens.
I experienced the same readings during my collapsed antenna range test ~40-50 feet with the ArduPilot connected and well over 100 feet when servos were directly connected to the receiver (bypassing ArduPilot). I am using a Futaba 7C 72MHz PPM TX and Futaba Receivers as well. I was wondering if you were able to find a solution that worked. My last flight lost RC signal less than 1/2 km away and servos pitched the plane down into the ground.
I wonder if there is a noisy part of the board that affects 72Mhz. All the dev team is on 2.4, along with almost all the users, so we've never tested 72mhz or had many reports. But the fact that a couple range issues are cropping up on 72 suggests that there may be some rf issues there. Might be worth trying various configurations to try to isolate the problem: without GPS, without Xbee, without shield, etc...

You mentioned the Co Pilot in your post above. Are you using the FMA Co Pilot and version 1.0 of the Ardupilot flight software? If so, you need to move up to a later version of the Ardupilot board and the Ardupilot software.

Just a thought.

Thanks Chris, I'll try some different configurations. I already removed my Xbee so I'll try some different setups with the other equipment I have. Right now I am working with the uBlox GPS, IMU v2, Shield v2 w/ airspeed sensor and ATMega 328 board running code version 2.6. Staying close to my launch point, I have been able to tune my gains enough to get RTL and AUTO modes working and navigating reasonably well, but I still need some tuning.
When twisting the servo cables together, do you recommend I twist them individually without separating the wires, twist pairs of cables together or should I disassemble the cable and twist the individual wires together?
When connected to the ArduPilot, it seems that when it loses signal the servos twitch like crazy and elevator moves to pitch the aircraft so it goes nose down. When this occurs, I can't switch back to manual mode or override the inputs. I have not been able to locate this type of behavior in the code and was expecting that signal loss or too much interference would be detected by the failsafe and the ArduPilot would enter the RTL mode. When this occurred, I was already in AUTO mode and it was navigating to waypoints. Am I mistaken about how the failsafe works or is the interference just overpowering the other inputs.
Thanks for your help.
Are you using ArduPilot to control the throttle (jumper cables soldered under the board)? If so, you may need to boost the channel 3 (throttle) signal. You can use one of these amps for that. Also, just checking that you've cut the D13 pin off on the AP board, as instructed in the manual for this configuration.
I still am waiting for my plane to arrive, and I do not yet have my ardupilot set up so I have to answer this question academically... However, I do know a bit about wireless communicaitons. Is there anything that changes in the environment between the two tests For example:
Do you have xbee running at the same time?
Are you testing this outdoors?
When you test, are their objects around that can cause reflections of the wireless signal? At 72 MHz at 100 feet multipath is unlikely but not impossible.
One oddball thing - when you are running ardupilot do you have a PC around? You would be amazed how easily a laptop can saturate a 2.4 GHz radio.

Anyhow, RF can cause weird problems
Chris, I am using ArduPilot to control the throttle. I have the jumper cables soldered under the board and did not install a pin into D13. My interest in drones has peaked rather recently and have found the instructions and info here really helpful and generally easy to follow. I am in the process of rerouting/retwisting some wiring and will try a different type of shielding.
I was reading about the amps you recommended and had been thinking about trying them from the optocoupler angle, but hadn't thought of trying it as an amp. Would it go between the receiver and the ArduPilot, or between the ArduPilot and the servos/speed controller.
Thanks again for all your assistance.
Thanks for the help. I have tested indoors and outdoors with similar results. I initially had an xbee on, but removed it to try to reduce some of the interference. I typically have my PC around to test and reload code, but have been turning it off just in case it was doing something weird to interfere with my 72 MHz radio. I'm going to try to borrow a friend's 2.4 GHz radio to do some other testing if I am unsuccessful reinstalling all my equipment and following the other recommendations by Chris.
Seems like this is a common issue for Futaba 72Mhz radio. I faced this problem before and I had a discussion here: http://diydrones.com/forum/topics/705844:Topic:14909

After I switched to the Futaba 2.4GHz FAAST radio, all the problem solved. It's really worth the money to switch to the 2.4 one instead spending time on troubleshooting the 72Mhz one.
I am using JR 7202 @ 72 mhz with no range issues.

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service