We have everything up and running in our fixed wing trainer but only get 40 feet away during the collapsed antenna range test before the servos go nuts. If Ardupilot is taken out of the loop, Range is over 100 ft, the plane flies fine and the Co Pilot works.
I removed all avionics from the plane and set them up on a test bed for diagnostics. Here's what we've tried----
1-Running Ardupilot off separate battery
2-Grounded shielding of Ardupilot and input cables
3-Opto isolation of Rx from Ardupilot
4-Reorienting components

I'm using a Futaba 72MHz PPM Rx and no matter what methods we've tried, the range is still cut in half. Anyone else have these issues or are my avionics possessed!?

Views: 362

Reply to This

Replies to This Discussion

yaya...this problem only happens on Futaba 72MHz model.
I have a Futaba 72mhz radio as well and am experiencing similiar issues. All will be fine then sudden twitching of the servos. May have to try a 2.4 to see if this solves the problem.

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service