Raspberry Pi 2 model b Not connecting with pixhawk via GPIO

Hi,
i am trying to connect raspberry pi b to my pixhawk at telem 2 port with the GPIO pins of the raspberry pi as shown inhttp://dev.ardupilot.com/wiki/raspberry-pi-via-mavlink/ post.
i have also changed the pixhawk parameters as in viewtopic.php?f=21&t=8798#p20733
but when i enter " mavproxy.py --master=/dev/ttyAMA0 --baudrate 115200 --aircraft MyCopter" in the pi terminal 
i always get 
"Connect /dev/ttyAMA0 source_system=255
no script MyCopter/mavinit.scr
Log Directory: MyCopter/logs/2015-12-14/flight5
Telemetry log: MyCopter/logs/2015-12-14/flight5/flight.tlog
MAV> Waiting for heartbeat from /dev/ttyAMA0"
i think either i am missing some setting in the pixhawk for which its not sending the heartbeat signals a to raspberry pi.
** i ran the Sitl on my mac and was able to connect with the mavproxy of the pi"
If i am missing something please point me in the right direction as to how i can set up the connection between the pi and pixhawk

Thanks.

Views: 440

Reply to This

Replies to This Discussion

Change "mavproxy.py --master=/dev/ttyAMA0 --baudrate 115200 --aircraft MyCopter" to
"mavproxy.py --master=/dev/ttyAMA0 --baudrate 57600 --aircraft MyCopter"

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service