Does anyone have a recommendation for a good composite to usb video convertor to use with the HUD in MP? I've got a cheap easycap one but it craps about at a very low frame rate and usually chokes and goes to black screen. I'm guess it can't handle the bandwidth. I'm using a 5.8GHz immersionrc vRx. It just has composite out.

Views: 1768

Reply to This

Replies to This Discussion

This forum sometimes cuts the post. Can you repost Michael.

I remember Tommy recommended the same thing to me on another discussion but I never set it up. With the delay though it will not be good for me. Better if MP can deal with the audio. It's possible Michael?

I've tried this out using my Diamond Multimedia VC500 USB video capture device and have had zero luck.  Tried both using the command line above and using the GUI (Windows 7) to get the video to stream, no dice.  

I can play video perfectly fine in the software that comes with the capture device (5.8GHz) as well as on a normal monitor, but cannot get it onto mission planner.

Any help would be greatly appreciated!  I've attached a pic of the driver and how it's working fine on my desktop using the video software that came with it.

Maybe using a different driver would help?  Are there particular USB capture device drivers that VLC supports? 

Attached some pics of the driver software and how its working with the crap software that came with the device... gotta get it working in VLC or it will never make it to Mission Planner :(.  Please help!

So good news and bad news... 

Good News is, with a couple important settings I got this to show up just fine in VLC.  The devil was in the details, the big setting change was setting caching to 0ms.  It is set at default to 300ms.  I've listed the final settings below.

Bad News is, Mission Planner does NOT like the the MJPEG stream I'm trying to send it using M Osborne's guide.  I'm getting an error in the console log when I try to open the stream, see screenshot below.  Maybe he knows why I get that error?  I followed his guide precisely to setup the re-stream back to Mission Planner, so now I'm a bit stumped.

VLC Settings:

 :dshow-vdev=Conexant Polaris Video Capture :dshow-adev= :dshow-size=720x480 :dshow-aspect-ratio=4\:3 :dshow-chroma= :dshow-fps=0 :dshow-config :dshow-tuner :dshow-tuner-channel=0 :dshow-tuner-frequency=0 :dshow-tuner-country=0 :dshow-tuner-standard=1 :dshow-tuner-input=0 :dshow-video-input=-1 :dshow-video-output=-1 :dshow-audio-input=-1 :dshow-audio-output=-1 :dshow-amtuner-mode=1 :dshow-audio-channels=0 :dshow-audio-samplerate=0 :dshow-audio-bitspersample=0 :live-caching=0

Now Working in VLC:

Error when selecting http:\\\ as the HUD MJPEG video source:

in your settings you seem to be missing the output type.

in vlc are you picking http, then "Add"

the output stream should have something similar to this

:sout=#transcode{vcodec=MJPG,vb=800,scale=Auto,acodec=none}:http{mux=mpjpeg,dst=:8080/} :sout-keep

Michael, first thanks for all the hard work you've done on this software. It is truly amazing how far this stuff has come and a lot of it is because of the work folks like yourself have done and then graciously offered to share it with us.

In regard to your previous question, yes I absolutely did hit "ADD" after selecting HTTP, and had port 8080 selected as the destination for the stream.  This definitely looks like a problem in VLC, where I click "Stream"  and for whatever reason (has to be a setting) it cannot re-stream the data.  Even though the video can play flawlessly when you open that source with 0ms caching.  I am just having trouble re-streaming it.  You can see it playing perfectly well in VLC in the first screenshot of my last post.

Not sure what setting I have wrong or if there are more specific information I can give you about my setup.  Here it is, for your convenience:

Airborne Tx :

Ground Rx:

Camera (NTSC, 700TVL):

Laptop Computer:

Dell, Windows 7 (64bit), running VLC 2.2.1, streaming to Mission Planner 

Capture Device (Diamond VC500):

Let me know if anyone has had more luck with re-streaming with this device from VLC to the HUD in mission planner.

have you tried the built in MP video engine?

goto mp options and try the option at the top.

#thatwaseasy.  #solved.

Wow.  Why was that not discussed ANYWHERE in this part of the forum?  Is that a new feature?  Now I feel dumb :/  ...

OK.  So now that the video is playing flawlessly in the HUD, the roll part of the overlay is jittering like crazy.  I've had that happen no matter what video was piped in (even just an MJPEG stream I had running from a security camera in the house).  I've also heard other people have this issue as well.  

Is it a frame rate issue?  I believe my cam is running NTSC, 720x480 at 30fps, but it does it at lower resolutions as well.  Its moving so quickly that you can't do a screen capture that is good enough for you to see it.

Here's it actually working in the HUD now, thanks for the previous help Michael!!  But what about the jitters?  (Maybe the copter is just nervous to fly? :)  )

Here also are my mission planner settings with the video input:

Anyone have any ideas on this?  Anyone else have a jittery HUD overlay when using a video capture device?

Reply to Discussion


© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service