RFD900, RFD900+ - New long range radio modem

Hi All,

I would like to introduce you to a new radio modem that we developed for very long range datalinks!


Some of the key features of the RFD900 are as follows:

  • Multi point and point to point link capability.
  • Long range >40km depending on antennas and GCS setup.
  • 2 x RP-SMA RF connectors, diversity switched.
  • 1 Watt (+30dBm) transmit power.
  • Transmit low pass filter.
  • > 20dB Low noise amplifier.
  • RX SAW filter.
  • Passive front end band pass filter.
  • Open source firmware / tools, field upgradeable, easy to configure.
  • Small (30 x 57 x 13 mm), light weight (14.5g).
  • Compatible with 3DR / Hope-RF radio modules.
  • License free use in Australia, Canada, USA, NZ.


These modems are designed to support long range applications, while being easy to use and affordable.  

These modems have been flying in various platforms and have demonstrated excellent performance in real applications. 

RFD900 modems are now available at: http://store.rfdesign.com.au

Support within APM planner and the radio configurator from Michael Oborne is already available.

It works seamlessly with APM planner, all radio Mavlink parameters are available.

Update, December 2014:  The RFD900+ with improved specifications is available now at:


Seppo Saario



Views: 110331

Reply to This

Replies to This Discussion

First, check that you aren't already in command mode - "AT<enter>" will do it. If you get "OK" then you're already in command mode (but that's probably unlikely.)

Next, check that communication is working properly - the simplest way to do this is to connect Tx and Rx on the remote module. That way, anything sent to the first module should be transmitted to the second module, through the loopback, back to the first module, then displayed in your serial console.

Finally, make sure you're doing the "+++" properly. There is *no* <enter> at the end! You need to wait a second without sending anything, press "+" three times, then wait another second. Typing "+++<enter>" will not work unless you're a *really* slow typist. :)

Thank you very much for the rapid answer! My problem was the <enter>, I changed to "no line ending" in cutecom and now it works :)

Much better link than the 3dr modem. 

Seppo: I do have a number of RFD900 and they all perform very well except one.

As I was setting the channel number and other various parameters through mission planner, the on board LED got solid red and nothing I have tried changed this?

It is the new version (black PCB with version I written).

I even downloaded RFDtools V 1.5 but it looks like this one refuse to communicate.

What should I do?

Thanks and regards



I have another question regarding the AT commands. Now when I connect the FTDI cable to the modem and write '+++' I get 'OK' back. However, then when I try any command, e.g. ATI5 I only get the exact same letters back and no information. Is this normal operation and I am missing something?

Thanks in advance!


I have a RFD900 modem Bundle working in my UAV. Now, I am build a new DIY UAV, so my question is: can I use my old RFD900 modem as ground station, and binding with new RFD900+ version in the UAV. It mean that my present Ground modem will be working with both UAVs, one at time?...it will be possible?

i am not an expert but I had a similar problem, the solid red means Firmware Update state. I clicked the Update button and enter in this state. The solution was update the Firmware with the same Firmware version. Please, use that as reference, I am not an expert, as told you....luck  :)

@juan : Thank you for your comments. 

As the comms between the modem and the USB interface look completely non responsive, that didn't work for obvious reason.

Placing another RFD900 modem on the same laptop / Usb interface works perfectly.


Perhaps Seppo took long holidays in a paradise island?



yep, in my case the modem seen not connect with RFDTools, or 3DRRadio.exe, but I realiced that the USB port recognize the modem. So, I tried to update the firmware, as read in some part, and, miraculously, the RFDTools worked straight. After that the modem return to green light........the key was read that the solid Red light mean Firmware update status.....was my case

The +++ mustn't have <enter> after it, but the AT commands need it! Did you change your serial console settings back after you got into AT mode?

Seppo is usually ridiculously busy running his business. Sales and support of the RFD900 are only a tiny part of RFDesign, mostly he's doing complex hardware design work for other companies.

So he definitely responds to warranty issues and the like if you email him, but he almost never has the time to spend on forum interaction. It's rarely necessary to get a response directly from him, anyway; other users here are more than able to help with basic issues.

Thanks again :) now it works!

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service