Roll issue on 3.2.1 firmware

Hi all. I think I found a bug in 3.2.1 firmware. Yesterday when I flied with not strong wind my octa (18” props, over 10 kg of weight) tilted made roll with 70 angle, with ANGLE_MAX = 3000. In logfile DesRoll on this moment equals 30 angles. A bit more and copter could turn over. I flied a lot of times before with this setup and everything was good. I think it is a kind of uncommon bug, which probably moved to later version (3.3 etc). Log analyze did not geve any answers for such behavior, except many GPS errors. I understood that when GPS is not stable copter can suddenly change position, but it should not roll more that angle set in ANGLE_MAX parameter. Log file in attached.

2016-03-02 12-27-49s.zip

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I would normally say it must me a PID problem. But I have the same issue on a smaller X8 platform as well. The thing is, that both multicopter fly very well, but sometimes they massively overshoots. So I don't know exactly where I have to tune.

    I only have this behavior on X8 multicopters... for me it's strange...

    • I did some further tests. It seems that the PID values were not optimal for the X8 setup. I decreased the P values and increased I and D. My smaller X8 fly with this modification very well. I can't see any overshoot in the logfile. My bigger camera X8 still overshoots a little bit. I think it comes from the relatively heavy camera who can wobble a little bit due to the damper system. I hope I find a way to eliminate this issue.

  • May be its some kind of PID misconfiguration?

  • Hi friends

    I think I have the same issue. I fly also a X8 multicopter. The model is a little bit smaller (16" props and 8kg weight). I noticed the problem the first time last autumn. It was a wonder that multicopter didn't crash... 

    I fly yesterday on a film set. It was partially very turbulent. So I saw a few times that the copter overshoots on the pitch axis. For me there are two scenarios. One of them is a software bug, the second is a aerodynamic problem in the coax setup.

    I hope somebody of the developers make a statement on this

    Thanks a lot 

    Michael

    254.BIN

    https://storage.ning.com/topology/rest/1.0/file/get/3702200649?profile=original
This reply was deleted.

Activity

DIY Drones via Twitter
Using ArduRover with an RTK GPS https://ift.tt/2N9I3RO
yesterday
DIY Drones via Twitter
yesterday
DIY Robocars via Twitter
yesterday
DIY Robocars via Twitter
Friday
DIY Robocars via Twitter
Friday
DIY Drones via Twitter
Thursday
DIY Robocars via Twitter
RT @Heavy02011: @diyrobocars : A Home-brew computer club* for Connected Autonomous Driving on Jan 23rd, 2021 https://www.meetup.com/Connected-Autonomous-Driving/events/275728684/ #Meetu…
Thursday
DIY Robocars via Twitter
Thursday
David Hori liked Isabella Domi's profile
Jan 12
DIY Robocars via Twitter
RT @Heavy02011: ⁦@diyrobocars⁩ Autonomous Driving Assembly at #rC3. join us at https://rc3.world/rc3/assembly/diyrobocars-f1tenth/ ⁦@f1tenth⁩ ⁦@DAVGtech⁩ ⁦@DWalmroth⁩…
Jan 11
DIY Robocars via Twitter
RT @chr1sa: New car designs coming for our next @DIYRobocars @donkey_car virtual race on the 23rd. Choose any one you want at race time Le…
Jan 11
DIY Robocars via Twitter
RT @RoboticMasters: Thanks to @EllerbachMaxime and the Sydney Uni Capstone Students the @donkey_car @diyrobocars simulator is getting a ma…
Jan 11
DIY Robocars via Twitter
Jan 6
DIY Robocars via Twitter
Dec 28, 2020
DIY Robocars via Twitter
An interesting line-following simulator to use with with your robocars: https://github.com/ron-grant/LFS
Dec 23, 2020
DIY Robocars via Twitter
Dec 23, 2020
More…