Hello, I hope someone might be able to help or point me in the right direction,


When running a test in the CLI on the Oilpan the roll and pitch figures will start at odd figures after the ADC calibration has finished. For instance the roll will show -4 and the pitch 6 and yaw 0, this is without touching or moving the board during the calibration process, if the board is then moved with the figures shown above it's like they are very dampend, they do not change with any great deal of speed if at all. One other thing to point out, it's like the board is driffting, if the board is sat still long enough the figures slowly begin to change, even when the board is not touched!

I have tried another Oilpan on the APM Board, and this works fine, so there is a fault with the Oilpan, what do you think the next steps can / should be, can this be recalibrated?






Views: 208

Reply to This

Replies to This Discussion

First, remember to do a EEPROM reset before testing a new board. Second, remember that yaw will always drift unless you're in motion or have a manetometer onboard, enabled and calibrated.

If that doesn't solve it, you may have a soldering error. Check all your connections. If that doesn't do it, contact DIY Drones customer support.

Hi Chris,


Thank you for your reply, this is an older board, a FoxTrap, I have done the reset to factory in the CLI and still have the same issues, I did not solder the board, but have checked and then resoldered the connections, there was a question mark over on a few of the joints which looked as if they had not taken. Still no joy, any other thoughts?





Reply to Discussion


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service