I wonder if one of the experts could have an analysis of these flight logs and tell me what caused this behavior.


Plane = Skywalker 168

RC Futaba 8fg Tx Corona 2.4 Rx

APM 2.5 downloaded with parameters for Skwalker from wicki

3d battery monitorset to 10.9 volts Failsafe with 3s 6000 40c pack

Video Tx Immersion 5.8

OSD Remzibi

Previous flights without APM have been smooth and precise with and without AV.  Flight was line of site not FPV. After launch the plane was trimmed out and flown away at about 200 feet and 150 feet high crusing level at 1/3rd throttle. When  RTL was selected the plane went to full throttle, full left aileron (a pefect wing over) and headed vertical down.  I switched back to manual and recovered level flight. I tried this a few times but with the same result.  I tried circle mode and that worked but with a descending pattern with no attempt to regain height but I did not give much time and switched out to manual and recovered level flight.  I then performed a manual touch and go and on climb out at about 80 feet the model went to full throttle, performed the wing over abd vertical dive.  This time it was too low and I could not recover, I had no control of the flight surfaces but I did get the throttle closed (I think). It was not a stall spin.  The model is a right off, so is the camera and Video Tx.  I do not know enough to decode the logs and I would dearly like to know what caused this crash.  I was in two minds to use the APM in this plane or buy the new FY-40 Autopilot, wish I had now, 300 pound down the pan!!

Views: 2854


Reply to This

Replies to This Discussion

Looks like you didn't have gps lock! I am an amateur in terms of ardupilot, but this is what it looks like when I plot your logs. Did you check you had lock? The GPS status was 0, throughout the second log.

Where was your GPS module located? 

Some reason can't edit the previous post.

If I am right assuming the first set of logs is from the same flight. Then, it suddenly lost gps lock and this is pretty bad. How was the weather? Even putting your hand across a gps can lose gps lock. My guess is that it might have been blocked by something or the gps module failed.

Also from my understanding, if the position was completely wrong then the controller would apply a massive response to your aircraft as it would have such a large error. So it makes sense that it would apply fully throttle and a sharp turn.

As far as the APM it was showing solid blue when I launched so locked. I had a feeling that after the touch and go and climb out all was OK then the RTL kicked in.  Could This have been when GPS was lost?  when I picked up the bits the APM's gps was unplugged.  Before or after, who knows?  I had the setting, if gps lost rtl. not carry on with mission.

OK, I can see that you went from manual to circle, then the weird stuff happened

At log number 1196 you had a failsafe. And it went into RTL, what was the battery voltage of the battery you used?

It might have been a radio failsafe or a voltage failsafe. I am not sure of the battery voltage from the logs. 

So I reckon that after you did the touch and go, it was at that point the plane went into failsafe. 

It's really unfortunate that your plane would have been fine if you had GPS lock. 

The logs indicate that it didn't have gps lock the whole time! So I am not sure why it was blue. 

Hello Tim, Your first log 2013-11-23 18-40 5.log shows you NNW of London. The next log 2013-11-23 18-42 6.log has absolutely no GPS data, all zeros. With no GPS data I believe it is supposed to go into circle mode, but the AHRS uses GPS velocity for drift correction. You should not crash from loss of GPS, but maybe that's the case. I will look into this matter.

You GPS being unplugged is the root of your crash, but we should be able to handle that.

It sounds more like a rudder hard failsafe event as used to happen with receivers. As others have said loosing the GPS would not have caused this behaviour. Not looked at the logs what was your failsafe set to do? Can that Corona have he FS set onboard as my FRSky modules do?

Hi Gary F, thanks for our help. Could the second shorter  log messages be caused by me unplugging the batteries? The model was powered by 2 x 3s 3000's so giving 3s 6000.  The failsafe was set to 10.7volts capacity set to 6000. One thing I would comment on though is that I could not find an instruction on arming Arduplane unlike Arducopter.  So what is the correct procedure?

Hi Gary M, the failsafe can be set on board but it was disabled. The corona failsafe is to hold last  input and as the throttle went to max I dont think it was that. APM failsafe was set to RTL.  On the first part of the flight I initiated a RTL which was when the plane rolled left and vertical. I switched out of rtl back to manual and recovered.  I think I tried this twice then tried Circle twice, then a couple of low circuits and a touch and go then climb out at full throttle then back to 30% throttle then the plane rolled left and vertical at full throttle.  It was too low to try and switch recover from failsafe even if I had thought it was that. The AMP GPS was on the nose platform 300mm away from the motor,  500mm away from the video tx.  If only I had not done the touch and go; still it would probabl have done it next flight.

So I believe that after the climb out the current dropped to below the battery faisafe causing a RTL.  But why did RTL command cause a wing over dive?

Arduplane arms when it's receiving throttle data. Not any special stick movements needed.

You only had one short failsafe, then the long failsafe happened right after. So it wasn't caused by you unplugging the batteries ( as the apm wouldn't have power if you did that). 

red is roll and green is pitch.

You had -10 roll the whole flight as well. It should be zero. Maybe the reason why it banked so hard?

Don't think so, near the end of the flight you had 3100mah used, leaving 2900 left. Your failsafe was set for 2200mah left ( Why so much).  So it wasn't that.

But I think I see why it banked so hard, it was due to that roll being -11 when it's supposed to be zero. So it's trying to correct for that.

What caused the -11 roll?  I am unsure of the trimming procedure for Arduplane.  On Arducopter you set the trims to zero on the tx, set level, then let the APM do the rest.  If you trim on the TX after that it causes issues.  Is this the same with Arduplane?  I did need to put in right roll trim from the get go.  As it was a 6000 mah pack it looks as if only one pack was connected. I will check the packs today, maybe one is knackered.

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service