RTL Power Dive resulting in crash

I wonder if one of the experts could have an analysis of these flight logs and tell me what caused this behavior.

Spec

Plane = Skywalker 168

RC Futaba 8fg Tx Corona 2.4 Rx

APM 2.5 downloaded with parameters for Skwalker from wicki

3d battery monitorset to 10.9 volts Failsafe with 3s 6000 40c pack

Video Tx Immersion 5.8

OSD Remzibi

Previous flights without APM have been smooth and precise with and without AV.  Flight was line of site not FPV. After launch the plane was trimmed out and flown away at about 200 feet and 150 feet high crusing level at 1/3rd throttle. When  RTL was selected the plane went to full throttle, full left aileron (a pefect wing over) and headed vertical down.  I switched back to manual and recovered level flight. I tried this a few times but with the same result.  I tried circle mode and that worked but with a descending pattern with no attempt to regain height but I did not give much time and switched out to manual and recovered level flight.  I then performed a manual touch and go and on climb out at about 80 feet the model went to full throttle, performed the wing over abd vertical dive.  This time it was too low and I could not recover, I had no control of the flight surfaces but I did get the throttle closed (I think). It was not a stall spin.  The model is a right off, so is the camera and Video Tx.  I do not know enough to decode the logs and I would dearly like to know what caused this crash.  I was in two minds to use the APM in this plane or buy the new FY-40 Autopilot, wish I had now, 300 pound down the pan!!

2013-11-23 18-42 6.log

2013-11-23 18-40 5.log

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • You don't have the airspeed sensor enabled by any chance?  We had it enabled one time but then left it unplugged and the plane would dive and go full throttle thinking it was in a stall. Does not sound exactly like your issue but just curious.

  • Now I have had a chance to go over this incident I think I made a fundamental error in set up.  I used a PM to power the board but I did not follow the instruction to power the servo rail from the esc.  I had all 3 wires from the esc plugged into channel 3 on the input side of the APM. I had the jumper removed.  Could this mean that when the APM called for RTL there was not enough power and the board browned out causing the GPS to go off line?  Also I did not follow the tuning guide exactly.  I did not do the FBWA tuning but went straight into manual flight and RTL.  Sounds like operator error or clutching at straws?

  • Hello Tim, Your first log 2013-11-23 18-40 5.log shows you NNW of London. The next log 2013-11-23 18-42 6.log has absolutely no GPS data, all zeros. With no GPS data I believe it is supposed to go into circle mode, but the AHRS uses GPS velocity for drift correction. You should not crash from loss of GPS, but maybe that's the case. I will look into this matter.

    You GPS being unplugged is the root of your crash, but we should be able to handle that.

  • Looks like you didn't have gps lock! I am an amateur in terms of ardupilot, but this is what it looks like when I plot your logs. Did you check you had lock? The GPS status was 0, throughout the second log.

    Where was your GPS module located? 

    ag4wi8F.png

This reply was deleted.

Activity

gotham liked gotham's profile
9 hours ago
DIY Robocars via Twitter
RT @RoboticMasters: Monaco GP Circuit in the Donkey Sim (coming soon). Including buildings, tunnel and all! https://github.com/robotics-masters/sim-donkeycar-f1/tree/f1-tracks @diyr…
yesterday
DIY Robocars via Twitter
RT @breadcentric: Here are the details of #AWSDeepRacer finals: https://blog.deepracing.io/2020/12/01/aws-deepracer-league-finals-2020-round-1-schedule/ #awsreinvent2020 #AWSreInvent https://t.co/ovqsjp8V…
yesterday
DIY Robocars via Twitter
RT @breadcentric: #AWSDeepRacer League #awsreinvent2020 Open race is on Dec 1st - Dec 31st in three categories, 15 DeepRacer Evo (with LIDA…
yesterday
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars It's just something that's easy to track with chroma keying. I ended up using different colors on th…
Monday
DIY Robocars via Twitter
Monday
DIY Robocars via Twitter
RT @TinkerGen_: "The Tinkergen MARK ($199) is my new favorite starter robocar. It’s got everything — computer vision, deep learning, sensor…
Nov 23
DIY Robocars via Twitter
Nov 23
DIY Robocars via Twitter
RT @roboton_io: Join our FREE Sumo Competition 🤖🏆 👉 https://roboton.io/ranking/vsc2020 #sumo #robot #edtech #competition #games4ed https://t.co/WOx…
Nov 16
DIY Drones via Twitter
First impressions of Tinkergen MARK robocar https://ift.tt/36IeZHc
Nov 16
DIY Robocars via Twitter
Our review of the @TinkerGen_ MARK robocar, which is the best on the market right now https://diyrobocars.com/2020/11/15/first-impressions-of-tinkergen-mark-robocar/ https://t.co/ENIlU5SfZ2
Nov 15
DIY Robocars via Twitter
RT @Ingmar_Stapel: I have now explained the OpenBot project in great detail on my blog with 12 articles step by step. I hope you enjoy read…
Nov 15
DIY Robocars via Twitter
RT @DAVGtech: This is a must attend. Click the link, follow link to read the story, sign up. #chaos2020 #digitalconnection #digitalworld ht…
Nov 15
DIY Robocars via Twitter
RT @a1k0n: Got a new chassis for outdoor races (hobbyking Quantum Vandal) but I totally didn't expect that it might cause problems for my g…
Nov 11
DIY Drones via Twitter
First impressions of the Intel OpenBot https://ift.tt/36qkVV4
Nov 10
DIY Robocars via Twitter
Nov 9
More…