I wonder if one of the experts could have an analysis of these flight logs and tell me what caused this behavior.


Plane = Skywalker 168

RC Futaba 8fg Tx Corona 2.4 Rx

APM 2.5 downloaded with parameters for Skwalker from wicki

3d battery monitorset to 10.9 volts Failsafe with 3s 6000 40c pack

Video Tx Immersion 5.8

OSD Remzibi

Previous flights without APM have been smooth and precise with and without AV.  Flight was line of site not FPV. After launch the plane was trimmed out and flown away at about 200 feet and 150 feet high crusing level at 1/3rd throttle. When  RTL was selected the plane went to full throttle, full left aileron (a pefect wing over) and headed vertical down.  I switched back to manual and recovered level flight. I tried this a few times but with the same result.  I tried circle mode and that worked but with a descending pattern with no attempt to regain height but I did not give much time and switched out to manual and recovered level flight.  I then performed a manual touch and go and on climb out at about 80 feet the model went to full throttle, performed the wing over abd vertical dive.  This time it was too low and I could not recover, I had no control of the flight surfaces but I did get the throttle closed (I think). It was not a stall spin.  The model is a right off, so is the camera and Video Tx.  I do not know enough to decode the logs and I would dearly like to know what caused this crash.  I was in two minds to use the APM in this plane or buy the new FY-40 Autopilot, wish I had now, 300 pound down the pan!!

Views: 2838


Reply to This

Replies to This Discussion

It's the same as arducopter, you should trim in apm and not on the tx. As when it goes into RTH or Auto, it will be ignoring your tx and the controller will be trying to fight it being out of trim the whole time.

Calibrate radio with ardupilot with zero tx trims.

Set ardupilot to level

Trim on ardupilot instead of TX. 

Well i am pretty sure thats what i did.  Anyhow I mean  if there is a next time I will double check.  By that I m me over $ean I will 99% go with a fy41 autopilot for fixed wing.  This APM has cost me over $500 in busted airframes and hardware.

TRIM_AUTO is off by default, if on it requires the sticks to be at neutral when switching modes as the trims will be remembered. If you trim on the Tx with it off the new trims will not be remembered by APM.

If RTL is activated the plane will attempt to return to it's launch point, any untrimmed surfaces will be compensated for.

I haven't gone into this in great detail but could it be that the touch-and-go just before the crash dislodged or disconnected something?

Its possible but unlikely as it was a real greaser on wet short grass.  Any ideas on how I can test the GPS?  When I used this GPS in a quad I ysed to get 7 or 8 sats regularly.  Here are 3 more logs from the download


You can do a GPS test from the Terminal tab, type 'test' and 'gps' after connecting. There isn't really any other way to test it, satellite visibility varies with other external factors too.

Now I have had a chance to go over this incident I think I made a fundamental error in set up.  I used a PM to power the board but I did not follow the instruction to power the servo rail from the esc.  I had all 3 wires from the esc plugged into channel 3 on the input side of the APM. I had the jumper removed.  Could this mean that when the APM called for RTL there was not enough power and the board browned out causing the GPS to go off line?  Also I did not follow the tuning guide exactly.  I did not do the FBWA tuning but went straight into manual flight and RTL.  Sounds like operator error or clutching at straws?

What's fbwa?



This is the most popular mode for assisted flying in ArduPlane, and is the best mode for inexperienced flyers. In this mode ArduPlane will hold the roll and pitch specified by the control sticks. So if you hold the aileron stick hard right then the plane will hold it’s pitch level and will bank right by the angle specified in the LIM_ROLL_CD option (in centidegrees). It is not possible to roll the plane past the roll limit specified in LIM_ROLL_CD, and it is not possible to pitch the plane beyond the LIM_PITCH_MAX/LIM_PITCH_MIN settings.

Note that holding level pitch does not mean the plane will hold altitude. How much altitude a plane gains or loses at a particular pitch depends on its airspeed, which is primarily controlled by throttle. So to gain altitude you should raise the throttle, and to lose altitude you should lower the throttle. If you want ArduPlane to take care of holding altitude then you should look at the FlyByWireB mode.

In FBWA mode throttle is manually controlled, but is constrained by the THR_MIN and THR_MAX settings.

In FBWA mode the rudder is under both manual control, plus whatever rudder mixing for roll you have configured. Thus you can use the rudder for ground steering, and still have it used for automatically coordinating turns.

Thanks. I do the Arducopter thing, so had never heard this term before. 

A bit off topic but can you explain this trim settings a bit more for arduplane? Following the plane.ardupilot.com instructions are:

 Ideally, you have already flown your airplane in manual RC mode and adjusted any trim values necessary, so the RC outputs reflect these trim settings; if you haven’t already flown your aircraft in RC mode and trimmed it out, you may need to do the RC calibration again later, after you have flown the aircraft (this is easy to do at the field).

I am still learning so I assumed this was on the Tx. I cant find instructions in wiki to adjust trim in ardupilot parameters. My Finwing flys ok now but would like to clarify this. Thanks.

You don't have the airspeed sensor enabled by any chance?  We had it enabled one time but then left it unplugged and the plane would dive and go full throttle thinking it was in a stall. Does not sound exactly like your issue but just curious.

Hi Marcus, no the airspeed sensor was disabled.  The dive was not a simple "down elevator full throttle".  It rolled to left 180 degrees and then dived for the ground at full throttle.  I think we now know that there is a chance that the board was browning out and resetting itself. 

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service