i have setup my heli and everything looks almost perfect, did't test fly it yet, but i have a note, my rudder never work unless i move the throttle stick a little high.

I have a turnigy 9x set as heli 1, i have connected the ESC directly to ch 3 on the receiver, and the pitch ch 6 to the ACM input 3, so since i have a throttle curve, it takes almost half the stick to stat moving the pitch output, but until the pitch is up a bit the rudder servo is absolutely not responding, neither from the radio, joystick or even the ACM stabilize. i thought it is something with the gyro, changed it with another one i had, connected the servo directly to ACM output 4, nothing, until i moved the pitch up.

is this normal?

is it something with the arming feature?

i tried to do it as in the manual, throttle down and full right rudder, nothing, unless i move throttle up, off course i have the throttle hold, but anyway it only affects the ch3 which is not connected to the ACM at all.

Views: 1272

Replies to This Discussion

hi randy, i loaded arucopter heli to new APM2 board (purple).  i have loaded traditional heli code using mission planner. everything works ok but there is no PWM on the servo out channels even after 'arming' the APM. PWM IN is showing in the setup bars. all 5 channels and the colletcive is getting PWM in. it tried evrything. when i burn quadcopter code the PWM out is perfectly ok.

ok, there is one difference between the heli code and the quad code in that on the quad we normally have "instant_pwm" enabled (i.e. we send the output to the motors right after the control loop completes the calculation of when it's done.

The quad/hexa/tri/etc do it a different way in which they send it at 400hz (or so) regardless of when the control loop runs.

It's possible that the instant_pwm output has not been tested on the APM2.  So..I guess we need to confirm this and if it's broken either fix it so instant pwm works on the apm2 or switch it to use the same method as the quad (probably the latter approach is better).

I've added an issue to the issues list here so you can start that for updates.

i tried the ardulheli code on APM1 also fearing that my APM2 may be having a problem. I noticed the same behavoiur on APM1 when i loaded arduheli firmare. everything seems OK including setup but NO PWM out even after arming the APM1. so it could be the code as you said. i am using CCPM flybarless head by 'tarrot'.

hi randy, do you think the issue would be handled soon. can i use an earlier verison of the arduheli.

I'll have a look at it tomorrow.  You're loading it from the mission planner or arduino?


     I've just checked the code from the mission planner on both APM1 and APM2 and it seems to work fine.  Can I ask how are you providing power to the servo rails?  On both APM1 and APM2 you need to provide power to the right-angle-headers that the servos connect to...they won't be powered from the USB (unless you have a very old version of the APM1).

     just a few replies further up you can see all the #defines that I put into my APM_Config.h to make the heli work.  the only one that I don't specifically mention is this one which should be at the top.




© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service