Hi all

After 8 very successful flights these last weeks, this morning for some reason, while in stabilise, my plane's surface areas are very slow to respond to movement of the airframe. Normally, using the standard skywalker parameters, the ailerons and elevator move rapidly to counter any movement in the

I've done the following to try to diagnose:

1. I've checked my PID's I've re-loaded the published skywalker parameters

2. Running in tuning mode on the APM planner, the APM seems to detect roll and pitch fine

3. Using my transmitter, surface areas respond immediately and full movement.

4. Increasing RLL2SRV_P does not appear to make a difference

I've recorded a small video to try to illustrate the problem:


The servo's are quite noisy while moving, it's as if it's being resisted.

I'm quite stumped! Any ideas welcome...

Views: 408

Reply to This

Replies to This Discussion

Forgive me if I'm totally off the mark, but I had something similar. It was solved by plugging in APM first and then the R/C receiver rather than the other way around.

Thanks Graham - do you refer to the short servo cables running between the APM and the receiver?

P.s. That's a big elephant...

basically power the APM before the Rx, and yes he was a big elephant!

Thanks, unfortunately I run my APM off my Rx power! Been like that always, no prolems until now. I have bought a seperate UBEC for powering my APM on a seperate feed, but it just seems as if I'm increasing the points of failures so I haven't installed it yet.

I've now reloaded APM 2.28 again, same problem. Getting worried.

Graham, I've just tried it anyway, powering the APM up with the USB running to my laptop, then connecting the batteries to the ESC and suddenly everything worked as it should!

Subsequently I powered it up without the APM first, and still it was fine!

Thanks a million for your advice - though I'm still unsure what was the cause and solution!

I've installed a UBEC to supply power to my RX and thereby my APM, but the problem still persists every now and then. Hope this doesnt happen in the air..

I'm still having this problem, even with an external power supply, no matter what sequence I power up. It appears to be random, I have to restart the APM until the problem goes away.

I'm very worried that I'm risking my plane now.

Should I get rid of my APM & buy a new one?

Update, I found that unplugging the Volt sensor from the battery balance lead makes the problem go away consistently.

Now the question is why, it's been working fine for many hours. I've tried different batteries too.

Some pictures: http://cde.co.za/shared/mark/ Yea it's a bit dirty :)

A friend of mine who is an electrical engineer had a look at the problem. His theory is, if I connect the volt meter before powering the APM, the APM tries to power itself from the power received through the volt meter.

First powering up the APM through the receiver and *then* connecting the voltage meter solves the problem!

Anybody else do it this way?

Thanks for taking the time to post this. I was having the exact same problem and your solution fixed it. Thanks again!

My pleasure, I'm happy that this could help someone!

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service