Setting up and testing Failsafe

A few comments on how to make the wiki clearer on how to set up Failsafe, and a question on how to test it. Extract from the wiki with my comments:

 

If you have enabled failsafe (how? I have set my config THR_FAILSAFE to 1 - is that correct?), your copter will RTL back to home, and auto-land after 20 seconds.

To enter failsafe, you must be armed (failsafe does not work when disarmed) and you must set your receiver to output a low throttle signal (below 975µs by default). To send a throttle value that is below your radio's normal neutral throttle value (say 1100), please read your radio's programming manual.

I would make this a bit clearer. For instance, "you must set your receiver to output a low throttle signal (below 975µs by default). This can be done by looking at the Status or Raw Sensor View (Radio) and changing the end point on your low throttle setting so that it is below 975µs. Then programme that into your receiver as a Failsafe setting (refer to your receiver's manual). Then reset your low throttle setting back to what it was e.g. 1100. Test that the receiver Failsafe setting is working by viewing the radio data as above and then switching off your Tx. The Ch 3 setting should now drop to the below 975µs setting. Switching the Tx back on should restore the Ch 3 setting to your normal neutral throttle value. Recalibrate your radio settings once you have completed this exercise.


How do I safely test that this will work? I tried taking my copter outside, powering it up, getting a GPS lock and then arming it and looking in Mission Planner. I could see Ch3 in reducing to 965 when I turned my Tx off, but there was no indication of a change in mode. Oddly enough, I am reluctant to turn my Tx off when I am flying it.

Any guidance on this would be much appreciated as I would like to have this safety feature as insurance to help prevent injury (and crashes and money!).

Regards, Bill

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I'm having trouble understanding how to set the ch3 output to go as low as 950.

    I'm using a turnigy 9x with frsky module, and currently I have the frsky receiver failsafe set to about 50% throttle and it will switch it into RTL using the ch5 mode switch.

    I don't feel particularly confident in this, as I just tested this on the bench with no props (and no gps lock) while the quad was armed by turning off the transmitter, and the motors went to 50% throttle (as expected).

    It sounds like the better method would be to set the receiver to output less than 975 on ch3 as discussed here, but I don't understand how this can be done with my radio. Anyone know?

  • oops wrong thread can someone please delete this.....

  • So this afternoon I had two flights out over the frozen lake.

    FW 2.3.1 GIT (as per this morning), APM2, MP1.1.35.

    I have already reported about how copter in AUTO mode reacts to failsafe, depending on the THR_FS_ACTION.

    But I also did hand tests, well away from HOME (due to the 10 radius limit, see the wiki) to find out what happens in Stabilize mode while turning on TX (entering failsafe). 

    Now maybe it almost works;

    Holding the quad in my hand at hover throttle and shutting of the TX would instantly make the motors drop thrust, but soon, within half a second i guess (have not yet checked the log) recover. But that momentary thrust drop-out was reason enough for me not to try this in flight!  Anyway it would of course be desirable that when copter for whatever reason enters failsafe RTL, it should do it firmly but at same time with a certain smoothness in the transition. Even more important on big copters with mass and momentum, as well as for trad helis.

    I am aware about the fact that a real situation RX failsafe is a rare situation for most multicopter users. But the day we need it we really want it to work flawlessly and predictable, right?

    I request that you, honoured developers and test pilots, run rigorous flight tests on the failsafe before official release of 2.3.1.

    Should have been done by 2.3.0 release, but let´s make it right this time ;-)

    Ps.

    Last flight I shut off the TX during AUTO flight. And I let it continue AUTO mission until last WP with auto land. I was determined to let it try to do a decent auto land. It went so-so. Last meter had high sink rate, and on touch-down it bounced up and flipped over, lying upside-down in the snow, motors running. Even though I switched TX on, entering stabilize (throttle at zero), switching modes, it would not react. Motors kept going. Had to pull the battery chord. I dont know if that was due to AC firmware or something happened to RC RX, since there was plenty of snow in the electronics hub. (I should get some more snow proof dome...)

    Picture: Quad drying in the dryer box.

    3692353952?profile=original

  • Developer

    Found a break missing in a switch statement. Should be all working in next revision. Made the update to the Wiki.

    Jason

  • in my simple logic (that's all i got to work with : p) i would say set your receiver fail safe to activate RTL .to test maybe pull the props off and walk away and turn off trans and watch your telemetry to see if it switches to RTL you could do this while its hooked up to usb... just a thought

  • I do have the THR_FAILSAFE at 1 to active it and THR_FS_ACTION at 2 so it will active RTL, but Ive not set up the radio yet to get it to work. Ill play around with it tomorrow.

    What I do notice though, in raw sensor radio when I turn of the tx, the throttle goes up to full and all the motors outputs do as well. So in theory the quad would take of into oblivion.

  • I finally had a go at this today. Hovering about 2 foot above a grassy snowy field, I switched my Tx off. The motors did not cut, as seems to happen to others, but they did reduce, so it just plonked down. When I switched my Tx back on, it slowly flipped over and got everything covered in snow. Not sure what the conclusion is here. Having read the rest of this thread, I will try to reduce the throttle setting to 900, as I had the Failsafe setting at 964, may not have been enough of a difference to trigger the RTL I was hoping to see.

  • Ohoy!!

    Has ANYBODY got the FAILSAFE throttle<975us to work on APM2 ??

    I am trying hard and it does not respond at all. Is that only me??

    Link to wiki

  • There must be some checking in the RTL code that prohibits it entering RTL mode unless throttle is not zero. I set my failsafe on my Rx so it would output 50% throttle and it seems to work now like it should.

  • On my tx jr9503 and jr921 rx I have two types of failsafes. Smart and preset. The one I use stores all channel values during binding and falls back to those values upon loss of signal. So the way I do it is put in the bind plug, power rx and it will fast blink. I then pull the bind plug before turning on tx. Then I set my radio the way I want it if signal is lost. For me this is just putting my flight mode switch on RTL. Throttle I didn't see how matters because RTL will manage throttle. When I test it on the ground by arming and while in stable mode I turn of tx. It shows on mp that rx signal is 1521 in relation to the flight mode channel but the copter appears to stay in stable mode with zero throttle. Not good.

    I'm going to do so e more testing today but it seems this type of fail safe is not working. Anyone else had any luck with this type of failsafe?
This reply was deleted.

Activity

DIY Robocars via Twitter
15 hours ago
DIY Robocars via Twitter
RT @SahikaGenc: AWS DeepRacer & Hot Wheels Track https://youtu.be/4H0Ei07RdR4 via @YouTube
Sep 14
DIY Robocars via Twitter
Sep 8
DIY Robocars via Twitter
RT @davsca1: We are releasing the code of our Fisher Information Field, the first dedicated map for perception-aware planning that is >10x…
Sep 8
DIY Robocars via Twitter
RT @SmallpixelCar: How this works: 1)object detection to find cones in single camera image, 30 frames/sec on @NVIDIAEmbedded Xavier. 2)comp…
Sep 8
DIY Robocars via Twitter
RT @SmallpixelCar: Use two color cones to guide the robocar. No map needed, on onsite training needed. Just place the cones and it will fol…
Sep 7
DIY Robocars via Twitter
Sep 7
DIY Robocars via Twitter
RT @roboton_io: Great to see http://roboton.io running at 60fps on the cheapest #chromebook we could find! #edtech #robotics #educat…
Sep 3
DIY Robocars via Twitter
RT @openmvcam: Crazy in-depth article about using the OpenMV Cam for Astrophotography: https://github.com/frank26080115/OpemMV-Astrophotography-Gear https://t.co/BPoK9QDEwS
Sep 3
DIY Robocars via Twitter
RT @openmvcam: Hi folks, it's finally here! Our first draft of our Arduino Interface Library is out! It works over SoftwareSerial, Hardware…
Sep 3
DIY Robocars via Twitter
RT @chr1sa: Please let them have an open API. This would be perfect for @DIYRobocars races https://twitter.com/NintendoAmerica/status/1301513099707658246
Sep 3
DIY Robocars via Twitter
RT @SmallpixelCar: Lanenet pretty much used all my GPU power on @NVIDIAEmbedded Xavier since I optimized with tensorRT. I need to run anoth…
Sep 3
xemone liked Max Gilson's profile
Aug 31
DIY Robocars via Twitter
RT @LyftLevel5: Our @kaggle competition on Motion Prediction for Autonomous Vehicles is now live! Experiment with the largest-ever self-dri…
Aug 24
DIY Robocars via Twitter
RT @chr1sa: Our next @DIYRobocars virtual AI car race will be on Sept 26th. Sign up here https://www.meetup.com/DIYRobocars/events/272786977/ https://t.co/UENKGSOWO8
Aug 24
DIY Robocars via Twitter
New ready-to-run @NVIDIAEmbedded JetRacer car from Waveshare. Perfect for the next @diyrobocars race as soon as we… https://twitter.com/i/web/status/1297960223013867520
Aug 24
More…