I have been following these instructions in the developer site here:

http://dev.ardupilot.com/wiki/setting-up-sitl-on-linux/

All is good with no errors until Step 6 - Start Up

I get the following - the problem is that SITL can't make properly.  What am I missing?

stephen@stephen-Image0-G6:~/ardupilot/ArduPlane$ sim_vehicle.sh
+ '[' -z '' ']'
++ basename /home/stephen/ardupilot/ArduPlane
+ VEHICLE=ArduPlane
+ EXTRA_PARM=
+ EXTRA_SIM=
+ case $FRAME in
+++ readlink -e /home/stephen/ardupilot/Tools/autotest/sim_vehicle.sh
++ dirname /home/stephen/ardupilot/Tools/autotest/sim_vehicle.sh
+ autotest=/home/stephen/ardupilot/Tools/autotest
+ pushd /home/stephen/ardupilot/Tools/autotest/../../ArduPlane
~/ardupilot/ArduPlane ~/ardupilot/ArduPlane
+ '[' 0 == 1 ']'
+ make sitl -j4
../mk/environ.mk:106: /home/stephen/ardupilot/config.mk: No such file or directory
../mk/environ.mk:108: *** ERROR: could not locate /home/stephen/ardupilot/config.mk, please run 'make configure' first and edit config.mk. Stop.
+ make clean
../mk/environ.mk:106: /home/stephen/ardupilot/config.mk: No such file or directory
../mk/environ.mk:108: *** ERROR: could not locate /home/stephen/ardupilot/config.mk, please run 'make configure' first and edit config.mk. Stop.
+ make sitl -j4
../mk/environ.mk:106: /home/stephen/ardupilot/config.mk: No such file or directory
../mk/environ.mk:108: *** ERROR: could not locate /home/stephen/ardupilot/config.mk, please run 'make configure' first and edit config.mk. Stop.
+ popd
~/ardupilot/ArduPlane
++ cat /home/stephen/ardupilot/Tools/autotest/locations.txt
++ grep -i '^CMAC='
++ cut -d= -f2
+ SIMHOME=-35.363261,149.165230,584,353
+ '[' -z -35.363261,149.165230,584,353 ']'
+ echo 'Starting up at CMAC : -35.363261,149.165230,584,353'
Starting up at CMAC : -35.363261,149.165230,584,353
++ cat /home/stephen/ardupilot/Tools/autotest/locations.txt
++ grep -i '^CMAC_PILOTSBOX='
++ cut -d= -f2
+ TRACKER_HOME=-35.362734,149.165300,586,270
+ '[' -z -35.362734,149.165300,586,270 ']'
+ '[' 0 == 1 ']'
+ cmd='/tmp/ArduPlane.build/ArduPlane.elf -I0'
+ '[' 0 == 1 ']'
+ case $VEHICLE in
+ RUNSIM='nice /home/stephen/ardupilot/Tools/autotest/jsbsim/runsim.py --home=-35.363261,149.165230,584,353 --simin=127.0.0.1:5502 --simout=127.0.0.1:5501 --fgout=127.0.0.1:5503 '
+ PARMS=ArduPlane.parm
+ '[' 0 == 1 ']'
+ '[' 0 == 1 ']'
+ '[' 0 == 1 ']'
+ /home/stephen/ardupilot/Tools/autotest/run_in_terminal_window.sh ardupilot /tmp/ArduPlane.build/ArduPlane.elf -I0
Starting ardupilot : /tmp/ArduPlane.build/ArduPlane.elf -I0
ERROR: Please install xterm
+ exit 1

Views: 921

Reply to This

Replies to This Discussion

Worked it out - just had to run make configure which created the file.

Working now - just have to figure out how to work it.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service