Skywalker 1900 , gridmission skipping patch and not following waypoints correct

Hi all,

After alway's flying manual(20 years)  i wanted to help a farmer to do some arial mapping. I have build a Skywaker 1900 flying nice and trimmed manual and also easy to fly in assisted flight.

In auto (grid) mission it does not follow each path correct and also skipping waypoints, i did already a auto tune on the plane. after that i created a automission with a box and tune the L1 parameter back from 20 to 16 (15 did not get any more accuracy). Changed also the max banking angle from the std 45 to 50, it can do nice corners but for some reason it does not follow the flight path correctly and even worse skipping waypoints

I use a PixHawk 2.1 with the Here+ gps. using Adruplane 3.8.4 and mission planner 1.3.56. All digital servo's running on 4s. GPS signal is excellent, i am out of ideas what to check next. 

I have set overshoot to 80 meter and leadin to 20 meters to help the plane to get on track on time but it does terrible job at it. Way-point radius is set to 10 meters. See attached screenshot

I am not speaking natural English, if something is unclear please ask.

Views: 603

Attachments:

Reply to This

Replies to This Discussion

Ok

Brent,

I've forwarded the file. Please keep in mind that the setup depends on your servos, servo lengths, servo speed ect. This setup tracks like my bird is on rails - very good.

I have a large composite 2.5m V-tail pusher setup that lifts a larger 800g camera that had the same issues as yours. I had bad path tracking and long sluggish turns. Eventually I found the problem to be - don't laugh - my rudder direction in the FBW, Stabilize and auto modes were in the wrong direction.

Have a good read at the yaw control in this part:

http://ardupilot.org/plane/docs/roll-pitch-controller-tuning.html?h...

I hope you find your solution.

Good luck.

Hi Antonie,

Got the param file looking into it. Work was interfering with this project , hoping to do some more tweaking and testing this week , if it's staying dry outside

It's from a Skywalker 1900 correct ?

Hi i looked at that part already a couple of time's i don't believe it in the wrong direction , it seems to be ok it i do a dry run on the ground, what i do see is that the rudder does not correct much when i turn the plane on the ground when it's in FWBA mode.

Antonie Kruger said:

Brent,

I've forwarded the file. Please keep in mind that the setup depends on your servos, servo lengths, servo speed ect. This setup tracks like my bird is on rails - very good.

I have a large composite 2.5m V-tail pusher setup that lifts a larger 800g camera that had the same issues as yours. I had bad path tracking and long sluggish turns. Eventually I found the problem to be - don't laugh - my rudder direction in the FBW, Stabilize and auto modes were in the wrong direction.

Have a good read at the yaw control in this part:

http://ardupilot.org/plane/docs/roll-pitch-controller-tuning.html?h...

I hope you find your solution.

Good luck.

Hi,

I did read the Yaw Controller tuning (again) and compared my parameters with the parameter file i did get from Antonie. All parameters mentioned in that section are the same with my settings. 

I do have some spare time next week to do a test flight again, i will try a bit more aggressive bank limit , and will tune the L1 more down. I also will try the 150M overshoot and 70M lead in and set the camera trigger to distance.

I some one wants to have a look at a logging file(or parameter)  i can upload one

I tried a 150M overshoot ( even 275meter ) and 70 ( 125) leadin. result of mapping are still the same (usable due to luck) , L1 is now on 11.

Seems to be holding the grid (still to one side) but is unable to get the corners correct , i used a 3 line separation.

Next time i will set the YW2SRV_INT and YAW2SRV_SLIP to 1 and see what is happening and tune from there. I also will increase the RLL2SRV_P to 1,8 i found this setting on the adruplane home page as starting point for the skywalker.

I still believe the answer is in the rudder. Just try trimming a ton of rudder in next time you fly the grid and I bet it will slide back onto the line.

I recently updated firmware in my apm in my skywalker 1900 and also have tracking issues. It flies S curves along the flight lines in a mapping mission. I do 400 meter overshoot and 100 meter lead in, might as well give the plane as much time to get back on track especially when mapping, this is critical. I do not know why my plane is flying such terrible lines now. Second issue is camera triggering, my camera will randomly trigger, I’ve tried setting to 20 meter distance, using IR sensor on Sony nex5. It used to work but now it does not, not near enough images taken to create a map. I tried 5 meter distance firing, this helped but still not near enough images taken. Any ideas? Maybe I need to upgrade my autopilot to something newer. 

HI  Darryl

Some suggestions :

1. You must do a proper auto tune on your bird - start here : http://ardupilot.org/plane/docs/automatic-tuning-with-autotune.html...

2. Make sure your rudder control is in the right direction in the Stabilize modes(FBW ect.)

3. Work through this in detail - the S curve across the navigation line can be tuned out : http://ardupilot.org/plane/docs/navigation-tuning.html

4. The camera trigger distance is set up in the mission planner and depends on you altitude, camera sensor size, orientation and overlap.

Some comments about using your own timing:

a. Flying at 15m/s and requiring an exposure every 5m will require the camera to take a pic every 0.333 seconds. That will not happen. You would require around 1.5 to 2 seconds between exposures for the camera to capture, process and store the picture.

b. At 20m is still very close and not enough time for the camera to process and store.

I would suggest around your camera:

a. Let APM manage the exposure distances based on your mission planner as per variables mentioned above. This way you also make sure that you do not have too many pictures and waste a lot of time processing them.

b. Get the fastest memory card you can find for the camera. That is a bottle neck.

c. Do not use autofocus on the camera. Set the focus before you take off. The camera does not do well if it has to autofocus.

d. I use shutter priority mode with auto white balancing and auto ISO. Shutter speed at 1600 to 2500.

e. Make sure the IR shutter command is trigger only and not focus and trigger.

f. I use jpg format only. There is not enough time to move the large raw files to memory.

Good luck

Thanks Antonie, I will try the autotune, I believe I did this when initially setting it up but haven't since updating firmware.  I completely understand how the trigger should work but for some reason it doesn't trigger very often.  The reason I tried setting it up at 5 meter distance was to get the camera triggering more often, I can trigger the camera by hand every 1 second and it will keep up with recording images. I have camera setup completely manual settings including manual focus, shutter, iso and aperture.  I will try setting it to trigger every 30 meters or so and see if that will work, but I have a feeling not as when set to 20 meters I only got a hand full of images from a 15 minute grid flight. It's a sled V2 trigger, set to 1500 not pressed and 1000 pressed, works when testing it on the ground doing the "test fire camera". Am also using JPG file format. Not sure what else I can do to increase triggering on the camera, again it used to work before upgrading to newest firmware.

Hi all,

I was observing the plane in auto mode , and i notice it was giving a lot of power in each corner. So i turned down THR_SLEWRATE to 2. Corners are almost spot on now.

Still having some issues with following the flight path. Sometimes i have a to large gap between  the lane, but not always. Does narrowing down the wp radios help ( or enlarge)  ? more overshoot (200 meters)  and leadin ( 125 meter)  ?

For those with skywalker what did you use and worked out for you ?. I did reduce L1 to 14 don't now if lower make sense for the skywalker 1900 ?

 

I also have looked at the ay parameter in the tuning window in flight  that one is all over the place from 100 to -100 sometimes more not a clue how to get that to 0. tried the adjust the suggested items in the tuning the side-slip controller but did not get it down.

So all those items are standard again, any Suggestion ?


I did fly the plane again in full manual mode not any trim is needed for keeping it flying straight.

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service