Hello,

Here are key points in a few words:

  1. The "BAD ACCELL HEALTH" error may be induced by two different causes:
    • IMU1 error - MPU6000 soldering issue while production in some early batches of PixHawk. Currently is fixed by 3DR.
    • IMU2 error - LSM303D improper discharge process during power off.
  2. This solution is only for the LSM303D case.
  3. Needed hardware parts always were there. They can be controlled by FMU firmware.
  4. For some reason this feature seems has never been used in FMU initialisation. But it was always accessible via nsh CLI as "fmu sensor_reset" command.
  5. It seems the reason why it isn't used in FMU initialisation is a bug in sensor_reset function. It breaks SPI functionality in firmware.
  6. The fix for broken SPI after "fmu sensor_reset" is here.
  7. It permits to use sensor_reset function in FMU initialisation to properly discharge IMU2 to avoid IMU2-related BAD ACCELL HEALTH.
  8. It has been implemented as firmware fix and available here.
  9. Pre-built 3.2.1 image with mentioned fixes are available here for testing purposes.
  10. Currently I testing v3.2.1 fixed firmware. You can do the same on your own risk.
  11. There is a chance it will not resolve the issue. Then hardware fix will be needed. It is proposed below also.
    • It could be implemented with a minor design change (Q601 replacement).
    • Also it may be implemented as post-production hardware workaround (SMD resistor soldered on top of C506).

UPDATE 1: 20ms is not enough

Tests were performed with some number of flights. This fix don't breaks anything. But it doesn't work with 20ms discharge time. Going to increase it up to 1s, but I have not too much hope it will do. It seems pure software solution will not fix it w/o hardware fixes.

UPDATE 2: It depends on temperature

I have two items of HKPilot32. I flashed item #2 with original ArduCopter-3.2.1 Item #1 already flashed with 1s power reset fix. I put item #1 in refrigerator and started with item #2.

Powering attempts numbered as they were performed in common sequence. Powering cycles were performed by battery disconnection and connection back. To reproduce issue a disconnection time should be less than 1 second. My results are below:

Item #2, original 3.2.1, room temp about 22C
--------------------------------------------
bad: 2 4 5 6 7 8 9 10 11 12 14 15 16 17 18 19
good: 1 3 13 20

Item #2, 1s reset fix for 3.2.1, room temp about 22C
------------------------------------------------------
bad: -
good: all from 21 to 40


WOW! Doesn't it work?! Let's check it with cooled item #1.
I took item #1 out of the refrigerator and put there an item #2.


Item #1, 1s reset fix for 3.2.1, from refrigerator
--------------------------------------------------
bad: 43 44 45 46 47 48 49 50 51 52 
good: 41 42 53 54 55 56 57 58 59 60

No luck. What about to warm it a bit?


Item #1, 1s reset fix for 3.2.1, after 30 minutes in room temperature
---------------------------------------------------------------------
bad: -
good: all from 61 to 80

It looks like it works for room temperature! But what about cooled item #2?


Item #2, 1s reset fix for 3.2.1, from refrigerator
--------------------------------------------------
bad: 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100
good: 81

Being cooled it doesn't work again.

All logs are here. Next step I going to play with 5sec power reset on cooled FMUs..

UPDATE 3: It mostly works for 5 sec power reset time

Item #1, 5s reset fix for 3.2.1, from refrigerator
--------------------------------------------------
bad: 107
good: 101 102 103 104 105 106 108 109 110 111 112 113 114 115 116 117 118 119 120

With 5s reset time it looks like it mostly works for the same item and same temperature.
Also it seems for the attempt #107 I've had really small (about 0.2s) disconnection time. It is an unlikely scenario of actual copter use.


Link to test image is updated, now it have 5sec reset time fix. It would be nice to have test results from people suffering from this problem.

UPDATE 4: It seems temperature dependency is not about capacitors

I measured discharge process on C506 of the same FMU item for two cases: a) FMU have room temperature and b) FMU has been cooled 30 minutes in refrigerator. It appears that measured values difference is really subtle. It is about 20mV difference for discharge level on 5 sec period. So it seems the temperature-capacity dependence is not a factor for this issue.


UPDATE 5: MOSFETs test results

Performed tests with SPICE models and in hardware (a number of MOSFETs were used) demonstrated that issue cannot be resolved reliable w/o hardware fix due to the fact Rds goes high when Vds and Vgs going down. VDD_3V3_SENSORS rail needs to be connected to GND via 220 Ohm resistor and it still need a software fix. As result the EN1 input of mic5332 doing its job perfectly w/o any MOSFETs. But it will not work reliable for the case with resistor connected between any other power line and GND, this way the issue still possible to happen for cases of short power disconnection.

UPDATE 6: hardware fix is enough for most cases

I must admit that it seems working ok even without a software fix. Just performed a number of tests with original ArduCopter-3.2.1 firmware on cooled (all night in refridgerator) board with 220 Ohm resistor which is installed in parallel to C506. As result: by disconnecting and connecting battery back with my hands I was unable do it in enough short time to reproduce issue. All logs from attempt 121 through attempt 140 are showing IMU2 works just fine. Software fix still needed for non-fixed boards only. In case you are able to (de)solder SMD parts the better place for resistor is instead of Q601, you need to desolder Q601 and solder resistor on emitter and collector pads.

Owners of non-modified boards are have to wait for a software fix. It have a chance to be included in ArduCopter-3.3.3.

Here is a long story:

Some time ago I decided to switch from APM to PixHawk, so I bought two items of HKPilot32 FMU from HobbyKing. So far I can see they are clones of PX4 FMU v2.4.5. Boards are labeled as "px4fmu-2.4".

Those days I had not too much experience with PX4 platform, so all intermittent issues and misbehaving were considered as a lack of my skills. When I first stuck with BAD ACCEL HEALTH issue I googled for the issue and found some mentions of power filtering and so on. So I decided to put some ferrite rings on power lines to FMU and FPV, to decouple possible noise and spikes on power lines. It seemed as it helped me for some time and I've seen no more BAD ACCEL HEALTH for a long time.

But later it happened again. So I decided to investigate it in a more details and googled this thread.

While checking my DataFlash logs I realised it wasn't MPU6K issue. It was definitely LSM303D issue. I read through all in the mentioned thread and I collected all important points together in a single document. Also I collected there some important points drom other forums like HobbyKing and Plololu. (All 'hello' and 'thanks' were skipped.)

I discovered that possible key to the problem is in the message by Artem on February 19, 2015 at 11:48am: "first hit is pololu community forum thread. Apparently lsm303d is very sensitive to how it needs to be powered down". So I googled once more and found original message on Pololu forum: "When we were testing the accelerometer on the LSM303, we noticed we could get a similar behavior where the accelerometer constantly reported a single value for all axes. It seems that if you interrupt power to the accelerometer in a certain way (like disconnecting or turning off/on power) so that the voltage falls below a certain amount but not all the way to 0, then it can brown out and get stuck in a bad state".

So I disassembled my HKPilot32 and downloaded all pix4fmu-2.4.5 schemas and pcb layouts. As you can see there are capacitors (C506, C507) on VDD_3V3_SENSORS net close to LSM303D, also there are some capacitors on the same net close to LDO and some capacitors should be close to other sensors:

Having a hope that I would be able to solder SMD resistor on top of C506 I found exact location of C506 and started to measure LSM303D power voltage on C506 pins:

Here is how LSM303D power drops down once battery get disconnected. There are no any other modules connected to FMU or PM (Power Module). As you can see it takes about 50ms to drop on level 0.8V and it takes about 0.1 sec to drop on level 0.6V. And it doesn't fall below 0.344V even after 1 minute since battery get disconnected from PM. It's definitely not good. And it can be even worse in case other modules are connected to FMU or PM.

I was ready to solder SMD 1k resistor on top of C506 when I suddenly discovered Q601. Then I traced VDD_3V3_SENSORS_EN net and..


WOW! It is controlled by PE3 pin of STM32F4 and it is there definitely to discharge sensors power line and to shutdown LDO output. By design it looks like it should do sensors power line shutdown in a proper way. It was designed to do exactly that we need to avoid BAD ACCEL HEALTH.
So why it doesn't work, what I missed? Broken Q601 transistor? PCB issue? Anything else? Well, let's measure it on R620.

To shutdown sensors power line the base of Q601 should go down with logical zero on PE3. And I believe it should happen on FMU initialisation. Ok, FMU is powered, pushing reset button..

During FMU initialisation it goes up for some (really long 5.4sec) time, until PE3 will be configured as an output. Ok, no problem. Then I setup trigger for my oscilloscope on 3V level to catch voltage drop and no luck. It means Q601 doesn't receive logical zero from PE3 on FMU initialisation. At all.

NOTE: Hereafter I will refer to source code of version 3.2.1.

Ok, it's to time to dig the source code. What about to grep PX4Firmware sources for "SENSORS_EN" word? Here it is. It is used in "sensor_reset" method to do exactly what we needed. Let's see where "sensor_reset" methods is used. Nowhere else, for the moment of v3.2.1 released it is used just in the same file "PX4Firmware/src/drivers/px4fmu/fmu.cpp". What about v3.3.1? Checked, the same.

After browsing fmu.cpp file I can state definitely: for versions 3.2.1 and 3.3.1 it is used just to provide ability to run nsh command "fmu sensor_reset" with an optional parameter. Nothing more. And it definitely doesn't used by FMU initialisation process. Ok, let's try to execute "fmu sensor_reset 20" to shutdown power line for 20ms.

It works! As you can see it falls down to 0.8V in 1.8ms and to 0.6V in 10ms.

The bad side is that it doesn't falls down to zero due to Vce(sat) parameter value for Q601. Q601 is BJT transistor of type MMBT3906 and it have Vce(sat) from 0.25V to 0.4V. So VDD_3V3_SENSORS net cannot be discharged below Vce(sat). In case a pure software solution with PE3 and Q601 will not do for BAD ACCELL HEALTH, then design for Q601 should be changed to use some MOSFET instead. It permits to discharge sensors power line much closer to zero level. Also there are low Vce(sat) BJT switching transistors on the market.

The good side is that level of power line discharge isn't an only important factor of issue. The rate of discharge may also affect LSM303D behaviour and we able to fix it right now. Anyway, here is chance it will do so let's try it.

I implemented it this way and performed FMU reset by pressing reset button. Next moment my board is turn on multicolour LED as red and it means a error while initialisation. I connected to PX4 terminal and found following startup error messages:

Starting APM sensors [MS5611_SPI] on SPI bus 1 at 3ms5611: interface init failed
Error in startup

Then I turned on debug messages and realised that SPI is affected:

Starting APM sensors [MS5611_SPI] on SPI bus 1 at 3ms5611: prom all zero
ms5611: prom readout failed
ms5611: interface init failed
Error in startup

After some reading of "sensor_reset" source code I discovered the cause of SPI issue. It doesn't enable back SCK/MOSI/MISO pins after reset. So I fixed it and then FMU loads ok.

As a bottom line:

  • I unable to see why mentioned hardware feature (Q601) being known for a long time is never been used in FMU initialisation.
  • It may fix IMU2-related BAD ACCEL HEALTH issue. Needs to be tested.
  • In case it will not, then really minor design changes are needed to fix it in reliable way.

Comments and corrections are appreciated!

Regards, Dmitry Prokhorov

Views: 22752

Attachments:

Reply to This

Replies to This Discussion

Ok sounds good I will try.

How do you think this could affect the variance issues between two IMUs due to temperature in mid flight ? Does a full reset of this sensor mean a fix for varience as well OR is this just a fix for being able to pre arm and fly but still with risks using IMU2 as well. Not sure if I am clear enough.

I unsure but I pretty sceptic this could affect it. So far I can see it's just for being able to arm and to use IMU2 on air. But how exactly IMU2 behaves on air it could be (and most probably it is) another issue.

In case you mean a risk for IMU2 to stuck in a wrong state, I suppose no. Once started ok it should run ok.

In case you mean a risk for variance issues between two IMUs, sure it is possible.

I believe IMUs mid flight variance issue could be fixed with new algorithms and code improvement. Anyway this story about maths :)

Dmitry,

Have you had a chance to discuss this change to 5 sec reset with developers ? If the change is effective. Would they be willing to include this in official release you think ? Like could it potentially cause other issues...

It took me a while to get my 3.3 working with new PID values and its now flying good with one IMU. If I want to use 2 IMUs I just bleed capacitance as suggested before and that works. I don't feel like re-flashing my board for now. (Too much headache :) )  Hope you understand.

I really don't want to take apart my drone but I wanted to test those capacitors and if they are out of tolerance. That could also be a potential fix. A change of capacitors c505 and C506.

I have all details of my investigation published here in this topic. I was sure it could be pretty enough to propose a communication on the issue. And I really unsure on how else to have a chance to discuss it with developers.

Here is a problem possible with this topic. I am not native speaker so my English is not so good and my style of explanation may look like improper or too ambitious. So it may prevent developers from responding me anything. Also it may be considered as an attempt to discover 3DR secret know-how. Unsure..
Anyway topic is really important and visible to all. Yesterday it was on 9th position on Top Discussions list. So I just wonder why nobody from developers responded so far. Maybe I conflicted with some non-formal policy. Have no idea.

About "to much headache" - no problem :) I can understand you really well. Anyway thank you very much for your help! I crashed my drone a bit due to wind gusts on its last flight, so I need some time to repair it and perform more tests. Maybe this weekend. Also going to build and publish fixed 3.3.1.

As soon as I will have stable positive results for my fix I going to create pull request to PX4Firmware original sources repository. It's kind of formal process for fixes. Then we would be able to see will it be accepted or not.

That's about capacitors, yesterday I measured power-off discharge process on C506 for two cases: a) FMU have room temperature and b) FMU has been cooled 30 minutes in refrigerator. I not published these results just due to the fact that measured values difference is really subtle. It is about 20mV difference for discharge level on 5 sec period. So it seems the temperature-capacity dependence is not a factor for this issue.

First of all your English is superb ! Is definitely more than enough to explain in detail. So that is no factor at all.

I was not sure of your role in this forum as I am very new here so I did not know if you have any specific contact with developers. I think the post is very visible due to the high activity. You have enough detail. The reason why I think it does not get a lot of attention from developers is because the HW that has this issue is not 3DR genuine. That's my personal opinion. And i think you have done some great investigative work. You and another active member have pinpoint the exact issue. (pretty much) 

What I was thinking the temp is probably not affecting the capacitance but I was wondering if the capacitors are not within tolerance.

I also do agree that at the moment the firmware only compares the difference between the two IMUs but cannot necessarily tell which one is the faulty one. It can only say YES there is a difference.. (Comparator logic)

On this forum I just a newbie. Nothing more.

About IMU values difference.. It means we need third one :)) And it should be a third type of IMU, not lsm303d or MPU6K. It could improve reliability a lot.

Dmitry,

Thanks for this excellent analysis, and you can be sure, that even  English not being your native language, you explain yourself perfectly.

I have been following this thread at drones discuss for some time ( more concerned about L3GD20H)  :

https://groups.google.com/forum/#!topic/drones-discuss/fnWYM48pGys%5B1-25%5D

So you can be sure developers are aware of this problem. Or at least they are aware there is some sort of inconsistency regarding the LSM303D or the L3GD20H.

Also Paul Riseborough points out a better performance of the MPU6000 gyros vs L3GD20H using EKF2.

https://groups.google.com/forum/#!topic/drones-discuss/iT_Qsx8VjhE

Is there any way of software disable both LSM303D and L3GD20H,  and just rely on the MPU6000? (or maybe disable and add an external MPU6000 as IMU2) ?

Congratulations, very nice work.

leolo,

Thank you very much for pointing me to these discussions on google groups! It seems I missed them somehow. Going to dig it.

Suppose you can use INS_USE2 parameter to disable usage of IMU2: http://copter.ardupilot.com/wiki/arducopter-parameters/#use_second_...

i have tried that and have been flying with IMU1 with no issues. (so far) 

Hi Dmitry,

I have the same issue with a Droppix board (the french Pixwhak like's).

Normaly, my Droppix is powered by the "power module" and by the ESC via the receiver and the pwm/ppm conveter. In this configuration, it's working perfetly.

The last week, because i need to have the possibility to switch OFF the Droppix only and not the receiver, i decide to use only the "power module" and cut the positive cable comming to the PWM-PPM converter. After this modification, i alway have the "bad accel health" issue when i restart it.

My solution to resolve this issue, i simply soldering a "mini" super capacitor (0,1F-5.5V) between the 5V positive/négative power pin of the Droppix.

I never had this issue before, just because there is some big caps inside the ESC module who delay the power-down of the Droppix.

Regards

I just realised this issue was known for two years. For some reason it hasn't been investigated in details.

I found a group where it seems developers are communicating actively. So I created new discussion there and referred this discussion also.

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service