I have an APM1 in my Skywalker and having some issues. I have the most recent ArduPlane firmware.

Manual Mode seems to be good, and all the sensors seem to be working as expected. GPS, Airspeed, and magnetometer.

- First thing that doesn't look right is Flight Mode 6 is disabled and I am unable to change it.

- Second thing is when I switch from Manual to Stabilize (or any other mode) the motor spins up to about half throttle.

When in stablize mode, the servos seem to work as expected. It looks to be stabilizing...but not sure why the motor is spinning up.

I have reinstalled firmware a couple times. With the same results. One of the installs...it seemed to be working well for a while...then about 20 seconds later the motor kicked on.

I have also had random instances of servos doing what they want in stabilize.

Can anyone point me in the right direction?




Views: 794

Reply to This

Replies to This Discussion

The version from Mission Planner should be fine.  Did you get it from there?  There was a cutting edge version in the github that has problems with flight mode1 and flight mode2.

Yes. I got it from the mission planner today. Anything else I could look at?

Thanks for your help.

Well, this is a little worrying.  With such behaviour, I don't recommend that you fly with this version until the issue is looked at.

Can you open an issue here:



flight mode 6 is hardware manual, and is never changable.

given that, is your manual mode what you are expecting it to be.

also, what receiver/transmitter are you using? your esc should be pluggd into output 2 or 3 on the apm, depending if your numbers start from 0 or 1


Stabalise had throttlew passthrough, so at this point in time i would check your radio connection to the apm, and your esc output as above.

Hi guys. Thanks for the advise. I will be working this again tomorrow night and let you know the outcome.

Thanks again.



I think the problem is fixed. But to answer your questions I am using a Futaba R617FS.

To fix this issue...I ran the reset command from CLI. Haven't had a problem since. I didn't know this had to be done. I thought the same type of refresh would be done upon a new install of the firmware.

I will keep testing it until the wind dies in Colorado.

Thanks again.

Is anyone flying with the current version of ArduPlane?

After a couple days of testing on the ground things looked good and I flew the plane in manual mode. It flew good with no problems.

I tested Stabilize on the ground and it was working good.This was tested over an over again before flying due to the issues above.

When I switched the plane from manual to stabilize in the air...The nose pointed toward the ground and I was unable to override with the controls. I tried switching back to manual...and that didn't work either. It would not go back into manual mode. I completely lost control.

No more skywalker... Does someone have a different version ArduPlane I could use? Has anyone else reported problems with this version?



Hi Ross, I Have the exact same problem as you have being the 1/2 throttle on automodes but everything seemed working fine on the ground. I launched in stab mode and where yours pointed to the ground mine pointed straight up untill it stalled. I also couldn't take control back. Skywalker nose totally smashed I even got stone embedded in the airspeed sensor pipe.

I'm using the V2.30 release but I don't remember if I did the reset procedure from the CLI maybe I shouldhave. In the configuration tab did you install a param file for your skywalker? I applied http://ardupilot-mega.googlecode.com/files/SkyWalker062311.param but now thinking of it, it might be the file for the smaller Skywalker. I have the Skywalker V5 169, which one do you have?

Did you solve your problem? I'm Going crazy...


Hi Steven,

I never got this problem resolved. I have a new Skywalker ready to fly but not using the Ardu as a stabilization system.

In regards to the half throttle...I think it is directly related to the SkyWalker config file. If you reinstall the firmware and do NOT load that config...it will stop going to half throttle...but still not safe for flying. I thought the problem was fixed since it didn't go to half throttle, but I was wrong.

One test I found safe is...do a flight in manual mode for about 10 minutes then land. Then switch to stabilize mode once its on the ground. When I do this...All my servos go crazy and I am very thankful to not have done it in flight

Due to the issues I have had both the Plane and Tricopter software, I have stopped using the ArduPilot as a stabilization system, and only use it for the logs. Sorry I couldn't be more help.

To anyone who the throttle going to about half or so problem when switching to Stabilze...I had and just solved this problem. I had set my min throttle to 45%, so in Stabilize it went to that. Reset your min throttle to 0%, problem should go away. I personally do not like that stabilize obeys the min throttle PID. I set mine to 45% so that if I turn downwind (I do not have an airspeed probe) the throttle will not reduce because a strong tailwind makes the APM believe the speed of the plane is fast. As far as I know the throttle will vary to maintain a groundspeed. Does anyone know if this is true? 

I think we should add a PID that allows idle only when commanding a descent, and a PID that allows some other min value for cruise flight so as to prevent airspeed ever from dwindling.

Maybe there is something I don't understand, but it worked for me.


I have the exact same issue - v 2.34 and 2.40.

It is generally stated that in stabilize and FBW-A the throttle is passthru, but this is definitely not the case.

The THR_MIN parameter is applied in both modes and when switching into these modes it is not possible to get the throttle lower than this value.

Is this the way it works or am I missing something?

In my particlular application I do not want autopilot to throttle back to less than 30%, but I do want  to land in stabilze mode and need to be able to close the throttle completely.  How can this be done?



Purple Dragon

Reply to Discussion


© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service