Hi, I am still having problems to get my radio controls in order for my hexa. 

After a couple days of absence, I tried again today to get my radio calibrated, and it still didn't work.
I did receive a message after all from the supplier. I send them a picture of my receiver connections and they said they were right, that is after I changed sides for the cables as was suggested.
I also changed receiver and 8CH transmitter (as I have 2, the second one meant for videography later). It is a Walkera 8CH. Still no success.
I put on the transmitter in plane mode today, put on lippo after taking out the 4-power-wires, connected the USB to MP, clicked on connect with success (a red LED blinks in the receiver), clicked on APM setup in firmware, clicked on calibrate radio in the radio setup,  I see the green bars and small red lines, but when I move the sticks on my transmitter to go to the maximum, these green bars don't move at all. I only have 1500 readings, which mean no connection, no ?  What am I doing wrong ?

I did this inside so no GPS lock and no internet connection, as I supposed this was not necessary for radio setup, but maybe I'm wrong.

Can anybody help me out maybe ? It's frustrating I still couldn't fly my hexa after more then two weeks.

Thanks. Filip

Views: 340

Reply to This

Replies to This Discussion

I am having a similar problem. I am using a DX-8 controller with an APM board set to be a hexa. No matter how many times I have tried I can never calibrate the radio. I don't see green bars or anything in the setup menu. I have tested the receiver with a servo to make sure it works properly and I have checked every other thing i can think of.

If you fix your problem please tell me what you did

Thanks

First thing to check, after it is all powered on, is the blue LED on the APM (red) board. When the IMU and APM are together, it is underneath the USB connection. Is it on solid (no PWM detected), blinking slowly (failsafe - lost PWM signal, blinks ~ 1 per second) or quickly (PWM is detected by APM, ~ 5 blinks per second)

Don, I always had the very rapid blinking of that blue LED on the board !
So, that means there is radio contact ?
I just did the test with a servo. The receiver was powered I suppose, as there was a red LED blinking. But when I moved the stick(s) on the transmitter, nothing happened, the servo didn't move.
Does it mean I have no connection between Transmitter and Receiver ?
How can I fix this ?
Greets.
Filip

I tested my receiver with a servo and everything is fine. the servo moved on all channels that I tried (1-4). However, I have two APM boards. The blue LED that you are talking about comes on solid blue (no blinking) on one of the boards, and on the other it is not on at all. What could my problem be?

Hi Filip,

Rapid blinking is actually good. 

Is your APM powered through USB only or did you connect your battery pack (BEC...) to the APM input/output rail? -> The USB board does not has sufficient power to power your RX. 

power supply is: Battery pack -> BEC -> 5V -> APM in/out rail-> RX 

 (most of the times there is a light on the RX to indicate power -> only if this is illuminated you got power)

 -Tobias 

 

PS: did you try (connect to APM through USB/FTDI COM 3) -> MissionPlanner->Terminal->tests->radio? Maybe you get here some more signals (or try if you get IMU/INS data, then you know at least that you're talking to the APM).

 

 

   

HI TOBIAS and anybody else,

My APM was powered through the lipo, ESC's disabled, Red LED blinking in RX. Is the blinking OK, or should the LED be solid ? 

I did not try to go through terminal, I don't understand that CPI language, but as said before, I got no movement in the green bars in the setup. 

But, more importantly, I tried to test my RC with a servo and separate battery (through UBEC), and I got no movement at all of the servo, moving my TX sticks. The red LED was still blinking in the RX, so power was OK.

So, I suppose I also have a basic RC problem. Or maybe that's the main problem that prevents me from going forward with my hexa ? Help.

I'm totaly stuck.

Filip

This could be something as simple as binding. Look in the users guide of your radio and find the binding procedure. Assuming that it is a 2.4ghz system.

Red blinking in your RC Rx means that it isn't bound to your RC transmitter. Please rebind.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service