I am as beginner as it gets.

I ordered this:

http://www.banggood.com/Mini-APM-V3_1-ArduPilot-Mega-External-Compa...

The one I got looks like this:

I attempted to follow this for setup:

https://www.youtube.com/watch?v=Zv49LdcaLv0

I keep getting stuck after the firmware is uploaded and verified. I have tried the latest release of the mission planner software. It gets stuck right after the firmware is verified and I click connect. It can't connect. If I use the wizard, it gets to the point where the little box pops up and says "get params". It does not advance past that.

I get the same result with the two previous releases.

I also tried it with the release the gentleman is using in the youtube video (1.3.16). I get a little further with this one. If I follow the video exactly, not using the wizard, It does connect and gets to the point were it says "Got param RC1_MIN". It does not advance past this point

I have tried 4 different usb cables. I have tried every usb port on my computer. I have tried identical strategies more times than I can count. I have looked through some forums. I have not found a solution.

Does anyone know what I am doing wrong? Does anyone have ideas they would be willing to share?

Thank you

Views: 1404

Reply to This

Replies to This Discussion

The power adapters are ACSP4 which has the 6 outputs built on the board so you can use it as a distribution board.  The ACSP5 is just a power module with no distribution just straight through.  You have to provide your own battery connector and wire on both options.

You could use your APM power module but you would need to make a cable from the power module to the Pixracer.  Or you could solder the power cables from APM power module to the ACSP5.

Sadly the firmware for this unit is a little up in the air right now.  APM is in development stages and PX4 flight software is ok but you would need different software to work with it.

APM3.3.4 pixracer firmware works ok and has most functions of this board working so you can start there and when the firmware catches up you will be in business.

So I got that pixracer in, we built up the quad. We were able to calibrate the sensors, but unable to get it to communicate with the transmitter and reciever. Not sure how to connect the R9D to the pixracer.

I'm also running out of time on right now. If we cant get it working in the next couple days, I'll need to get something decent that handle a gopro so I can shoot video for the next two months and then come back and try to complete this build. Does anyone have a suggestion of a out of the box drone I could pic up so I can get ariel video with this gopro for the next couple months?

https://drive.google.com/open?id=0B-1SJ-5JyqcwWlk0UHJkdDM1Um4zQnY1S...

https://drive.google.com/open?id=0B-1SJ-5JyqcwUGt1a2ZlN240YnZIbUlwL...

To use the R9D with a Pixracer or Pixhawk you need to ditch the individual cables and just use one cable connected to 9.  They even have a video on how to do it.

Do you know where I can find that video?

This is a video connecting to a NAZA which is basicly the same as Pixracer which uses SBUS.

https://www.youtube.com/watch?v=NCXxlZp6TAA

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service