I am as beginner as it gets.

I ordered this:

http://www.banggood.com/Mini-APM-V3_1-ArduPilot-Mega-External-Compa...

The one I got looks like this:

I attempted to follow this for setup:

https://www.youtube.com/watch?v=Zv49LdcaLv0

I keep getting stuck after the firmware is uploaded and verified. I have tried the latest release of the mission planner software. It gets stuck right after the firmware is verified and I click connect. It can't connect. If I use the wizard, it gets to the point where the little box pops up and says "get params". It does not advance past that.

I get the same result with the two previous releases.

I also tried it with the release the gentleman is using in the youtube video (1.3.16). I get a little further with this one. If I follow the video exactly, not using the wizard, It does connect and gets to the point were it says "Got param RC1_MIN". It does not advance past this point

I have tried 4 different usb cables. I have tried every usb port on my computer. I have tried identical strategies more times than I can count. I have looked through some forums. I have not found a solution.

Does anyone know what I am doing wrong? Does anyone have ideas they would be willing to share?

Thank you

Views: 1417

Reply to This

Replies to This Discussion

I'm not an APM board person as I started with the Pixhawk.  The latest firmware for APM is 3.2.1 which should work on this unit.

The design seems flawed to me.  First off you have all these cables that are going to connect to another wire which makes thing harder.  Second you going to connect 10 wires from your receiver which adds more wire.  With the new flight controllers they use SBus or PPM so you only need 3 wires for the same configuration.

Look at the PixRacer as it gives you more features with less wire and only double the price.  It also has a buzzer to let you know it loaded correctly.

The first thing Mission Planner does is read the parameters from the flight controller so if it connects and then stops there it's not loaded correctly on the board.

The mini APM is a perfectly good flight controller. But don't discount how unbelievably a pain both APM and Pixhawk are with USB cables. First have a USB cable with a rf choke in it. The ones with a knot or "blob" somewhere on the cable. Then try a different computer. Then try an external powered usb hub. Then try a different computer with a different operating system.

try APM Planner 2 , if you get same results...  something is fishy with the device itself.

Thank you for the responses so far, guys, thought I haven't gotten any further with it. I've tried every micro usb of mine and my 2 roommates. I've tried more releases of mission planner. Sometimes all the drivers install. Sometimes they don't. I'm still only able to get as far as "Got param RC1_MIN". It stops at the same point every time, every release (with the ones that get that far. the others just get to "getting params"), every cable, every port. I'm starting to suspect it is probably the APM board. How do I "flash" the board? Is that just when I upload the firmware? When I hit that reset button on the board, is that wiping the countless firmware uploads I've attempted?

I'm getting this result with APM Planner 2. I've followed that path, and it's either not there or I can't find it. Did a search and nothing came up either. Every time I try it, it seems like it generates the same file with some random numbers after it, and then that file disappears. 

Have you used a USB with a rf choke? It makes a difference. You can use 50 different USB cables without one and it won't make a difference. I ordered 10 different USB cables and the only one that works for me is the one with the RF Choke. Next the drivers often will not load if you have anti-virus or other such blocking installs of new software.

Last think of the fc as having two areas of memory, where the firmware is stored, the program the runs the flight controller, and where the variables are stored - the parameters that set options you choose. It is possible for the parameter memory to get corrupted.

So you can reload the firmware but the parameter memory stays the same. So you need to erase everything on the board. People do this in a couple of ways. You can get most but not all of the parameters erased by loading a different firmware, like one for the antenna tracker or Rover.

The best way is to load 3.1.5, which still has the terminal, connect to terminal. At the prompt type:

setup

erase

reset

Then reboot the fc and install whatever firmware you want at this time, if other than 3.1.5.

This APM planner 2 must be old, v2.0.20 (which you should be using)  would be getting firmware from  http://firmware.ardupilot.org (not the old diydrones.com location)

I use just about any USB cable and they all work just fine.  You have some other issue.  Before you flash the unit with Mission Planner, if you pull the port settings box down does it identify the board you are connected to or just say serial device.  It needs to say what board is connected.

First, MP does not have to enumerate the type of com device for it to work. Two, clearly he is selecting the correct com port if he is flashing firmware.

If it doesn't have the port named correctly then the drivers are not loaded correctly.  Loading firmware requires more band width then reading the parameters.  I have had problem when the driver wasn't loaded correctly.

If he can load the firmware then it's not the cable anyway unless it not really loading the firmware.

You should see the programming bar move across as it loads.

I had a friend over last night who understands this much better than I do. He used the terminal tab in MP to try some things. It was very corrupted at first, only returning complete gibberish. He did manage to flash it and get some more sensible feedback, but we were unable to properly program it. It was still returning gibberish in the end. He also came to the conclusion that something must be wrong with it. I have contacted banggood. They have forwarded all the info to the manufacturer and I guess we're waiting from a reply from them. I am going to take you up on your suggestion, Michael Burmeister, and look at the PixRacer with serious consideration. Thank you everyone who has replied here. I'll keep this up to date.

If you have later than 3.1.5 arducopter installed, the terminal interface was removed. So it is normal to see giberish in the terminal screen.

If you want to clean up memory corruptions install firmware 3.1.5, then connect to terminal, the type setup, erase, reset and then reboot the fc.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service