Let's put this in here so everyone can start to post reports and get their devices working. 

Tested and OK devices:

- Samsung Galaxy Note II (AND_4.1.2) - (19.02.13)

- Samsung Galaxy S3 (AND 4.1.1) - (19.02.13)

- Samsung SIII, (AND 4.1.2) -  (21.02.13)

HTC One X+ (AND 4.1.2) - (21.02.13)

Acer Iconia A500 (Thors ROM) - (28.02.13)

- T-PAD IS709C, (AND 4.0.3) - (03.03.13)

Motorloa Photon XT897 (AND 4.0.4) - (05.03.13)

- Samsung 8" Note (AND 4.1.2) - (25.04.13)

Asus TF300T and TF300TG


Tested but having problems:

- Oker TP-703 tablet (AND_4.1.1) - no link (19.02.13)

So if you have a device that you tested and it is working or not working, please post in here so we can update list, Please include your android OS version too.

Views: 6790

Replies to This Discussion

Sony Xperia Go St27i (Mobile Phone)

Andriod 4.0.4

Kernel 3.0.8+ Ver 6.1.1.B.1.54

Andropilot 1.4.14

Standard OTG-adapter

RCTimer 433Mhz 3DR-Clone

Just installed and plugged in the radio. Instant GCS on the phone.:)

Wicked cool. Tnx to all devs.


Google Nexus 10: Nothing. Can't get the thing to connect directly to the board, USB or using a 3DR. USP provides no power output.

Motorola Droid Bionic: Same results as above. Am I just not doing something right? 

I did make my own microusb to female USB 2.0 adapter, and that works. I have no idea how to setup the TCP link from a computer, it just doesn't seem to be clicking right in my head, and I can't get UDP to work. Is there a guide out there I can look at?

hmm - strange.  I use a Nexus 10 quite a bit and it seems great for me.  When you say you made your own adapter, did you hook up the special signal that tells the tablet to go into USB host mode?

....see, that would have been a brilliant idea.... Seeing as I have yet to find a guide that actually explains the connecting procedure, would you mind linking me one?

The closest think I know of is this: http://en.wikipedia.org/wiki/USB_On-The-Go

But from memory, you connect the ID pin (pin 5) to ground.  If you are modifying an existing cable be careful to see if pin 5 really is hooked up - it was only added for OTG and most cables don't use it.  You might need to buy one of the $3 adapters on amazon...

Thank you very much! I already have 2 of these on overnight: 


I've been messing with TCP and UDP servers for the Ardupilot Mission Planner for a while now, and I was wondering, can you send the UDP data from the computer to the Andropilot app using the Ardupilot simlink? I'm thinking I could set up a UDP server on a laptop and create an Adhoc network to send the data to multiple Andropilot tablets, like a router in between the plane the tablets.

Tablet that does not work:

Amaze 7"


Successfully connected a USB drive with my OTG cable and copied files off it.

Connected my working 3DR radio up to my Amaze tablet and it would not connect. Lights came on the radio.

Tested 3DR radio on my laptop just to be sure - worked fine

Eventually sold it for $50 to a mate at work and bought a Google Nexus off eBay

BTW it did not work in Droidplanner either.

I asked Michael Oborne to add that when DroidPlanner didn't had USB connectivity. It should enable all the device for which USB doesn't work to use both Andropilot and DP.

But since then I added USB to DP and haven't had the time to setup the MissionPlanner link. I'm looking forward to see your results.

Anyone had any luck connecting the new HTC one? I keep getting the error "USB device not supported".

- I've tested my Microsoft wireless mouse, usb wired keyboard and they both connect and work fine...

- Rooted the phone

- Installed usb host check and ran the fix, re tested still not working!

- Looked through previous post and saw someone recommending this: http://stackoverflow.com/questions/11183792/android-usb-host-and-hi...
- Couldn't find these folders on my phone through the pc browser, do you need to browse from the command prompt? This is my first android phone...


I can't seem to find these folders on my phone...Did you use your pc to browse to the folders on your phone? or the command prompt? Cheers

If a keyboard works, you don't need the steps described in the that stack overflow article.  The next thing I'd recommend trying is:

Plug in an externally powered USB hub between the phone and the radio.  If it works then, it means that the phone can't source enough current to power a radio.  Please update the compatible devices wiki with whatever you learn...

I got my Pipo S2 working in USB Host Mode with a 3DR Radio directly connected by flashing the rom here:


and then downloading an app called 'usb host check', and then running the fix inside there which restores the missing files it needs for the USB host to work.

Now to work on a nice mounting solution for it on my TX


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service