i am currently using the pixhawk autopilot and traxxa e-maxx brushless rover. Now when i flip the switch to manuall the car swereves back and forth. I use mission planner as a ground station, so can anyone help me out?

Views: 409

Reply to This

Replies to This Discussion

@James,

What do you mean by "swerves back and forth"?

Are you describing the steering function in the Manual Mode or does this have to do with the Electronic Speed Control?

What transmitter/receiver are you using with the Pixhawk? Are you using a standard receiver and a PPM encoder?

Have you calibrated your ESC with the R/C transmitter through the Pixhawk when in the Manual Mode?

Are you using the Elevator Joystick as the throttle control as the ArduRovr2 v2.45 firmware expects the throttle neutral to be at 1500us with full forward at 2000us and full reverse less than 900us?

I currently have a Traxxas E-Maxx working with an APM2.6 and a Spektrum DX7 transmitter and stock R/C receiver. I also have a Traxxas Slash 2WD chassis working with a Pixhawk and a Spektrum Remote Satellite Receiver.

Regards,

TCIII ArduRover2 Developer

Sounds similar to a problem I had. The steering servo rotated every time data packets were sent to the ground station from the vehicle. Solved it by using a different frequency data transmitter. I think the original transmitter was 433Mhz.

sorry it swerves in auto mode not manual!! and i mean that the cars wheels go left then right left then right while moving in a straight line in auto mode. i am using the turnigy 9x with a d8r-xp frsky reciever. we use the pitch as throttle and roll for turning. but like i said it drives fine in manual but in auto it swerves

also it swerves in steering mode as well but not manual

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service