Hi. Does anybody know how to save the param-file via Mission Planner? I'v opened the param file in Full parameter list, write params and refresh params to see that the new values was written. But after power off an reconnect the old values is back. I have reload the firmware and did the same procedure again as above but with no success. I will be happy if someone have an idea about this issue.

I'm not able to arm the motors, but set the drone in calibration mode from the radio is ok.

The firmware is ver 1.2 and the params is H500_1_1



EDIT: It seems to be a forum for DIYs but I hope to get any answers anyway ;)

Views: 877

Reply to This

Replies to This Discussion

I have the same problem, the CLI says: "Firmware change: erasing EEPROM..." every time i connect to the terminal. 

I read on a QR X350 forum about the same issue, they solved it by installing not only a firmware but also a config update through the serialangel firmware update software from walkera. I can't find this config file for the tali though..

Did you find an answer to this? 

Thanks for your reply! I haven't find any solution yet. Can you please give me the link where you found the QR X350 issue? Maybe I can ask them for a solution.

I found it at http://www.rcgroups.com/forums/showthread.php?t=2085032&page=364

That config file, however, is provided by default on the walkera site.

I have emailed walkera, perhaps they can help as they have done for me before.

If they provide a solution i will share it here.

Well, walkera basically told me to buy a new controller

so i did.. and not considering this board bricked i started experimenting.

I loaded the QR X350 GPS_EEPROM bin in the CONFIG through serial angel (download slot 1)

It now saves params, however, gps and compass don't seem to work any more.

It does show that reloading the config file (not to be confused with the params file) should solve the problem.

Perhaps this (re) bricks your controller, or you can find ways to activate all sensors. Keep me posted if you do.

That QR X350 file can be found here: http://www.hobbyking.com/hobbyking/store/uploads/929903647X265290X1...


I loaded the QR X350 configfile and then loaded the Tali H500 paramfile in Mission Planner. It seems to STORE the new value at last! I did this by remote from my work via Teamviewer so I have to "power off" the mainboard from USB when I come home, and then verify that the values are stored.

I have disassembled the Tali totaly so I have to put it together again and then test all funktions.

I will be in touch!


I found that, although the params will store, the compass and GPS cease to function.

Giving it a reset or erase instruction after loading this brings it back to the infunctional state (not storing params). 

It truly seems that all should be well when a config file matching the FCS-H500 is released. unfortunately reading the config from the controller doesn't work. If it would i could get it from my new controller (arriving tomorrow).

Let me know if you make any progress getting things functional, and if so, please tell me how.

Perhaps the GPS module have a specific baudrate that not match the mainboard, and will be corrected with a fresch config-file? I shall try to connect the GPS-compass module and see if I have the same fault.

I don't understand why Walkera does not have an official config file for users to download? And I have also figure out that it is impossible to read out the config (Upload config: Sync Error).

Btw... wich firmware do you have? I have tried both 1.2 and 2.2. The 1.2 has a "critical fix" for stable flight but have no idea what 2.2 does better.

Any news on this issue? After damaging my fcs-h500 controller I bought a new one on ebay, unfortunately it has a QR X350 config file preloaded, and although I'm able to upload tali firmware, serial angel still thinks it's a qr350 and I cannot get compass and gps to work...    

Reply to Discussion


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service