Hi everyone,

After spending almost my entire Sunday trying to get this work, I finally thought that asking here might be wise...

Here is my problem:
I can't get to control my tarot gimbal tilt from my RC through the Pixhawk.
I think the Pixhawk is running the latest apm version (I updated it a month ago).

I've found two different wiring instructions.
- Here, using 3 cables: http://3drobotics.com/wp-content/uploads/2014/02/Tarot-gimbal-kit-q...
- Here, with 2 cables: http://copter.ardupilot.com/wiki/common-tarot-gimbal/

None would work for me.
With the 3 wires option, the gimbal turns and locks facing up/left.
With the 2 wires option, the gimbal behaves like it's working independently (i.e. stabilizes nicely, keeping the camera straight, but now way to command it).

I checked in APM PLANNER, RC calibration, the knob (pot) I want to use seems correctly mixed to channel 6 and I can see the gauge moving on the calibration page.
So it seems that it is not something on the RC side or the Rx.
Btw, I use a turnigy 9x flashed with the er9x firmware. The receiver is a FrSky D8r-II plus flashed with the XP firmware to get PPM.

I also followed the wiki instructions to configure the gimbal in the mission planner.

I uploaded the 3dr settings to the gimbal with the tarot flashing software.
And the gimbal is running the 1.4 firmware.

So please, can anyone help me find where I'm messing up?
And as a starting point: is it a 2 or 3 cables wiring needed to the pixhawk?

Many thanks for your help,
Mathieu

Views: 16723

Reply to This

Replies to This Discussion

It's not clear if you're using the Tarot gimbal controller or not.

Two things I was reminded of when upgrading to AC3.2-rc6

  • Make sure the blue light on the Tarot Control board is flashing (it's receiving external commanding)
  • Make sure that BRD_PWM_COUNT is non-zero (I use the max of 6).

Seems like Don is not using the Tarot controller but an alexmos clone.

For different reasons (mounting the gimbal front facing on my TBS Discovery being the main one) I've dropped the Tarot gimbal for an alexmos controller + brushless motors and 3d printed gimbal.

My control board is directly connected to the radio receiver.

Haven't tried to connect it through the Pixhawk so I don't know if it's compatible...

Cheers,

Mathieu

Yes exactly, I'm using a goodluckbuy alexmos board, which I now know to be an unauthorised clone (you pay an extra $15 for the 'official' firmware which turns out to be b*llocks).  The board itself seems to work very well, certainly better than the cheap rubbish that the tarot 2d comes with, but my problem at this point is simply getting a signal out of the aux port.  My ch6 from rc (taranis/x8r) is coming through fine as I can see it on the rc calibration page, but it doesn't seem to pass through to aux1 even though I know I've set it up properly through APM Planner/MP.  Ive tried setting MNT_MODE and BRD_PWM_COUNT and I see a difference now, but I can't get more than .34v.  I would expect to see up to the full 3.3v.  My problem lies at the moment at the pixhawk end, rather than the gimbal controller end.

I got this to work on a pixhawk to tarrot 2d gimbal. I can't get the ROI to work but the knob controls the gimbal. I had to use channel 7 or 8 and it wired up to the second row of pins on the pixhawk. I'll hook her up later and get the exact settings for you.

black and white wire only

I'm stuck in the same situation (Tarot board seems to be working, though a little afflicted by jello even before the props turn, but no response to the Aux 1 even when all the settings discussed are applied.

Well, all that I can find.

That said, I don't see a blue flashing light on the Tarot Control Board (unlike when you have the USB attached), nor do I see a BRD_PWM_COUNT option in APM.

It's incredibly frustrating. Wish I'd got the DJI Gimbal now.

Anyway, what should my next move be? Do things like RELAY_PIN matter? OR RCx_FUNCTION?

I'd make ultra-sure you've got the wire pinouts correct.  You might need to use Mission Planner to gain access to the BRD_PWM_COUNT which could have possibility defaulted to something non-usable.  I don't think RELAY_PIN matters, but RCx_FUNCTION will when you confirm the "blinking blue light" for connectivity, and need to pass through the RC commanding.

Hi All,

I am having the same issues that I am not able to operate my Tarot 2-D gimbal through RC.

Here are more details about my systems and things I've tried so far.

1. Pixhawk with Arducopter V3.3.3, 

2. S900 airframe

3. Followed all the instructions given here , http://ardupilot.org/copter/docs/common-tarot-gimbal.html

4. Tarot 2-D gimbal with Gopro 4, latest firmware flashed

5. Output rail powered via separate BEC (although not necessary since Gimbal is powered on it's own)

Gimbal operations; It maintains preset attitude (GoPro camera orientation) pretty well, flight tested.

My goal;

I am trying to get the manual control of camera via RC working but no luck so far,

I have tested the toggle option via Mission planner and Gimbal moves fine but when I try to operate via Transmitter the gimbal doesn't work.

What am I doing wrong ? any suggestions ?

Hello all:

I had the same problem using an Alexmos type gimball and finally got the following solution:

- Connected Main Out nº6 (section 3) with gimball

- Set SERVO6_FUNCTION to 1 RC PASSTHU ( http://ardupilot.org/copter/docs/parameters.html#servo6-parameters )

Be sure to power the Pixhawk with battery when testing (not through USB)

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service