Anyone managed to get pixhawk to control the t4-3d gimbal?

i've tried following the same steps in the wiki but that was for the 2 axis gimbal

http://copter.ardupilot.com/wiki/common-tarot-gimbal/

i cant get control the gimbal at all. It works when i plug the gimbal directly into a receiver like the conventional way. i've tried all different aux ports and tried different settings but just cant.

Anyone got this gimbal working with pixhawk before?

Views: 7829

Replies to This Discussion

Brad,

Ignore the BRD_CAN_ENABLE parameter. This setting disappeared on me as well after an update of MP (currently running the latest beta for fun). The missing setting has no effect.

I believe the issue is the splitter. If you can temporarily remove it and run direct see if that fixes it. If it does I will plug in my Futaba SBUS splitter and replicate the problem tonight and determine the solution.

I am sure you already are doing this but I will mention it anyway. I use the POT style switches for the tilt and pan - Are you doing the same?

Regards,

Gio


Brad McMillan said:

Hey Gio thanks for your reply. We are currently connecting the gimbal via an sbus splitter from the receiver to the Pixhawk, and have the pan and tilt mapped to the left and right pot sliders. I can see the sliders on the Tarot gimbal software moving when I move the pot switches, but the gimbal does nothing.  I'll try your suggestion of connecting without a splitter. Are you connecting the gimbal directly to the Pixhawk Sbus port?

I configured the settings like you described above, however I cannot find BRD_CAN_ENABLE parameter. I found both BRD_SBUS_OUT and the RC_FUNCTION and set those according to what you've described, but could not find the other one. I'm using the latest Mission Planner with the latest firmware on the Pixhawk. Could it be called something else? What version of Mission Planner and Pixhawk firmware are you using? I also made sure the MP gimbal settings were disabled. 

Thanks again!

Brad

sorry for answering so late. first MP is on lattest vers also on my quad. 

on the Camera gimbal:

-Type is "servo"

- Tilt RC9 with 1100 to 2000 and angles: -90 to 30

- Pan RC10 with 1100  to 2000 and angles -140 to 140

BRD_PWM_COUNT 4

RC_TRIM is 1500 on RC9 and RC10

Are you running the APM firmware or Pixhawk? running APM and my aux outputs do nothing... they are enabled and mapped. I can control the gimbal from the X8R directly but not through the pins 1-6 (51-56) on the Px4 - at least not using APM Copter V3.3.3 Quad.



B Petru said:

sorry for answering so late. first MP is on lattest vers also on my quad. 

on the Camera gimbal:

-Type is "servo"

- Tilt RC9 with 1100 to 2000 and angles: -90 to 30

- Pan RC10 with 1100  to 2000 and angles -140 to 140

BRD_PWM_COUNT 4

RC_TRIM is 1500 on RC9 and RC10


Petru hi! hey could you please help me with setting up my T4-3D with Pixhawk and Futaba SBUS? Below is my setup:

Futaba 14SG with EZUHF receiver connected via SBUS thru CH1 of receiver

Tarot T4-3D Gimbal

So far Ive tried what you sugested but no luck. I need to know details on hos do I assign a channel of my radio to control RC9 & RC10 of the Pixhawk


B Petru said:

yes there is a solution!!! make sure you have the latest firmware on your tarot t4-3d thats means v1.1

how to connect Tarot T4 gimbal to pixhawk: 

-set gimbal to pwm (not to sbus)

-connect pwm1 from gimbal to rc9(pixhawk) AUX

-connect pwm2 from gimbal to rc10(pixhawk) AUX

-go to mission planner -> intial setup -> optional hardware -> camera gimbal

        - set TILT to RC9 and do not check stabilization and then set what channel you want from radio RC6, RC7 ....

        - set PAN to RC10 and do not check stabilization and then set what channel do you want.

This worked for me, i have pixhawk and tarot T4. any question please ask :)

Yes, I already did all of that, but what Im having problems is how do I assign a radio channel of my futaba to control RC9 (Aux) on Pixhawk. Also, do I need to do anything within the Gimbal/Camera screen on mission planner? To what setting do I set gimbal to? Servo?

Sincerely,

Jose


 

Gio first allow me to thank you for posting this information. I have already set the parameters in mission planner according to your instructions but using RC_Functions 5,6,7 to control Tilt/Pan/Mode. However I do still have a few questions:

1. Where does the "PWM1 (SBUS)" cable coming from the gimbal connects to the Pixhawk? When you say SBUS_OUT, are you referring to the port labeled "SB" of the Pixhawk?

2. On my Futaba 14SG radio I configured Channels 5,6,7 with switches "LS, RS & SF" to control Tilt/Pan/Mode respectively. By setting RC_Functions 5,6,7 to "RCPassThru" on Pixhawk does these means that any inputs made in my radio to channels 5,6& 7 will effectively be sent thru RC_Functions 5,6,7 of the Pixhawk respectively? Sorry for the stupid question!! I'm just trying to gain an understanding of how all of these works.

3. If all of my assumptions above are correct, within the Tarot Gimbal software, after selecting "SBUS" for receiver, which channels am I to select to control Tilt/Pan/Mode?

I'm sorry for the lengthily reply, I've trying to figure this out for a week now and still, no working gimbal.

Sincerely,

Jose

I was able to connect the Tarot T4-3D to a Pixhawk (providing Tilt control only) over the weekend and wanted to share the steps/details of the setup.

Pixhawk Configuration (Mission Planner)

Initial Setup > Optional Hardware > Camera Gimbal

Type - Servo

Tilt - RC9

Servo Limits - set according to your radio (mine is Min 1100, Max 1900)

Angle Limits - Min -90, Max 0

Input Ch - RC6 (I'm using a slider on an Aurora 9)

Physical Configuration

Verify the wiring out of the gimbal controller to the Pixhawk. I had to change the signal wires on the two PWM/SBUS connectors (moved the signal wire from the single wire connector to the two-wire connector)

Connect the two-wire connector to the Pixhawk AUX 1 port (RC9)

Gimbal Configuration

Update the Firmware to 1.10 (http://www.tarot-rc.com/index.php?main_page=page&id=14)

Receiver Type - Conventional

Default Mode - Pan Follow

RC Mapping - TILT > Channel 1

Control Mode - Angle Control

Don't forget to Write Flash

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service