Hi all,

A few weeks ago I was having arming issues and while trying to fix them, I reformatted my pixhawk’s SD card on my desktop. The “Download DataFlash Log Via Mavlink” log downloader menu gives an output after clicking “download all logs” of “Getting list of log files…” followed in the next line by “No logs to download” (see figure 1.1)

Now when I plug the SD card into my desktop, i get an error message that says that the file or directory is corrupted and unreadable (see figure 1.2)

The first time I plugged the SD card into my desktop the files inside went something along the lines of...

“SDHC -> APM -> LOGS and TERRAIN ... the logs folder was empty and the terrain file had some stuff in it...” LINK TO FIRST THREAD

But that was before ejecting the SD card, putting it in my desktop and reformatting it (see figure 1.3)

The copter has flown many times with the LOG_BITMASK value set to 131070 and the logs never seem to be there. Did I brick my SD card? Do I just need to manually make file extensions/folders in the SD card on my desktop so pixhawk knows where to put the logs? Any help is much appreciated

The whole point of needing the logs for now is to take the GPS data from the logs and tie it to photos taken from a XiaoMi Yi in photoscan, I have the professional version but the free trial ends in 8 days and I need to convince certain advisers that this program and airframe can make GIS available digital elevation maps with scale

Fluffydust

Views: 1023

Attachments:

Reply to This

Replies to This Discussion

Google HPUSBDisk and use that to format the SDCard. Make sure to right click on the card in explorer and select "eject" before removing it. Put it back in the hawk and fly. Check to see if there are now logs in mission planner.

Some cheap hawks come with fake or cheap SDCards and go bad fairly quick. SDCards have a limit to how many writes they can accept before they start going bad and the cheap ones go bad faster than a good one. 

A nice little tool to test the card is here and if it fails just toss in another card but I would make sure it is a good card that is class 10

Hi Craig,

Boy am i glad to have your help again

The card that came with my pixhawk is a Kingston 4gb class 4? card... see attached 

Suppose i pick up a brand new class 10 card from walmart, should the pixhawk format the new microSD with the correct files and such to store the flight data just by putting it in and powering up?

Attachments:

I'd test the current card before ditching it, but yah ardupilot will create the folder structure and then start writing the files as needed to a new sd card. It should come already formatted fat32 so you really would just need to plug it in and away you go :)

Test the card using http://oss.digirati.com.br/f3/ it will detect any  problems.

I hAve experienced two times in my long Ardupilot history, that logs stopped to be written to a working SD, last time with a awful loss of whole days work.

https://github.com/ArduPilot/ardupilot/issues/4661

Both times, doing a filesystem check did not fix anything, nor deleting files, folders.

Nor did formatting the partition. Any other device, tested with camera, computers, used the sd fine.

In both cases, the cards have only been written to by pixhawk,  only read by computer, until problem.

In both cases, I needed to repartition the SD, then they worked fine (I even restored all logs and files)

So there must be something that fail to write to those cards after some change.

I had a problem with my Pixhawk flash card early on as well.  It worked for a while, then it stopped recording log files.  Turned out to be a bad card as mentioned above (I also had a knock-off pixhawk).  I read some other posts about these cheap cards going bad so I popped in a new card and everything has been great since. 

  Doug

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service