Hi all!

This isn't a discussion about wireless telemetry but more to do with the telemetry port itself.

Could somewone tell me what the signal voltage levels are on the tlemetry port on the Ardupilot Mega.

I hoping to test my telemetry link by using a serial to USB adapter, but when I do I get a garbled mess of data in my "raw data" window. I have no problems when I defie the GCS port as the USB port and send the data that way (I get the normal MAVLINK data stream)

I have checked baud rates both ends and have got tx/rx and ground all correct.
I have double checked by forcing GCS to telem port correct protocols etc.

Is the APM designed to output at normal RS-232 signal level voltages or is it TTL.
If it is TTL, I have 2 questions...

1. Is logic 1 and logic 0 reversed when using TTL (compared to serial RS-232)

2. Is it likely that I have fried my Ardupilot mega telemetry using a USB to serial adapter. (I assume that usb to serial uses +5V to -5V on the serial side?)

Any help yould be greatly appreciated as next step is to attach the Digi Xtend modems!

Many thanks,

John Cousins

Views: 4025

Reply to This

Replies to This Discussion

Hi

Did you find out about the TTL level ? :)

I am also trying to find out the TTL level of the APM telemetry port.

For those who would say "it's 5 volts", then why is it suggested to buy a 3.3 volt USB TTL to program the 'APM-telmetry radio'?

For those who would say "it's 3.3 volts", then why are people buying ttl-converters to hook up the telemetry output of APMs to the Rasbperry PI GPIO port?

---This seems like conflicting information, and I can't find any documentation that gives a definitive, verifyable answer

I am a no expert in apm, but..... usual FTDI cables which supply 5v and 3.3v logic are very tolerant to 5v logic circuits.... so, I am pretty sure it is just this ftdi tolerance that makes communication with apm at 3.3v possible, however raspi tx/rx are VERY sensitive and will fry @ 5v so LLC is needed. 

I have used APM 2 with the second gen Raspberry with no power issues tested for over 24 hours with no problems (not flying ground test).This was directly connected to telem on APM and GPIO to Raspberry how ever I  was using the Raspberry to supply power to the APM not sure if it would cause any issues if the power source was reversed.

I can answer question 1. The signal from the APM should be inverted before going to a standard rs232 port. Use a MAX232 chip though I can't confirm if it is 3.3v logic.

I have been connecting my APM2.5 directly to the Rpi with no issues. 5 <> 3.3 volt is no problem :)

Hi, really not?

There are overvoltage protection diodes in the IO ports of all those chips. If you pump 5V into an input of something running at 3.3V, the diode from the input to +3.3V will draw current. Quite a lot of current actually. So much current that the 5V output will budge (overload) and/or the 3.3V chip's supply will now be driven by the diode and rise above 3.3V. Neither is very good.

So I'd say use a level converter. For simple, slow serial signals a series resistor is also OK. Like 1kOhm or 4.7kOhms.

On the other hand, the line from a 3.3V output to a 5V input can be connected directly.

Regards

Soren

Hi,

APM uses 5V TTL logic.

Logic 0 and logic 1 are the same as RS232 however the voltages are the other way round. +12V<-->0V and -12V<-->5V. Hardly anyone uses the 12V signals (although these are the real RS232 ones) for small short range serial any more.

2) Not very likely no.

There is a serial test sketch in the source code. You could try that. It is easier to know with that if the garbled garbage is MAVLink or if it is data gone silly in transmission - because it uses no MAVLink.

Regards

Soren

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service