Everyone who has spent anytime in the RC hobby knows the feeling you get when your model fails to respond to your controls... it happened to me yesterday.

It was a great day for flying and I decided to take my Quad out for a mid day spin.  Flew an entire 5000MAh without incident after upgrading to 2.8.  I few stable mode, Alt Hold with simple Mode, and Loiter....all was working really well.  I had never really flow in simple mode before but I thought I would give it a try.  It seemed like a stress free way to wing the quad around.

For the next battery I made no config changes and was generally flying around spending some time in loiter mode as it was a little breezy and it was a good test.  All was working fine.  I then went to Alt Hold with simple mode turned on and was doing a typical circuit.  On the return leg I felt disconnect from the model.  I was giving it left input and it was not responding.  The quad then banked a bit and I needed to give it forward and left input to correct... no response.  At this point it was moving at a very high rate.. I tried bumping the throttle to climb out of harms way.. again nothing.  Then it all ended with a ~25 mph smash into the back of my SUV.

Quad was in a few pieces nothing than cant be repaired... truck now has two dents in the back.

Obviously I am upset but I want to understand what happened.  I have not used with any degree of success the logs or telemetry that this thing stores and I want to ensure I get something that someone knowledgeable can help troubleshoot.

Assuming my APM turns on.. can someone give me the idiots guide to what is needed.  I have pulled logs off the dataflash before but never really understood how to use them in detail.

Views: 1354

Reply to This

Replies to This Discussion

John D,

    I've had a look at the logs and maybe they're the wrong log files?  As John C says you appear to have gone into RTL mode.  From the flight modes you had set-up "Alt Hold", "Stabilize" and "Loiter" it seems that the only way you could have switched into RTL was by your radio failing to provide updates which would have triggered a failsafe.

     It looks like maybe you disabled the CTUN log message (it's on by default) so I can't actually see the throttle input unfortunately.

     The change to RTL happened at line 3060 which is half way through your flight so it appears that you got radio contact back and were then flying around in RTL mode for the rest of your flight.  This is possible because because pilot inputs override the autopilot.  We can also see your roll and pitch inputs are coming in through the flight.

Looking at the end of the flight..you switch into Stabilize mode but you still appear to have control.  We can see the roll and pitch values are updating.

There must be a radio issue going on here.  Could you turn on CTUN?

Also I think it would be a good idea to upgrade to 2.8.1.

John D,

    One good way to check how well your copter is tuned is to go into the dataflash and check the ATT message.  This shows you the pilot's input as "Roll In" and the copter's actual Roll as "Roll".  It also has a "Pitch In" and "Pitch" value.

     I've just compared these and I think the copter is very badly tuned.  Normally I'd expect the Roll-In vs Roll lines to be very close together with the "Roll" lagging just slightly behind the "Roll-In" but in these graphs I see the copter's roll (in green) is off from the "Roll-In" (in red) by more than 10 degrees for extended periods of time.  Pitch is even worse .. being off by 20 degrees at times.



     I see you're using the standard PIDs which are usually ok for most copters but perhaps not for your copter.  Can you tell me what you're flying?


Thanks for your help.  I will certainly update to 2.8.1 but at the time I was flying the latest code.  I am reasonably certain (85%) the log files are correct as I only had 2 flights that day and I just updated the new firmware and configured those flight modes which are atypical for my normal flying. 

I will also attempt to turn on CTUN.. i dont recall ever turning it off, in fact I dont even know how to turn it off/on.

The log and analysis just dont seem to match the flight.  I was in Stabilize mode by default  (no way to switch out) from the moment I armed the motors.  I then switched to ALT HOLD with simple.. a few minutes in loiter then back to ALT HOLD with Simple.  Even the GPS output does not really match my flight that day... I can provide the other log file from that day to see if that helps. 

I know this may sound defensive but I am very doubtful it was a radio problem.  I have had this radio for a year and fly it across 8 or so planes and I have not had a problem.  Range would not be an issue as the quad was never more than 100 feet away.

My question would be how does the APM change to RTL mode if its not enabled as part of flight modes? ... and how do I have no radio contact if you see roll and pitch inputs? 

If the APM was logging roll and pitch inputs but the quad was otherwise unresponsive what does that tell you?

Here is a picture of my quad.  Built out of light ply and towel bar holders.  Total cost to build is less than $10.

Distance between motors is ~22 inches



I am very curious as to your points on tuning.  I had a basic test flight today just some simply hovering, loiter and alt hold.   I did try some sharp pitch and roll input to set the response and all seemed well. 

I am hoping you can take a look at these logs to see if the tuning points you saw earlier still persist in this flight.  If the tuning is as bad as you indicate I am hopeful to get some pointers on how to correct it... and begin to test RTL and other functions.



     Much better!  You can now clearly see that the Roll (green) is following the Roll-in (red) and Pitch is following Pitch-In.

     It's ok that the roll and pitch values don't quite reach the top of the roll-in and pitch-in values.  I think that's just because you're quickly asking the copter to go back the other way.

     Nicely done!


Thanks again for looking into the logs.  But I now I suspect the poor tuning you see in the previous log was a symptom of the problem before the crash.  For the latest test flight I actually did not do anything.  I simply updated to the new firmware, calibrated radio and mag, set flight modes and flew.  You should be able to see this in the settings  It flew exactly as it has done in the past (with the exception of the last 5-10 seconds of the flight that resulted in the crash)

As I mentioned in the initial post I felt a gradually disconnected from the quad prior to the crash... this might be yielding the poor tuning symptom prior to a total loss of control.  

Could the APM be failing/locking up.. or slowing down resulting in this behavior?

The only variable I have not tested is simple mode...I had it set in simple mode prior to the crash.


Happy to report I flew 4 batteries yesterday with no issues.  I tested all flight modes..stabilize, alt hold, loiter, simple and even RTL.  I was very happy with the results.  Confidence is not fully restored but I think I am one step closer to an answer as to what happened in the crash.

Some of you may recall I have been unable to get RTL working correctly with older code.  The quad would randomly fly where it wanted to.  Today it worked well about 8 times. 

Well is a relative term and I was caught by surprise when I had no control on the last part of landing.  The quad landed and the motors were at an idle speed but the quad skipped around for several seconds and at one point looked like it was going to flip.  I disabled RTL and tried to disarm but that did not work either.... finally it just shut down.

I have seen posts about this prior so I am not concerned this is unique to me.. however given the log analysis that has been done on my crashed flight indicating I was flying while in RTL mode and given the total loss of control  had during the last 5-10 seconds of that flight... and correlating that with the lack of control during a typical RTL landing... I was wondering if this could explain the crash.

In no way do I understand how the APM switched to RTL during the flight in which I crashed, but if it did and it was attempting to land  (very far from the launch point) and it was ignoring inputs.. well that seems like a recipe for failure.

So this brings me to two questions:

1.  Can anyone explain how on my crashed flight the APM got into RTL mode?  This is important as if there is a tendency for APM to change modes by itself it should be fixed.

2.  While in RTL is there anyway to abort once in the final landing routine.. ie when its skipping around on the ground?  I aborted RTL a few times before it started to descend with no issues.


Hi John, did you ever get a response to this?  Now that I know what i'm looking at with mine, I experienced the same RTL result as you, ie, the skipping around and well, acting insane.


     I believe the consensus was that it was caused by radio interference caused by a mobile phone with it's wifi signal turned  on.

     I'm very sure there's no bug in the flight mode selection in arducopter.  What happened is a radio failsafe..in these cases arducopter switches to RTL which is consistent with this situaiton.

     The pilot can take back control from RTL by switching the flight mode switch.  So say you're in stabilize mode and you have the throttle failsafe set-up, and you lose radio contact, it'll enter RTL mode but once radio contact is restored you can change the flight mode switch to any other position and then back to stabilize again and you'll have full control.

     2.9 is coming out soon and has a much improved method of landing which mostly stops the bouncing around.  The release is being tested at the end of the 2.8.1 release thread.


Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service