Three Identical APMs, Two Without GPS Lock Until Unplugging Compass I2C

Hi all,

We're competing in the Outback Challenge and have a strange issue with our GPS setup. Turning on the three redundant APMs one always gets a GPS lock within a few seconds of starting, but the other two can sit for half an hour or more under a clear sky without acquiring a lock. The only work around I've found is to disconnect the I2C compass cable from an APM with no lock until the lock is acquired, and then reconnect. Even after this the two problem GPSs often see less than half the number of satellites the working GPS sees.

The APMs are mounted upside down, with the 3DR UBlox/Compass modules the right way up. Since the compasses are normally ROLL_180 because they're upside down in the housing but because they're the opposite orientation of the APMs we use ROLL_NONE, as per setup instructions. The compasses have all been calibrated using the compass dance. I don't understand the compass mot calibration but I assume that it doesn't matter if we're not electric powered.

The GPSs have all been upgraded to the latest settings using the u-Centre instructions on arducopter, and connected to u-Centre they all have identical performance, with 3D accuracy around 4.5 metres.

The APMs have identical parameters, and are all running the same firmware based on 3.0.3 (we commented out some modes and code we didn't need, including compass declination tables in case that's pertinent to this problem - we set the declination manually to -12 30 for Sydney Australia) because we couldn't compile and stay within upload size limit (this is another question).

My guess is that the compasses are used to init the GPSs somehow in the APM code, and some combination of the orientation of the compass to the APM or being in the Southern Hemisphere has somehow mucked this up.

You can see the tray with the GPSs and APMs setup at 4:17 in this video:

We can fly once we have the locks, but getting the locks in the first place can be complex. Any pointers or suggestions would be really appreciated.



Views: 245

Reply to This

Replies to This Discussion

I'm very envious of your setup. Nice job.

There may be a couple of issues with GPS lock. One may be the location of the GPS units. Have you tried experimenting with the gps modules outside of the plane? I'm also wondering if the IF frequency of each unit might be interfering with each other since they are so close to each other. If you get a chance you might try them farther apart. I would try each unit one at a time open and see how the lock is. If one at a time they work well then they are interfering with each other otherwise you may have two bad gps units. I would look placing the gps units on the exterior of the plane with at least 6"/15cm separation.

Another thought is the electronic ignition off when you start up the apm modules?

After reading my other theory is that there is a soldering or other hardware problem in the two problem GPS/compass units that only occurs when the compass cable is connected (the compass cable wasn't connected when I was hooked up to u-Centre getting identical results from the good and "bad" units).

Hi Rob,

Thanks, it's our first competition and we might try to make things a bit more simple next time :-).

All the behaviour I've reported is with the tray sitting by itself in the back yard, so no ignition. I also wondered about interference, but if that were the case you'd think they'd all be equally affected, the one in the middle more so, and that's not the case - in fact the good one is the one on the right.

I think about a year ago 3DR changed their gps antennas to the current one you have so the issue in the link may not apply anymore. What I suspect is happening is there is some RFI coming down the I2C line and messing with the GPS reception. You may look at adding some RF chokes on the lines coming to the GPS units if they don't effect the magnetic compass.

After watching your video again I'm beginning to think you may be getting some RFI from somewhere else like the main cpu. Have you tried the starting up just the APM modules and not the main computer? I've had my own issues in the past with gps units that didn't have built in compass. I was getting RFI first from the speed controllers and later I got some when I added a go pro 3. I think it wouldn't hurt to raise your gps antennas a bit to get above the surrounding metal. Oh btw what metal is the frame made out of. Also be sure there are no ferrous metals if you haven't already done so. 

Do you have access to a spectrum analyzer that can go to 1.575 ghz? If you do I would check your noise floor turning on one device at a time including all the other electronics to see if something is interfering.

One other thing you could do is post your log files from all three units. Not the TLOG but the .log file directly from each APM.

On my mission planner I have it display satellite count and HDOP. If HDOP is below 2 then you are good. 

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service