I've built a Tricopter. The radio is calibrated in Mission Planner, the Esc's are calibrated. Prop configuration, right prop, (Pusher) ran clockwise, the left prop and tail prop (Regular) turned counter clockwise. No luck? I tried all different prop configurations nothing worked? Anybody have any ideas what is causing the Tricopter to spin?

Views: 4271

Reply to This

Replies to This Discussion

Your tail servo should be plugged into output 7. When in stabilise mode, it should move left-right when giving jaw on the controller. (Don't go in the air until servo works). You may need to reverse the channel 7 as per instructions above

It's plugged into output 7. And its in stabilized mode. But no response? Just throttles up, and throttles down? Trying to use Motor Test in Mission Planner. Select "Test Motor A or B or C". And message comes up - "Command denied by Autopilot?"

Can we get you to post a picture of the tail mechanism and of the apm (need to see the outputs).

The wiring is correct so it has come down to 1 of 3 things:

1) Settings on the transmitter are wrong.

2) Firmware issues.

3) The APM itself, (which I doubt this.)                                   

The firmware is fine, my tricopter flies like a dream. 

You obviously have checked the motors/props are turning the right way? BTW, always test without props (at least initially) in case something is wrong.

Try this: the throttle needs to be increased a bit before roll and pitch become active so take the props off and throttle up to half, then pick the copter up and tilt it one motor down, that motor should speed up and the others slow down. Now place it level and try pitch forward on your Tx, the rear motor should speed up.

Nice video. Yes, pusher prop, CW right front, regular prop, CCW left front, CCW on tail. No change in the motor's when I tilt the Tricopter forward? Rear motor doesn't speed up. All motors run at the same constant speed?

Sorry, if you tilt forward at half throttle the rear motor should slow down and the front two should speed up but anyway you should have some change. I'm not sure what the problem is, but it may be worth checking all the steps again to see if there's anything missed

That's okay. I tried tilting it in different directions and the motors remained constant. No variable speeding up or down? If someone is using a FlySky 9 channel radio, and a APM 2.6 that are flying a Tricopter I would be interested in what settings they had on the radio, and the parameters for the APM?

Wait a minute!? It has to be something to do with the APM? Because if I am not using the radio, and just moving the APM and it is not responding to those movements, then it's has to be something wrong with the APM?

Hi Joe,

As requested earlier, can you take a new pic of the APM so we can see how it's wired up.

Mainly interested in the output's to the ESC's.

If it's in stabilise (or many others but not acro) mode then yes I believe it should try to vary the props to balance itself.

I cant remember if you said it earlier but have you done the accel calibration?



Hi Chris,

APM photo wiring - Output side are Pins - 1,2,4 ESC's, Pin 7 is the tail servo. The props are set up just like the instructions say. Right front, Pusher prop, spins CW. Left front normal prop, spins CCW. Tail, normal  prop, spins CCW. So it's not the wiring or the props.

There's something wrong with the APM? I've tried programming it in Mission Planner. I can do the "Accelerometer Calibration". I can do "Radio Endpoint Calibration".

But! I can't do the "Compass Calibration" and in "Flight Mode Calibration" moving the 3 mode stick on the radio will not change any settings on the APM?

When I try to test the motors in Mission Planner/Optional Hardware/Motor Test. A,B,C... Error message... "Command was denied by autopilot."

I'd like to know what settings someone is using on their APM, and radio? Then I would set the APM and radio the same way and see if that works?


Hi Joe,

I agree looking at the pic and text it looks like it is indeed wired up correctly.  When connected to Mission Planner do you see the horizon change?

When you say the compass calibration doesnt work, what msg do you get?  Or did you give up before it finished?  I had several goes (I gave up a number of times) before I managed to get enough data points, it was painful but it was worth it.

Does the artificial horizon change when you move the apm?

On your radio do you have a way of visually seeing what its outputting, just to be sure your mode switch is doing what you think it is.  If it is then from what I hear from you is that you don't see a corresponding change in the radio calibration screen.  If you are saying it is changing but the modes aren't changing then that is really odd, I agree you will need some help to setup the radio.

If the horizon is working, the RC inputs are showing in the RC calibration screen, then its possible you've got a dud board.



Hi Chris,

I just "reset" the APM using the DOS commands in "Terminal" in Mission Planner. And I was able to do the "Compass Calibration."  Also the Horizon moves when I pick up the Tricopter. GPS 3d fix. Clocks ticking away, numbers are fluctuating, radio calibrated, and so are the ESC's. I'm charging the battery and when its charged I'll try again and see if the APM is working properly?

As for the radio it doesn't show any outputs. Just what mode its in, battery, time and type of  craft. I hope its not a dud board? But if it is? I'll have to get a replacement...

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service