Hi guys,

 

I have a problem with my ACM and Turnigy 9x (with 2.4 GHz Frsky module and receiver)
working together. The system seems to work fine with my 72 Mhz Jr radio gear. I
thought that I would post a query here as it seems a lot of people have the
Turnigy 9x radio with various transmitter and receiver modules.

 

The  basic problem is that the autopilot freezes only the rudder, jamming the yaw
servo on my tricopter in the last position it was it. The other channels are
still controllable during this 'freeze' period. I think that the problem is
that Turnigy radio is dropping a signal now and again which defaults throttle
to 0, and the ACM doesn't respond to rudder when the throttle is 0; causing the
yaw servo to jam up. I don't see why the servo gets stuck for so long though
(sometimes up to 15 seconds), as the other channels all work fine.

 

Video of the problem:

https://www.youtube.com/watch?v=koZGSb44rf8


More information/description:

http://code.google.com/p/arducopter/issues/detail?id=186


Any help or advice on what to do would be greatly appreciated. Thanks



Views: 729

Reply to This

Replies to This Discussion

Has anyone seen this problem yet, or is it just happening on my set up?
 

Ok, I think that I was on the right rack before. I found a way to reset the Frsky failsafe (push the bind button with the throttle above 0 and a green light on the receiver blinks). By resetting the throttle value that the receiver spits out when signal is lost to a value > 0 the apm no longer freezes or locks up. Sometimes though the solution isn't a 100%; the apm still locks up, but for only very short whiles, and much less frequently.

So, it would appear that the Turnigy radio/Frsky are dropping signal every once in a while, causing the receiver to default to failsafe mode. By dropping the throttle to 0 and having any rudder value, other than the mid-point, caused the apm to freeze the rudder because the apm though that the signal was genuine and stopped listening to yaw/rudder input - causing the servo to lock up until another radio glitch came along or the throttle manually set to 0.

You should be able to see this problem by moving the throttle up (from 0) with the rudder stick off-center. The apm safety features stop the motors from flaring up when throttle is 0, regardless of what the yaw input is doing. You should see that the yaw output is now broken i.e. I think that the apm doesn't respond to the new yaw input. This was how I found the problem, at least in tricopter mode.

If you have an AVR programmer, you can see if the new PPM encoder firmware fixes this:

http://www.diydrones.com/profiles/blogs/beta-test-new-servo-input

I uploaded the PPM encoder hex file, but the problem is still there. The radio is still a Turnigy 9x with Frsky 2.4 GHz radio module/receiver. I am also wondering if the problem may be linked to me (and the radio) being in close proximity to the receiver when doing these tests - since 2.4 seems to troublesome at very close range. I also noticed that I can adjust the antennae to significantly vary the affect the signal.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service