I've been having trouble with my AttoPilot 90A current/voltage sensor. I'm getting bad readings. I'm wondering if the ArduCopter software is the problem. I'm running the latest Mission Planner and an APM2 board w/ version 2.8.1. I've previously tried all sorts of ways to get this sensor to work, including following the normal setup procedure in the Wiki, and also erasing EEPROM, re-flashing the firmware, and operating the Battery Monitor settings in a variety of ways.

This is what I typically see when I open the Battery Monitor tab:

I was doing something in Standard Params and it wouldn't let me write because of unacceptable values for Battery Current sensing pin, and Voltage sensing pin. That's when I noticed the Current and Voltage sensing pins are blank, as shown here:

I can set a correct pin for each one, and write the settings to the vehicle:But when I return to the settings screen, the pin settings are gone, as seen in the second picture.

I've checked the AttoPilot 90A to confirm that it is giving valid readings. I've many-times-checked the wiring (I get paid to do this type of wiring; I don't screw it up). So I'm wondering if either I've ruined my APM board, or if there's a software bug..?

Other than this the vehicle seems to fly just fine, but the main goal of this project is to obtain a power consumption profile.


Views: 875

Reply to This

Replies to This Discussion


When I installed my AttoPilot sensor, there seemed to be a minor conflict with the Wiki and the MP instructions. Knowing that the MP changes more than the Wiki, I went with the MP instructions. Nothing else was done to make mine work.

HERE is the blog post regarding this though it is mostly about adding the EC3 connectors to solve the wiring harness situation on my quad. Rereading the post, I did have to reset the APM for the sensor function to take place.

That said, I never had to mess with the Current/Voltage sense pins selection.

I believe those are for the APM1 at there are four places for analog inputs on that system.

You might want to try the 'battery' setting in CLI to save you effort with a 'fly-download log-analyze' cycle.


Actually, I figured it out. I was on to something when I started manually assigning the voltage and current pins in the configuration page, but I was choosing the wrong ones from the drop-down list (I blame low blood sugar).

As specified in the hardware setup instructions, Voltage is on A1, and Current on A2. I wrote the settings, and now it works! It's presently reading a steady 11.93V. I spun up the motors and the current went from zero to 4 amps (no props).

There is either a software bug OR the setup instructions are missing that step.


Reply to Discussion


© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service