My "ready to fly" quad continues to have problems and has yet to achieve lift off.

After several violent flips and broken props on attempted takeoffs I have tethered the quad to a platform so that I could observe it better.

In this tethered mode, I can see that pitch works correctly, but yaw and roll moves are reversed.
In other words:


Pushing the right stick to the right causes a roll to the left (opposite to expected behavior)
Pushing the right stick to the left causes a roll to the right (opposite to expected behavior)
Pushing the right stick down causes the front of the quad to pitch up (correct)
Pushing the right stick up causes the front of the quad to pitch down (correct)
Pushing the left stick to the right causes counterclockwise rotation (opposite to expected behavior)
Pushing the left stick to the left causes clockwise rotation (opposite to expected behavior)


In mission planner setup,

pushing the right stick to the right produces high pwm
pushing the right stick to the left produces low pwm
pushing the left stick to the right produces high pwm
pushing the left stick to the left produces low pwm

According to the documentation, these values are correct.

Prop configuration is correct for an X configuration and X config is confirmed in Mission planner.

The props spin in the correct directions, however the motors command shows up a discrepancy with the documentation - the motors do not spin up in clockwise sequence  - they spin up in counterclockwise sequence.

I can reverse the roll in the transmitter or mission planner and correct the roll problem, but if I do that to the rudder, arming does not work.

Suggestions anyone?  Is this perhaps caused by the motor connections to the apm? 

As I worked through the documentation I have seen numerous references to leds blinking and turning various colours but I can't really determine what is what looking at the apm.  Also there are references to the CLI switch, but I don't seem to have one, or at least it isn't brought outside the case.  Was this eliminated in the move to newer hardware?  Is there a place where all the beeps and led blinks/colours are documented together?

Ken

 





Views: 274

Reply to This

Replies to This Discussion

I am having a similar issue - how did you resolve this?

Did you order it with transmitter (in which case you shouldn't have to change anything) or are you using your own transmitter (in which case it sounds like you've got some channels reversed)?

There have no RTFs shipped from uDrones (which is a name that has not been used for more than a year) or with the APM controller since last year. When did you purchase this?

-c

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service