I'm using Planner 1.1.14 with a new APM2 board. Win XPpro and the Atmega2560 inf driver file from the repository.

Planner loads and verifies the 2.27 firmware but it does not connect to the APM2.  I have used Putty and it does reset the APM2 on connect and I do see packets with mixed binary/alpha content (presumably MavLink).

When watching the APM2 board, it does not appear to come out of reset after Planner opens the port.  Since the reset step works correctly with Putty, it seems as though Planner is holding the reset line for some reason.

Should I add this as an "issue" ?


Views: 2087

Reply to This

Replies to This Discussion

I am having similar problems. Every since I got my APM 2.0 board, connecting has been very hit and miss. I resorted to usng my Xbees by default. However, since updating Mission Planner to 1.1.14, I do not seem to be able to connect, either through the USB or the Xbees - it just times out, even when I have a GPS lock. I have checked the baud rates for both the USB and Xbees. I have used the Arduino MEGA 2560.inf driver. At times it seemed to freeze my mouse. I have now set it to use GDI+ which seems better in that I can move my mouse more easily, but clicking is slow to react. 

Update - did a re-install of the firmware from 1.1.14 and it seems to connect using the USB ok now.

Another update - now my Xbees don't connect, great!

Thanks for your updates, I'm going to look for an AMP2 blog since this may or may not be a Planner problem.

Just tried it again and here's what I see happening-

1) Insert USB to APM2 board. It powers up, the red, yellow and blue status leds are active, the GPS led is flashing and there is TX activity on the usb port at about 2hz.

2) Click Connect from Planner. All APM2 leds (except GPS) go out as though it is in reset.

3) The Planner connect progress box appears and counts down to "0".  I see periodic USB RX activity but no other leds are active on the AMP2 board.

4) The Planner connect progress times out and at that point there is USB RX and TX activity.  Planner throws an exception about not seeing heartbeats.

5) When I close the exception message box, APM2 red, yellow and blue status leds come alive and there is again USB TX activity.  APM2 appears to start up normally.

6) Open the port with Putty terminal emulator.  APM2 resets, I see the startup header and then mixed binary/ascii messages about initialization.

As a cross-check, I just used Planner 1.1.14 to connect to an installed APM1 (red) board in a flying plane.  It came up and connected promptly as it always has in the past.

The problem appears to be on the APM2 (purple board) side so I'm going to post a message there, too.

Another update - I now cannot connect using USB on either my desktop or my laptop, but I have just managed to connect using my laptop and Xbees, which did not work last night. Does this sort of behaviour make any sense to any one in the APM 2.0 or Mission Planner dev teams? I would hate to think that I have a bad APM 2.0 board as suggested by the other thread on this subject after the fun I have had with a bad APM 1 board.

Andy, try the latest planner, i modified how the reset works. 1.1.15

Hi Michael, would love to test this. What is the time lag between your publishing an updated version and it being available? Have tried both the Check For Updates button in 1.1.14 and the normal download site, http://code.google.com/p/ardupilot-mega/downloads/list.

I get the same behavior with my APM2 board.  When I connect to the board via USB, it resets, the ABC lights come on and there is some TX activity.  Then A(red) turns off and stays off.  When I look at the MissionPlanner console, I see the following:

124 got param 163 of 172 name: RC6_ANGLE_MIN
Init Gyro145 got param 164 of 172 name: RC5_ANGLE_MIN
MAVLink readpacket read error: The operation has timed out.
Mavlink Bad Packet (crc fail) len 0 crc 65535 pkno 0

I am able to connect to the APM in MissionPlanner using the terminal.  In terminal, I run the IMU test and get the response InitGyro and then nothing. 

One final note.  If I play around in terminal and then run the IMU test it works.  Once this works, I can connect normally until I power down the APM.



I think I get this. I am still using 1.1.14, but managed to connect my APM using both my Xbees and the USB on my laptop. This is what I did - while nothing is connected, I opened Mission Planner, went to Configuration, clicked on the Planner tab, and unticked the option APM Reset Reset the APM on USB Connect. I then closed down Mission Planner, connected my drone by USB, restarted Mission Planner then it all connected perfectly. Just redone that on my desktop, and again, it connected fine this time. Hope this helps!

Michael,  Just tried an automatic update from 1.1.14 and nothing came across.  Also looked in the repository but no posted .15 file.  Can you tell me where to find the newer version?

Bill --  Michael (Planner developer) has a newer version that handles the reset differently.  I'll post the results as soon as I get access and can test it on mine.

Sure, am also waiting for 1.1.15, but in the meantime, unticking the  APM Reset option at least allows you to connect the board to the Mission Planner - always reassuring to see gyros actually working in the HUD!

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service